Page 1 of 3 123 LastLast
Results 1 to 25 of 54
Like Tree1Likes
  1. pdxrunr's Avatar
    Member

    Posts
    16 Posts
       #1  
    So I have a brand new HTC 8X on Verizon. If I enable Internet Sharing, I can connect and use the connection just fine with an Ipad, Windows 7 PC, other phones, pretty much every device I have tried. The exception is my Dell Latitude E4310 with Windows 8 Pro loaded on it. I can connect to the wifi just fine, I get an IP and a gateway address. I just can't seem to get traffic to route through the device. Same PC with another hard drive with Windows 7 works just fine. I'm an IT Pro and have tried changing just about every network setting you can think of and I'm stumped. Never seen anything like it. The PC has a Broadcom 802.11n Network Adapter and I'm using the driver that Win 8 installed. Dell doesn't offer any Windows 8 drivers and the Windows 7 driver they offer doesn't load in Win 8. Anyone have any thoughts on something I can try? One last interesting tidbit...same laptop....it will tether just fine to my old HTC HD7! So it appears some spec has changed in Windows Phone 8 with regards to Internet Sharing, but of course there are no "settings" on the phone that I can see that we are allowed to change.

    Thanks!

    L
    leowagner likes this.
  2. #2  
    When was the last time the Win8 PC was restarted? I know... silly question - but I had the exact same problem yesterday, and I'm an IT pro as well, and it drove me nuts for an hour. But when I last-ditch-effort tried a reboot (what is it we tell our users? Did you try rebooting?), it did an install of updates, and then all worked well. The kicker was that I had already done a shutdown and a startup, but the updates didn't install then. I had to do a "restart" for the updates to install. I think it was the updates keeping it from connecting, myself.
    - Rich


    WPCentral.com | WPCentral Store | Mobile Nations Forum Rules

    Join Bing Rewards and get rewarded - and get me a few bonus points!
  3. pdxrunr's Avatar
    Member

    Posts
    16 Posts
       #3  
    Thanks for the reply Rich. Yeah, multiple reboots, all updates installed, etc. It has to be a check box some place, or a setting on the Windows 8 machine, but the strange thing is, the Win 8 machine has no trouble connecting to any other wifi access point. Even Starbucks, public ones, etc...all work fine. And it routes traffic through my Windows Phone 7 HD7 phone..that is the really odd part.

    Louis
  4. #4  
    Hmmm.... I assume you've tried deleting the virtual wifi adapter and virtual switch that the phone puts in there?
    - Rich


    WPCentral.com | WPCentral Store | Mobile Nations Forum Rules

    Join Bing Rewards and get rewarded - and get me a few bonus points!
  5. pdxrunr's Avatar
    Member

    Posts
    16 Posts
       #5  
    Not sure if I understand what you mean. On the phone? On my Win 8 machine, the phone added nothing with regards to adapters or switches. I only have my LAN card and my Wifi card in Network Connections.
  6. pdxrunr's Avatar
    Member

    Posts
    16 Posts
       #6  
    I was just able to try this with another Dell Latitude with Windows 8...same result! IP, but won't route traffic. So it isn't just my Latitude.

    L
  7. Daniel Ratcliffe's Avatar
    Retired Moderator

    Posts
    2,775 Posts
    Global Posts
    4,429 Global Posts
    #7  
    I'm hoping it'll run fine on my MacBook Pro running Windows 8... When I get my 8X or Lumia 820...

    "Fortune cookie said: 'Outlook not so good'. I said: 'Sure, but Microsoft ships it anyway'."
  8. GreenScrew's Avatar
    Member

    Posts
    190 Posts
    #8  
    This doesn't really help you directly, but to test out your scenario I just tethered my HP EliteBook running Windows 8 Enterprise to my Verizon HTC 8x. Share everything plan. Worked perfectly fine, no issues at all. So at least you know it can and should work! Windows 8 even notified me that I was connected over a metered connection and suggested to disable skydrive sync to save data!
  9. #9  
    Quote Originally Posted by pdxrunr View Post
    Not sure if I understand what you mean. On the phone? On my Win 8 machine, the phone added nothing with regards to adapters or switches. I only have my LAN card and my Wifi card in Network Connections.
    Ok... I guess the virtual adapter and virtual switch on my system (added to Hyper-V) must have been added by the Phone SDK. Never mind - I was guessing the phone added them when I tethered, because when I am tethering, that's what connects to the phone. Weird...
    - Rich


    WPCentral.com | WPCentral Store | Mobile Nations Forum Rules

    Join Bing Rewards and get rewarded - and get me a few bonus points!
  10. dknoodle's Avatar
    Member

    Posts
    1 Posts
    #10  
    I just got off the phone with AT&T support. It looks like this is an "unconfirmed" Windows 8 issue. I have a Mac Air (bootcamp) running Windows 8 (dual boot, not a virtual). I'm able to both wifi and USB tether the Win 8 laptop to my iPhone (4S) with no problems. When I try to connect the Win 8 laptop to my Windows Phone 8 (Nokia Lumia 920) via wifi (I don't think there is a USB option?) the laptop connects just fine and gets an IP address but I can't even ping the Gateway IP so no data.

    Just as a sanity check I disabled the Cell connection on my iPad and tethered it to the Lumia 920 and got data with no problems (super fast by the way). I did the same thing with my iPhone and it worked just fine. It appears to ONLY be an issue when tethering a Windows 8 OS to a Windows 8 Phone!!!!! <insert anti Microsoft comment here>

    I've been pulling my hair out and searching all over but I can't seem to find any solutions anywhere. The AT&T Enterprise rep did say they have a LOT of tethering issues being reported using Win 8 desktop/laptop's.
  11. pdxrunr's Avatar
    Member

    Posts
    16 Posts
       #11  
    Thanks for the info. Good to know I'm not crazy! :) Hard to believe MS didn't test this internally. If GreenScrew really was able to route traffic and not just "connect" to it, then it still seems to be related to particular drivers or network cards in the Win 8 machines.

    L
  12. #12  
    I'm tethering to my 822 right now, on an HP (first and last HP I'll ever own) dv6t SE with Win8 Pro x64 on it. Other than the problem I mentioned above, I haven't had any problems since, so it's not a system-wide Verizon problem, and not a problem that applies to all WP8-W8 scenarios. :/
    - Rich


    WPCentral.com | WPCentral Store | Mobile Nations Forum Rules

    Join Bing Rewards and get rewarded - and get me a few bonus points!
  13. pdxrunr's Avatar
    Member

    Posts
    16 Posts
       #13  
    Thanks for the update Rich. I have talked to other 8X owners on Verizon who can't tether to their Win 8 machines. Still not clear on where the issue is, but there does seem to be a problem someplace. I just wish I could fix it! :)

    Louis
  14. Luke Kailburn's Avatar
    Member

    Posts
    81 Posts
    #14  
    damnit.

    add me to the pile. windows 8 laptop connects to the wifi just fine, gets all IP info. but no traffic routes. Can connect my old 4s(with no cell service) to the wifi hotspot just fine and gets fantastic bandwidth. This SUCKS to say the least.

    -Luke
  15. GreenScrew's Avatar
    Member

    Posts
    190 Posts
    #15  
    I'm one that has been tethering just fine (8x on Verizon) but curious if you're all using the built-in security (anti-virus, firewall, etc) and whether you've tried disabling (temp) the firewall? I'm sure whatever the issue you're all having can be solved. My first guess would be firewall blocking.
  16. jaimeastin's Avatar
    Member

    Posts
    312 Posts
    Global Posts
    328 Global Posts
    #16  
    When you connect for the first time, did you select public or private connection? That shouldn't make a big deal...

    See if your windows 8 machine is recognizing the 8X's connections a metered connection. If it does, make sure it is set to use it.

    Ping another computers address that is connected to you phone. Ping and do a trace route to google.com.

    My Lumia 920 by default uses WPA2-Personal AES. Maybe your drivers can't use that security with your computer.

    Finally I have noticed WiFi does not work well I am on the phone. I am sure it is due to att turning off 4g when the phone is on a call.

    Just a few options to check. I haven't had one issue with my windows 8 laptops, surface, iPad, widows 7, or any device I connected to it... I am using a Lumia 920 (previously 900) and never had an issue with either of them...
    Last edited by jaimeastin; 12-08-2012 at 11:31 AM.
  17. futurix's Avatar
    Member

    Posts
    63 Posts
    #17  
    1. Check 'Action Centre' in 'Control Panel' if it tells you to finish installation of any drivers. If it is - do it and reboot.
    2. Make you that you have download of drivers enabled in Control Panel -> System -> Advanced system settings -> Hardware -> Device Installation Settings

    Also make sure you actually reboot and not shut down your PC and turn it back on.
  18. #18  
    I, too, have it working fine. I'm curious, since carrier has been brought up... I see at least one more on Verizon has it working, I'm on Verizon and have it working. What carriers are those of you on that do not have it working?
    - Rich


    WPCentral.com | WPCentral Store | Mobile Nations Forum Rules

    Join Bing Rewards and get rewarded - and get me a few bonus points!
  19. Ant177's Avatar
    Member

    Posts
    5 Posts
    #19  
    I've been experiencing this as well with my HTC 8X (SIM-free) in the UK. Works okay on my iPad and MacBook Air (with the odd glitches, it isn't as reliable as the iPhone 4 I replaced). On my Windows 8 laptop, nothing. IP and gateway assigned correctly but no connection to the outside world, DNS or ping so obviously an issue routing.
  20. Ant177's Avatar
    Member

    Posts
    5 Posts
    #20  
    Quote Originally Posted by futurix View Post
    1. Check 'Action Centre' in 'Control Panel' if it tells you to finish installation of any drivers. If it is - do it and reboot.
    2. Make you that you have download of drivers enabled in Control Panel -> System -> Advanced system settings -> Hardware -> Device Installation Settings

    Also make sure you actually reboot and not shut down your PC and turn it back on.
    Driver issues wouldn't prevent an individual network routing.
  21. AaronMoorcroft's Avatar
    Member

    Posts
    3 Posts
    Global Posts
    125 Global Posts
    #21  
    FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED - FIXED


    Hi Guys so after reading the first post I was starting to question if I had wrote it myself, I am a computer engineer, exactly the same issue, been though every option I could think of to fix it, in all honesty I probably went over the top right from the off. The joys of being an IT geek huh.

    Right good news for you all, I fixed it...........

    I hear you asking how ????

    hehe well its simple, after a lot of digging and reading up it turns out that Windows 8 wifi drivers are normally installed on the Windows 8 OS and basically that's the issue, all you need to do is download the correct driver for your wifi device and install, you may be able to roll back your driver if not just upgrade to a non Microsoft version.

    and well that's it, that's how I fixed my its not working without issue, enjoy guys...

    regards

    Aaron
    Thanked by:
  22. pdxrunr's Avatar
    Member

    Posts
    16 Posts
       #22  
    This is NOT a carrier issue. I have tried an 8X on tmobile and verizon with my Dell Latitude E4310 and can't tether using either phone. If it's a driver issue, which I'm not convinced it is, I can't install any other driver other than the one microsoft installed with Windows 8 because it's dated 3/2012 and Dell hasn't released a specific driver for this machine for Win 8 and they probably won't since it's a 3 year old machine. Guess my only option is a new PC.

    L
  23. AaronMoorcroft's Avatar
    Member

    Posts
    3 Posts
    Global Posts
    125 Global Posts
    #23  
    You should be able to use a driver for windows 7 without issue.
  24. realityeye's Avatar
    Member

    Posts
    25 Posts
    #24  
    I had trouble connecting my MacBook air (running windows 8) to my 920 wifi until I did the following:

    1. Turn on Internet sharing on the phone
    2. On pc connect to the wifi network (it will say limited connection)
    3. Right click on the connection to view connection properties and select the security tab. Click on advanced and then tick the checkbox for "Enable Federal Information Processing Standards (FIPS) compliance for this network.

    I read this somewhere and it worked for me after days of trying.
    Thanked by:
  25. Ant177's Avatar
    Member

    Posts
    5 Posts
    #25  
    Fortunately it isn't a driver issue at all so you won't be needing that new PC. Why people think that reinstalling drivers will help connect to certain networks I don't know.
    It would appear that the suggestion to enable FIPS helps, my laptop has now connected successfully to my HTC 8X, I'll keep an eye on whether the connection is stable or the issue crops up again. Interesting why this is required though.
Page 1 of 3 123 LastLast

Similar Threads

  1. Windows Phone and a car head unit that play nice
    By Welve in forum Windows Phone 7
    Replies: 1
    Last Post: 03-31-2012, 11:00 PM
  2. Windows Phone and the US a bad match?
    By theefman in forum Windows Phone 7
    Replies: 15
    Last Post: 03-08-2012, 03:31 PM
  3. Replies: 6
    Last Post: 02-03-2012, 06:38 PM
  4. Replies: 8
    Last Post: 12-07-2011, 11:56 AM
  5. A missed Opportunity. Windows Phone and LTE
    By jdevenberg in forum Windows Phone 7
    Replies: 10
    Last Post: 11-07-2011, 08:35 PM

Posting Permissions

B