Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
Like Tree1Likes
  • 1 Post By zedmartinez
  1. zedmartinez's Avatar
    Member

    Posts
    31 Posts
       #1  
    It turns out WP8 only seems to like ID3 v2.3 tags, not the more modern 2.4 ones. If you've been having random albums that don't have their art sync over, or problems with things like "Various Artists" collections where individual tracks don't show their unique artists like they used to on Zune, this is probably the cause. Checking is easy from iTunes, just inspect the track and look under the summary tab. Fixing is also easy in iTunes, since you can just right- or command-click a track and choose to convert ID3 tag. Fixed all my problems when moving music over from OSX using the connector tool last night, all my soundtracks and stuff come through perfectly now. Only thing I still don't see support for that Zune did is multiple artists per track, noting such will just yield a "Various Artists" entry on the phone.

    Hadn't seen this anywhere, and I spent a very frustrated couple of hours last night figuring out why some of my soundtracks worked and some didn't while I was playing with ne0cr0n's mpatool to fix the gray screens from missing artist pictures. So, thought I'd share here in case anyone else was hitting similar problems.
  2. marcinaldo's Avatar
    Member

    Posts
    10 Posts
    #2  
    Are covers displaying correctly for you now?
  3. zedmartinez's Avatar
    Member

    Posts
    31 Posts
       #3  
    Yup! All covers are showing as they should, and all various artists albums show Various Artists as the album artist, and the actual track artist for each track inside the album, just like I'd expect. It was weird, because most of my stuff synced fine from the get-go, just a handful of things were screwing up and it took forever to figure out why.
    Thanked by:
    marcinaldo likes this.
  4. Guzzler3's Avatar
    Member

    Posts
    811 Posts
    #4  
    I haven't had an issue with my metadata on my MP3's, but I use a program called Mp3tag for all my metadata editing on my music. Using it's defaults, my phone has picked up all the information just fine. The biggest issue I've had, was that the "Album Artist" field is what Microsoft likes to use. Every other music player works off of the "Artist" field.
    Guz

    [S]iPhone 3G[/S]
    [s]Blackberry 6320[/s]
    Lumia 810
  5. zedmartinez's Avatar
    Member

    Posts
    31 Posts
       #5  
    The two fields do different things, and most players will use both if they're filled out correctly. I keep mentioning soundtracks, because sound tracks and compilations are where this comes into effect. Say I have an album with 12 different bands. The Zune way to mark this, so it showed up as one album, was to set the album artist to "Various Artists" but the track artist to the correct artist. If you did this, the album would show up as one album, and each song in it would be properly credited. The, the individual tracks would also show up under the artist themselves, under the Songs list. WP8 continues to respect this, but only with ID3 v2.3. If you use 2.4, you will get the phenomenon you're describing--where only the album artist is recognized.
  6. luk3ja's Avatar
    Member

    Posts
    486 Posts
    #6  
    Found an amazing windows phone app!!! It downloads album art and artist images too!!!

    MPAtool | Windows Phone Apps+Games Store (United Kingdom)

Similar Threads

  1. Having trouble with BING on FIREFOX.
    By btbam91 in forum The "Off Topic" Lounge
    Replies: 2
    Last Post: 04-19-2012, 02:19 PM
  2. Replies: 0
    Last Post: 10-05-2011, 11:35 PM
  3. People have to be empowered to know what to want.
    By Techblogger in forum Windows Phone 7
    Replies: 3
    Last Post: 08-30-2011, 02:32 PM
  4. Any 1.4 Owners Having Trouble Syncing After NoDo?
    By hammerhand in forum Samsung Focus
    Replies: 2
    Last Post: 08-10-2011, 01:34 AM
  5. Update for people using focus without a cellular service?
    By johnpaul12 in forum Windows Phone 7
    Replies: 2
    Last Post: 03-28-2011, 09:54 PM

Posting Permissions