Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
  1. uktivo's Avatar
    Member

    Posts
    121 Posts
    Global Posts
    434 Global Posts
       #1  
    Hi all.

    I received today my 920 unlocked and sim free unit from clove.

    Unfortunately, if I press the camera button it opens up an agreement accept box but then it just disappears. If I try to open it from the camera app nothing happens. Any ideas? Is this a bust unit?
    Any help welcome.

    Sent from my HTC One X using Tapatalk 2
  2. #2  
    So you've accepted the agreement or the box disappeared before you could? Have you tried restarting the phone and tried again? What exactly happens when you open the camera, via the app list and button on the side of the device? If all else fails, have you tried hard resetting the phone to its factory defaults?

    Should that fail as well, I'd recommend giving Clove a ring, I believe they'll have a 920 ready to replace a faulty device.

    Richard Edmonds
    UK Editor - Windows Phone Central
    Email: rich@wpcentral.com
    Twitter: @RichEdmonds
    Socl: RichEdmonds
    Thanked by:
    uktivo 
  3. uktivo's Avatar
    Member

    Posts
    121 Posts
    Global Posts
    434 Global Posts
       #3  
    Not done a hard reset yet. Will try in the morning.

    If I press either the camera button or the app icon, the camera will not open at all.

    Will try the hard reset and advise back.. oh.. how does one do a hard reset?

    Thanks

    Sent from my HTC One X using Tapatalk 2
  4. uktivo's Avatar
    Member

    Posts
    121 Posts
    Global Posts
    434 Global Posts
       #4  
    Nope camera is 100% snookered. Did a factory reset this morning and still exactly the same. Unfortunately, clove are now sold out.. suppose that means a full refund and wait for anyone else to get unlocked stock...



    Sent from my HTC One X using Tapatalk 2
  5. uktivo's Avatar
    Member

    Posts
    121 Posts
    Global Posts
    434 Global Posts
       #5  
    Ok an update. I resolved myself that the camera was bust.. I contacted Clove this morning, after a short conversation and persuasion i finally managed to get a replacement. Then after showing my wife a short 2min video, the phone completely locked up. Absolutely nothing i did would bring it back to life. I then plugged it into a wall charger. After about 2mins it rebooted. Basically the phone had been charged via wall plug overnight. It had been off charge for 1 hour, very little use. When the phone rebooted it was down to 28% battery😨. BUT the good news is the camera is now working..

    Now.. I have a dilemma. In order to get a replacement handset from clove they have to test the unit. This meant me being without a business phone whilst it was away. I couldn't be in this situation so i offered to purchase the replacement phone at full price. Once it arrived i would return this faulty unit. Now where do i stand legally? Its clear there is some sort of issue with this handset.

    Has anyone else had issues with the camera?

    Is there a Nokia helpline i can talk with?

    Thanks in advance.
  6. uktivo's Avatar
    Member

    Posts
    121 Posts
    Global Posts
    434 Global Posts
       #6  
    Update.
    Since the original handset reset itself its been fantastic. Battery life is great and all works well. I assume it was a sw glitch.. Anyway. Its a keeper and now in going to sell the new handset that arrived Friday..
  7. #7  
    Glad to hear that it's resolved! There seems to be some teething issues with the Lumia 920 (some of the batch anyway). Will you be returning the new unit back to Clove for a refund (as it wont be unboxed) or are you selling it? If you start to struggle with battery life, be sure to turn off NFC when not using it - it seems to have an affect.

    (sorry for not replying in this thread earlier)

    Richard Edmonds
    UK Editor - Windows Phone Central
    Email: rich@wpcentral.com
    Twitter: @RichEdmonds
    Socl: RichEdmonds
  8. uktivo's Avatar
    Member

    Posts
    121 Posts
    Global Posts
    434 Global Posts
       #8  
    Hi.
    I've returned the second unit to Clove...but on Friday the unit that had the bad camera froze and died. So this unit has also been returned. I will look at wp maybe in 6 or so months time.. let the dust settle...

    Sent from my HTC One X using Tapatalk 2

Posting Permissions