Results 1 to 7 of 7
  1. AlexanderJJJ's Avatar
    Member

    Posts
    132 Posts
    Global Posts
    206 Global Posts
       #1  
    I've had both the Lumia 900 and the HTC Titan II and it seems like some of the time when I put it on the AC charger it won't fully to 100%. Is this a problem with the 8112 OS version? Because my Samsung Focus Flash or Focus S have never had this problem. Thanks.
  2. mparker's Avatar
    Member

    Posts
    298 Posts
    Global Posts
    308 Global Posts
    #2  
    Does it show 98% or so when you take it off the charger? If so then this is the battery-management system doing it. It's more like the battery-management code in a laptop, where once it's charged it runs off the battery until it's depleted a few percent then charges back up again. This is better on the battery than keeping it topped all the way up all the time, and neither of the 900 or T2 have replaceable batteries...
  3. jimski's Avatar
    Member

    Posts
    2,254 Posts
    Global Posts
    2,259 Global Posts
    #3  
    Quote Originally Posted by mparker View Post
    Does it show 98% or so when you take it off the charger? If so then this is the battery-management system doing it. It's more like the battery-management code in a laptop, where once it's charged it runs off the battery until it's depleted a few percent then charges back up again. This is better on the battery than keeping it topped all the way up all the time, and neither of the 900 or T2 have replaceable batteries...
    Exactly. I have the homebrew Battery Meter app and reviewing an overnight charge, you can see the the battery tops at 100% then trickles down to 98-99%, then back to 100% ten minutes later. Did this the whole time it was on the charger. Very normal, and better for the battery.

    Sent from my Lumia 900 using Board Express
    Nokia Lumia 900 - OS: 7.10.8112.7 - Firmware: 2175.1002.8112.12084
    HTC Surround - OS: 7.10.8107.79 - Firmware: 2250.21.40500.502
  4. drdumasss's Avatar
    Member

    Posts
    1 Posts
    #4  
    Hi i have a Htc Titan 2 and I recently have been experiencing problems with charging. The phone only charges to about 65% even if i leave it on the whole night. anyone experience this before?? the light never turns to green as indication for a full charge. it just stays red. even hours of charging like overnight. One thing though is that my wife was using this phone overseas in europe for a couple of months and used an lg charger from over there that had the same micro usb plug. You guys think she could of damaged the battery with that other charger, or could it be any software related issues? Any feedback would be appreciated.
    Thanks.
    Tony
  5. doconco's Avatar
    Member

    Posts
    1 Posts
    #5  
    I have the same problem.
    Did you find solution?
    Thanks
  6. ratsttam's Avatar
    Member

    Posts
    187 Posts
    Global Posts
    1,096 Global Posts
    #6  
    Quote Originally Posted by doconco View Post
    I have the same problem.
    Did you find solution?
    Thanks
    The solution was stated above, several times. It's NORMAL for the battery to be used 1-2%, then charge back up. It helps with the overall lifespan of the battery. And really, does starting the day off at 98% instead of 100% really make a difference.
  7. Richard Marx's Avatar
    Member

    Posts
    1 Posts
    #7  
    Only charging to 65% and the red light never changing to green is a different problem than the battery charging manager cycle. A bad charger, charger cord, or bad battery are the usual culprits.

Posting Permissions

B