Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. sandmanfvr's Avatar
    Member

    Posts
    129 Posts
    Global Posts
    984 Global Posts
       #1  
    Ok I have mentioned this for a couple months, as my windows phone rocks and I LOVE Mango, but when I am connect to wifi my phone will not run well. Well I have this posted on the Microsoft forums and somebody mentioned to check the ip settings on the router. I went to my attached devices and watched when my windows phone attached to the router, WHOA. I saw the same mac address and THREE, yes three, ip addresses. This is a bug in windows phone as my wife and I have an ipad, playbook, ps3, android phone and I have had blackberries on it work fine with 1 ip address to 1 mac address. SO, I put in an mac address reservation to 1 static ip address, rebooted router and bam my windows phone is usable. I have weak cell signal and when we connect to the wifi, smart phones and apps run great, now my windows phone is rocking. So posting this for all, on all types of windows phone (seen this xda forums and happens to other people) if you have issues with slowness, check your router attached devices to see if your phone grabs more than 1 ip address. Enjoy.
  2. HeyCori's Avatar
    Mod Emeritus

    Posts
    5,128 Posts
    Global Posts
    5,153 Global Posts
    #2  
    I wonder if this is an issue with the Arrive or Windows Phone 7?
  3. TheWeeBear's Avatar
    Retired Moderator

    Posts
    5,293 Posts
    Global Posts
    5,295 Global Posts
    #3  
    The multiple IP/MAC address issue has never ever happened on my Omnia, so it must be a problem specific to certain handsets.

    .........HANDSET: Nokia Lumia 920
    .........COUNTRY: Scotland UK
    .........NETWORK: 3 UK
  4. sandmanfvr's Avatar
    Member

    Posts
    129 Posts
    Global Posts
    984 Global Posts
       #4  
    It might be. I don't know if it is wp7 or the wireless chipset in the arrive, but it done it and the second time it grabbed FOUR ips. Now with the mac address programmed in the router with a specified ip, it works fine.

    Thinking this through, I AM running RTM mango(same build as everybody else), so it may not be the software and the hardware in the arrive.
    Last edited by sandmanfvr; 09-10-2011 at 02:58 PM.
  5. TheWeeBear's Avatar
    Retired Moderator

    Posts
    5,293 Posts
    Global Posts
    5,295 Global Posts
    #5  
    Quote Originally Posted by sandmanfvr View Post
    It might be. I don't know if it is wp7 or the wireless chipset in the arrive, but it done it and the second time it grabbed FOUR ips. Now with the mac address programmed in the router with a specified ip, it works fine.
    That's good, bit of a rigmarole, but at least you got to the bottom of it. :)

    .........HANDSET: Nokia Lumia 920
    .........COUNTRY: Scotland UK
    .........NETWORK: 3 UK

Posting Permissions