Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!

View Poll Results: Nokia Lumia 920 - 1308 Firmware is a failure or success

Voters
60. You may not vote on this poll
  • Failure

    12 20.00%
  • Success

    40 66.67%
  • Was not required at this Moment

    8 13.33%
Page 1 of 4 1234 LastLast
Results 1 to 25 of 91
Like Tree4Likes
  1.    #1  
    Hi Guys,
    I just wanted to clear out some confusions on the new firmware for our Nokia Lumia 920 for India Users. Last night I received this update OTA and I upgraded the firmware.
    Since then I have the below mentioned findings:-

    1. I can use the 3G/2G connection at the same speeds as I used to get before upgrade.
    2. Screen brightness is perfectly fine. Not much of a difference to me.
    3. Storage Check works just fine and couldn't find any "fuss" about it.
    4. Battery is something which I need to check in coming days but as of now it seems to be fine. "Make sure you disable GPS, WIFI" when they are not in use to save those extra "mah" in your phone battery.

    Rest all is fine, no problems faced by me since the upgrade. Incase you faced any issues (Only India Lumia 920 Users), then let me know we can try to get it fixed.

    Thanks for your time in reading my post ! Cheers !!!

    --------------------------------------------------------------------------------------------------------------------------------
    Hi Guys, As on 12-April @ 19:00 PM
    I just received the Display+touch update prompt on the Windows App store ....Post updation, I restarted my phone... went into Settings > Display+Touch.... Couldn't find the Lumia Color Profile settings or any new settings...
    Last edited by Sunny Bhatnagar; 04-12-2013 at 08:40 AM. Reason: Just received Display+Touch Update from Nokia
    Thanked by:
  2. flair77's Avatar
    Member

    Posts
    35 Posts
    #2  
    So is the 1308 available for download OTA? Been waiting since ages, I live in Kuwait but have my location set to the US. Will go home and check on wifi :)
  3. nileshdd's Avatar
    Member

    Posts
    76 Posts
    #3  
    That's great news! Please keep us posted with your experience on the firmware..If the overall reports are positive, I'll go ahead with it.:)

    Thanks
    Nilesh
  4. hipporama's Avatar
    Member

    Posts
    282 Posts
    #4  
    Updated today morning. So far no problems at all. I have noticed that the vibration is much much better now.. no more rattling sound. Also I'm getting H+ now instead of just H before. Photos look slightly better. So far so good :)
    Thanked by:
  5.    #5  
    Quote Originally Posted by flair77 View Post
    So is the 1308 available for download OTA? Been waiting since ages, I live in Kuwait but have my location set to the US. Will go home and check on wifi :)
    not sure about Kuwait... set the location to India and see if you get it over wifi.. so far it works like a charm....
  6.    #6  
    Quote Originally Posted by hipporama View Post
    Updated today morning. So far no problems at all. I have noticed that the vibration is much much better now.. no more rattling sound. Also I'm getting H+ now instead of just H before. Photos look slightly better. So far so good :)
    its all down to the signal for that area..



    H+ is 3G.

    H+ is in the the highest mode group of transfer the SII supports.

    It goes:

    2G:
    GPRS (G)
    EDGE (E)

    3G:
    UMTS (3G)
    HSDPA (H)
    HSPA+ (H+)
    solution2u likes this.
  7.    #7  
    Quote Originally Posted by nileshdd View Post
    That's great news! Please keep us posted with your experience on the firmware..If the overall reports are positive, I'll go ahead with it.:)

    Thanks
    Nilesh
    I think its safe to go ahead... battery life is also fine per me for now.. not other issues reported... H+ aka 3G is a little bit more speedy now..
  8. Elton Jothi's Avatar
    Member

    Posts
    146 Posts
    #8  
    i was having this problem before the firmware update lumia 920 touch not responding properly, but now its fixed and am very happy about this issue being fixed...
    also i use to get 3g @ my house now i get H+
    I dont see much of a difference in the photos.
    I think there is a battery issue, its was better before... anyways will check again and confirm.
    Thanked by:
  9.    #9  
    Quote Originally Posted by Elton Jothi View Post
    i was having this problem before the firmware update lumia 920 touch not responding properly, but now its fixed and am very happy about this issue being fixed...
    also i use to get 3g @ my house now i get H+
    I dont see much of a difference in the photos.
    I think there is a battery issue, its was better before... anyways will check again and confirm.
    Thanks man ! Hope everyone keeps updating about there experience so that we all know about any hidden bugs with the firmware... :)
  10. #10  
    Updated just now. everything seams fine. only H+ is the newthing instead of H.
    Thanked by:
  11. nikhilr51's Avatar
    Member

    Posts
    331 Posts
    Global Posts
    334 Global Posts
    #11  
    All the connectivity problems with 1308 are MAINLY for americans (hence they stopped the rollout of the update there only).
    Here in australia everything is much better since 1308, especially battery!
  12.    #12  
    Quote Originally Posted by nikhilr51 View Post
    All the connectivity problems with 1308 are MAINLY for americans (hence they stopped the rollout of the update there only).
    Here in australia everything is much better since 1308, especially battery!
    Thanks for the confirmation Man ! Much appreciated !
  13. avi_920's Avatar
    Member

    Posts
    8 Posts
    #13  
    Guys, Please HELP!

    Just updated to the new firm ware. Nokia Lumia 920, to firmware 1308.0001

    But, when I select the 'storage check' , the new screen opens, but it just keeps on loading!

    The overview is keeps on loading, the apps and media files' storage is showing --

    And, when, i move the window to details, even then it keeps on loading. Nothing is showing up. All the storage data are just blank, and the typical loading symbol at the top keeps on loading...

    Attaching a screen shot:

    wp_ss_20130409_0002.png wp_ss_20130409_0003.png



    PLEASE help!

    What to do!?
  14. Sanjay Chandra's Avatar
    Member

    Posts
    486 Posts
    Global Posts
    783 Global Posts
    #14  
    Quote Originally Posted by avi_920 View Post
    Guys, Please HELP!

    Just updated to the new firm ware. Nokia Lumia 920, to firmware 1308.0001

    But, when I select the 'storage check' , the new screen opens, but it just keeps on loading!

    The overview is keeps on loading, the apps and media files' storage is showing --

    And, when, i move the window to details, even then it keeps on loading. Nothing is showing up. All the storage data are just blank, and the typical loading symbol at the top keeps on loading...

    Attaching a screen shot:

    Click image for larger version. 

Name:	wp_ss_20130409_0002.png 
Views:	9 
Size:	109.6 KB 
ID:	31969 Click image for larger version. 

Name:	wp_ss_20130409_0003.png 
Views:	11 
Size:	99.6 KB 
ID:	31968



    PLEASE help!

    What to do!?
    Well , I have 820 , loads the ring 3 times and shows things fine.

    Tried restarting the device ?
  15.    #15  
    Quote Originally Posted by avi_920 View Post
    Guys, Please HELP!

    Just updated to the new firm ware. Nokia Lumia 920, to firmware 1308.0001

    But, when I select the 'storage check' , the new screen opens, but it just keeps on loading!

    The overview is keeps on loading, the apps and media files' storage is showing --

    And, when, i move the window to details, even then it keeps on loading. Nothing is showing up. All the storage data are just blank, and the typical loading symbol at the top keeps on loading...

    Attaching a screen shot:

    Click image for larger version. 

Name:	wp_ss_20130409_0002.png 
Views:	9 
Size:	109.6 KB 
ID:	31969 Click image for larger version. 

Name:	wp_ss_20130409_0003.png 
Views:	11 
Size:	99.6 KB 
ID:	31968



    PLEASE help!

    What to do!?
    Try the following:-
    1. Power off the mobile and keep it powered off for 10 mins.
    2. Secondly, try resetting the phone from Settings > Reset Your Phone --- "You will loose all your data so make sure you backup all you files, photos, sms etc."

    Post us the results if it works...
  16. garfieldm89's Avatar
    Member

    Posts
    84 Posts
    #16  
    Sunny, u facing any network issues or something like AT&T ppl were reporting?

    And Do i have backup anything before the update?
  17. avi_920's Avatar
    Member

    Posts
    8 Posts
    #17  
    Quote Originally Posted by Sunny Bhatnagar View Post
    Try the following:-
    1. Power off the mobile and keep it powered off for 10 mins.
    2. Secondly, try resetting the phone from Settings > Reset Your Phone --- "You will loose all your data so make sure you backup all you files, photos, sms etc."

    Post us the results if it works...
    I tried powering off for sometime & then turning on back after a while. Still didn't work.

    Any other option other than reseting? Cause I got some good apps from the store. I don't want to lose them.
  18. garfieldm89's Avatar
    Member

    Posts
    84 Posts
    #18  
    u can backup all ur settings and do a reset. After that all your apps will be reinstalled automatically. Make sure you have full battery with wifi
  19. ktl88's Avatar
    Member

    Posts
    161 Posts
    #19  
    Quote Originally Posted by avi_920 View Post
    I tried powering off for sometime & then turning on back after a while. Still didn't work.

    Any other option other than reseting? Cause I got some good apps from the store. I don't want to lose them.
    Before doing a reset from the settings menu, try a soft reset and see if it helps.
    Press the volume down and the power button together for around 10 seconds till the phone vibrates to do a soft reset.
  20. ktl88's Avatar
    Member

    Posts
    161 Posts
    #20  
    I too updated mine in this morning. Update went smooth.
    I get better connectivity. Before update I used to consistently get 3 bars, now I consistently get 4-5.
    I don't use 2g/3g cause i'm always on wifi.
    Haven't noticed any other difference other than this better connectivity.
    No idea about battery life, will have to wait for a couple of days.
    Guys, go ahead with the update.
    Thanked by:
  21. garfieldm89's Avatar
    Member

    Posts
    84 Posts
    #21  
    Do i need to backup my apps and settings before update?
  22. ktl88's Avatar
    Member

    Posts
    161 Posts
    #22  
    Quote Originally Posted by garfieldm89 View Post
    Do i need to backup my apps and settings before update?
    No you don't need to back-up anything, it will do it automatically as long as you update using the OTA, rather than forcing the update through a software etc...
  23. #23  
    Updated today morning,everything working perfectly nice but where is the lumia color profile (display+touch) in firmware update?
  24. #24  
    Updated today morning,everything working perfectly nice but where is the lumia color profile (display+touch) in firmware update?
  25. siriustds's Avatar
    Member

    Posts
    23 Posts
    #25  
    Updated mine just now ..looks ok ..thank god they fixed the vibration rattle..was annoying..now i can keep it on for silent modes.But i dont see the display + touch in this firmware..will see for random call drops issue and connectivity..
Page 1 of 4 1234 LastLast

Similar Threads

  1. Replies: 677
    Last Post: 07-05-2013, 08:29 PM
  2. Replies: 27
    Last Post: 05-05-2013, 05:03 PM
  3. Nokia Lumia 920 Rogers Latest firmware update
    By flame l in forum Nokia Lumia 920
    Replies: 1
    Last Post: 04-03-2013, 06:43 PM
  4. Lumia 920 - ATT OS/firmware update question
    By smchambers56 in forum Nokia Lumia 920
    Replies: 8
    Last Post: 03-07-2013, 09:36 PM
  5. How to force update Nokia Lumia 800 to latest firmware 12070
    By Dave Blake in forum Nokia Lumia 800
    Replies: 7
    Last Post: 02-03-2013, 09:55 PM

Posting Permissions