Results 1 to 11 of 11
  1. sjhippie's Avatar
    Member

    Posts
    73 Posts
       #1  
    Hi all
    I have a 920 and it's been steller. I've been extremely happy with it and little to no issues with it nor the battery. I can easily make it through my day with normal usage (photos/texting/facebook/web etc). In fact I've never had a problem with it plummeting from full to nothing .... until today. So basically my day was a trip from San Jose to San Francisco.. a few texts taunting friends that I was touring ATT park, about 10 photos, a Lomocam use and upload to Flickr. That's it. I went from 100% when I left to 15% when I got back. All my usual stuff is turned off. In fact nothing has changed on my phone.

    What I find interesting is that a friend of mine with the same phone, was doing ok with her battery, but a recent trip via train to SF did the same thing to her battery. I'm wondering if there is something with the way the phone is searching for reception or something similar. I didn't even make it through half the day before it died.

    I dunno...anyone else have something similar happen?
  2. slashd0t's Avatar
    Member

    Posts
    171 Posts
    Global Posts
    259 Global Posts
    #2  
    Yeah, it sounds like an issue with reception... When travelling, you're phone is constantly hopping on and off different towers which can drain a battery really fast..
  3. sjhippie's Avatar
    Member

    Posts
    73 Posts
       #3  
    I was thinking that. Would this be a way WPhone handles it? I don't think there is anything to change manually.... hrm.
  4. slashd0t's Avatar
    Member

    Posts
    171 Posts
    Global Posts
    259 Global Posts
    #4  
    Quote Originally Posted by sjhippie View Post
    I was thinking that. Would this be a way WPhone handles it? I don't think there is anything to change manually.... hrm.
    Pretty sure all phones behave this way.. How is it when you're not travelling around?
  5. sjhippie's Avatar
    Member

    Posts
    73 Posts
       #5  
    Rock solid battery. Moderate usage today so far, nothing abnormal and I'm at 83%. Really weird that it was (hopefully) just yesterday.
  6. Bataar's Avatar
    Member

    Posts
    43 Posts
    #6  
    I've been thinking there must be some kind of environmental factor with the battery on this phone. I do some gaming activities and at one place, I can go and run an app on the phone and after about 5 hours, I still have about 1/3 of the battery left. There's another place I go to in a different area. I run the exact same app and the battery goes from a 100% charge to completely dead in about 3.5 hours. Nothing else is different on the phone, just my location. At the second location, I even turn wifi and Bluetooth completely off as well, where they're both left on at the first location.
  7. pdskep's Avatar
    Member

    Posts
    58 Posts
    #7  
    What happens to me fairly consistently is I have a huge battery drain AFTER I get home from work. I get little or no reception at work and my drain is worse than I would like, but not horrible. When I get home, the phone turns hot and it starts to drain over %10/hour until I restart it. During the weekends at home my battery is stellar. Somehow it seems like it's trying to connect during the day at work and when I get home, where the reception is great, it get stuck is some sort of loop and drains quickly. I'm on my second phone due to an unrelated issue and the other did the exact same. Here's an example and you can see when I restarted it at around 8:00PM.
    Attached Thumbnails Attached Thumbnails capture.jpg  
  8. christenmartin's Avatar
    Member

    Posts
    327 Posts
    Global Posts
    610 Global Posts
    #8  
    I have been having this battery gremlin. If I download or get on the internet the battery jumps to 25-30% an hour and continues draining after all activity stops. I have tried shutting every thing off, but a reset is the the only thing that will stop it. Doesn't matter wether it is on wifi or 4g. I can listen to music for 45 minutes and the battery doesn't move, but check facebook or WP central and it sticks but not all the time.??? I definitely think it is a software issue, most likely something didn't load right. I did a factory reset on it and it seems to have leveled it out between 2.5 and 5% an hour, which is what I would expect. I just did it yesterday so I want to let it settle down again and see how it does. I definitely think it is an os issue though simply by reading other forums and fixes as well as my own experience. There does not seem to be a overall fix, one thing works in this case, does not work in that case...... Turning everything off is not a viable option. If thats the case get a flip phone!!
  9. joeynox's Avatar
    Member

    Posts
    588 Posts
    Global Posts
    604 Global Posts
    #9  
    I'm on my 4th 920 and this unit has been great but once in a while I get that mystery battery drain as well. The only way to resolve it is to restart the phone. Poor app coding and poor os coding are to blame. The os should force the apps closed.
  10. Jaripi's Avatar
    Member

    Posts
    540 Posts
    Global Posts
    541 Global Posts
    #10  
    Quote Originally Posted by pdskep View Post
    What happens to me fairly consistently is I have a huge battery drain AFTER I get home from work. I get little or no reception at work and my drain is worse than I would like, but not horrible. When I get home, the phone turns hot and it starts to drain over %10/hour until I restart it. During the weekends at home my battery is stellar. Somehow it seems like it's trying to connect during the day at work and when I get home, where the reception is great, it get stuck is some sort of loop and drains quickly. I'm on my second phone due to an unrelated issue and the other did the exact same. Here's an example and you can see when I restarted it at around 8:00PM.
    Do you think that it is possible that this is just an battery monitor problem ? ... as there is NO power consumption almost at all, between 8 PM and 10 PM (after a sudden drop) ...
  11. pdskep's Avatar
    Member

    Posts
    58 Posts
    #11  
    Quote Originally Posted by Jaripi View Post
    Do you think that it is possible that this is just an battery monitor problem ? ... as there is NO power consumption almost at all, between 8 PM and 10 PM (after a sudden drop) ...
    That occurred to me, but it doesn't explain the phone getting warm/hot during the drain. Also the fairly flat line between 8-10 is consistent with what happens during the weekend when it's idle. Oh and it's no longer warm after a restart.

Similar Threads

  1. My first battery issue on the 810
    By Mystictrust in forum Nokia Lumia 810
    Replies: 20
    Last Post: 12-25-2012, 09:27 PM
  2. Just spoke to Nokia about my battery issues (2nd phone)
    By joeynox in forum Nokia Lumia 920
    Replies: 13
    Last Post: 12-05-2012, 07:53 AM
  3. My first real issue with my Focus! The display is seizing up.
    By TheAngelOfElysium in forum Samsung Focus
    Replies: 1
    Last Post: 05-10-2011, 04:06 PM

Posting Permissions

B