Results 1 to 5 of 5
  1. Brad M's Avatar
    Member

    Posts
    14 Posts
       #1  
    So yesterday and today I've had to constantly turn airplane mode on and off to get my phone to reconnect to 4G. When its connected I have full bars. I will be in the middle of searching something or emailing and it will loose connection. I searched any the only thing I saw was to restart or do the airplane mode. This just will not work for me if this continues. Thanks for any help!
  2. howie's Avatar
    Member

    Posts
    14 Posts
    Global Posts
    1,156 Global Posts
    #2  
    I've had this issue for a few weeks now, since I got the 920.
    I haven't found any solution, yet.
    Just glad it's my "play line" and not the line I depend on for service.
    I can sit there and watch the 4G drop down and bounce back up every few seconds, but the signal stays strong.
  3. #3  
    Yep, me too. I thought it was just Rogers being crap but I'm noticing my signal is not stellar. Sometimes at my desk I have a weird double speak echo even on regular phone calls as if I have super poor signal.
  4. niteshade1975's Avatar
    Member

    Posts
    11 Posts
    #4  
    I also have this problem on an unlocked phone in Cyprus. The data connection works fine for a few minutes, drops and then resumes continueously. I haven't been able to verify this but it looks like it's having problems maintaining a steady connection after switching between 3G & H
  5. supereddzz's Avatar
    Member

    Posts
    27 Posts
    #5  
    I've had this too in the UK. I've sent the phone back for repair/replacement...

Similar Threads

  1. constant data band switching issue
    By dwoodlock in forum Nokia Lumia 810
    Replies: 18
    Last Post: 07-14-2013, 10:06 PM
  2. On Constant Wi-Fi, why is AT&T charging data?
    By alex2364 in forum Windows Phone 8
    Replies: 6
    Last Post: 12-24-2012, 04:07 PM
  3. Tethering data connection dropping while on voice call?
    By rhalbert10 in forum Nokia Lumia 822
    Replies: 3
    Last Post: 12-06-2012, 12:00 PM
  4. Do I have the dropping data connection issue?
    By icaruschuck in forum Nokia Lumia 900
    Replies: 2
    Last Post: 06-01-2012, 07:49 AM
  5. Workarounds to dropped data connection?
    By XboxOmac in forum Nokia Lumia 900
    Replies: 7
    Last Post: 04-12-2012, 12:39 PM

Posting Permissions

B