Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
Like Tree1Likes
  • 1 Post By Memristor
  1. Memristor's Avatar
    Member

    Posts
    44 Posts
       #1  
    Did anyone experience power button problems yet? I can't do a soft- or hard reset to try and see if that will fix my issues. I guess the only way to reboot my Lumia 920 is letting the battery die. Right now the only way to turn the screen on is by receiving a phone call or hook up a charger. Any ideas?
  2. Daniel Ratcliffe's Avatar
    Retired Moderator

    Posts
    2,815 Posts
    Global Posts
    4,474 Global Posts
    #2  
    Get it replaced. Definitely defective hardware.

    "Fortune cookie said: 'Outlook not so good'. I said: 'Sure, but Microsoft ships it anyway'."
  3. Memristor's Avatar
    Member

    Posts
    44 Posts
       #3  
    Quote Originally Posted by Paladinleeds View Post
    Get it replaced. Definitely defective hardware.
    Cheese, that is already my second one. The first one had some graphics issues. I sure hope that I wont have to replace my phone every month. I had no issues with my old HTC Surround. It still works flawless as a spare phone. I expected much better quality from Nokia.
    Andyshine77 likes this.
  4. Daniel Ratcliffe's Avatar
    Retired Moderator

    Posts
    2,815 Posts
    Global Posts
    4,474 Global Posts
    #4  
    Quote Originally Posted by Memristor View Post
    Cheese, that is already my second one. The first one had some graphics issues. I sure hope that I wont have to replace my phone every month. I had no issues with my old HTC Surround. It still works flawless as a spare phone. I expected much better quality from Nokia.
    I've heard there have been some quality control issues. With my N920 I've noticed my capacitive buttons are a yellowy tinge. Only slightly though, and you only notice it when you consider I've compared it to my HTC TITAN that were a brilliant white. Everything else seems fine (except for maybe the PureView camera isn't living up to the marketing, but I'm putting that down to lack of practice on my part). I read someone had to get SIX replacements to get one that works fine. I'm fortunately on my first one (Twice I've got lucky, I remember the whole TITAN fiasco as well, no issues for me.) - Honestly if you like the phone just keep pushing with it! And yes, I also expected much better from Nokia. That's despite owning the POS that was the 5800, that crashed 10 times in a chain, meant my phone was out for 20 minutes, and also drained 75% of my battery... All because I decided I want to browse the web...

    "Fortune cookie said: 'Outlook not so good'. I said: 'Sure, but Microsoft ships it anyway'."

Similar Threads

  1. Headsets not working with my 920?
    By sabotagebx in forum Nokia Lumia 920
    Replies: 7
    Last Post: 05-27-2013, 10:11 AM
  2. Replies: 1
    Last Post: 12-19-2012, 11:55 AM
  3. Just moved, Data not working on my Focus :S
    By sunshine182 in forum Samsung Focus
    Replies: 13
    Last Post: 05-28-2012, 10:53 AM
  4. Deleting Gmail emails on your phone does NOT work
    By MikeEggleston in forum Windows Phone 7
    Replies: 52
    Last Post: 05-16-2012, 10:02 AM
  5. Older bose MIE does not work on L900 properly.
    By jcar302 in forum Windows Phone Accessories
    Replies: 0
    Last Post: 05-02-2012, 08:24 AM

Posting Permissions