Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 26
  1. TK2011's Avatar
    Member

    Posts
    229 Posts
       #1  
    I am seeing couple of issues:

    If you leave the home wifi area, phone sometimes gets confused and you don't have data access at all even if there is a strong 3G or LTE. If you then turn off WiFi, data connection starts working again. Are we supposed to turn off WiFi manually in this situation?

    Along this line, phone sometimes uses cellular data even though WiFi connection is shown at the top of screen. This can be a very costly bug if you are on a limited data plan. Just this morning I was at home and noticed very slow to no data speed with WiFi enabled. I figured WiFi was just busy with other computers and started to download an app. It took a while for download to get started, but when it did, it showed I was using cellular data! WTH? Of course once you start an app download, you can't stop it. Thank god it wasn't one of those 200MB games, I would have consumed my 300MB monthly quota right there.

    Anyone else with similar experience?

    EDIT: The second issue where it uses cellular instead of WiFi *may* be due to my new router I got yesterday. My laptops are having some trouble connecting this morning.
    Last edited by TK2011; 01-13-2013 at 04:55 PM.
  2. GizmoEV's Avatar
    Member

    Posts
    202 Posts
    #2  
    I haven't noticed that on my 920. I've noticed other things like high battery drain after opening and then closing some apps and sometimes live tiles not updating. A soft restart fixes it, however. Do you have the latest updates installed?
    David D. Nelson

    Nokia Lumina 920, Nokia Lumina 2520 & keyboard cover
  3. TK2011's Avatar
    Member

    Posts
    229 Posts
       #3  
    I have all the updates including Portico.

    More on the issues..in the first case, it seems like phone was looking for a known WiFi access point indefinitely. It should have given up and switch to cellular network after a reasonable period, say 15 seconds? The second case is more serious one. It should have either used the WiFi or don't show that WiFi is connected. Showing WiFi is connected and then using cellular connection is bad.

    For now I will keep the always on feature disabled. It's not worth the hassle IMO.
  4. tibere86's Avatar
    Member

    Posts
    52 Posts
    Global Posts
    56 Global Posts
    #4  
    I have noticed the phone using cellular data with an active wifi connection. Usually cycling wifi off and on rectified the issue. Hope Microsoft fix these small issues. It would also help if they included the feature that Android + iOS have which is when an active wifi connection is present, the phone hides the cellular data icon so the user knows none is being used.
  5. #5  
    I have not noticed this problem with WiFi, however, I will be monitoring now.

    As for updates, not had an update to the phone (apart from apps) since I got it.
  6. TK2011's Avatar
    Member

    Posts
    229 Posts
       #6  
    Quote Originally Posted by johnfishcurtis View Post
    I have not noticed this problem with WiFi, however, I will be monitoring now.

    As for updates, not had an update to the phone (apart from apps) since I got it.
    Then you don't have the always on WiFi option yet. Issues I mentioned above happened for me only when the option is enabled. It seems like the phone gets into a little confused state when you leave the wifi area with the option enabled. And sometimes it doesn't seem to fully recover even if you come back to the WiFi area.
  7. TK2011's Avatar
    Member

    Posts
    229 Posts
       #7  
    The second issue where it uses cellular instead of WiFi *may* be due to my new router I got yesterday. My laptops are having some trouble connecting this morning.
  8. #8  
    Since updating to Portico my practice has been to connect to WiFi when I'm at home and turn off the mobile data connection.I have noticed that if I leave home and don't turn the WiFi off and the mobile data back on, but go somewhere else where I can connect to WiFi (e.g. my dad's house), the phone won't search for a new WiFi network and connect whilst in standby mode.I think that this is a feature not a bug.God blessAndrew
  9. jiayit's Avatar
    Member

    Posts
    302 Posts
    Global Posts
    327 Global Posts
    #9  
    You can actually cancel a downloading app.. Go to the store, it should say 1 download or something, click it, hold the app to cancel it.
  10. smoledman's Avatar
    Banned

    Posts
    1,252 Posts
    Global Posts
    1,282 Global Posts
    #10  
    There is no satisfying people. Microsoft fixes the WiFi "not always connecting" and then people complain their data cap drains. I swear some people exist just to trash Windows Phone platform.
  11. RuleOfSines's Avatar
    Member

    Posts
    126 Posts
    #11  
    Quote Originally Posted by smoledman View Post
    There is no satisfying people. Microsoft fixes the WiFi "not always connecting" and then people complain their data cap drains. I swear some people exist just to trash Windows Phone platform.
    If it was fixed, data wouldn't drain. I noticed my lumia still seems to put wifi to sleep, I get a sudden surge of emails when I unlock it even though wifi should be always on.
  12. Chregu's Avatar
    Member

    Posts
    7,509 Posts
    Global Posts
    7,539 Global Posts
    #12  
    Everything works perfectly for me.
  13. smoledman's Avatar
    Banned

    Posts
    1,252 Posts
    Global Posts
    1,282 Global Posts
    #13  
    So the way I understand it, there is a new bug that WiFi does not automatically switch over to LTE when it needs to?
  14. TK2011's Avatar
    Member

    Posts
    229 Posts
       #14  
    Quote Originally Posted by smoledman View Post
    So the way I understand it, there is a new bug that WiFi does not automatically switch over to LTE when it needs to?
    Let me clarify. Portico introduced the wifi always-on option. By default it's off. But if you turn that on, leave your wifi area and then try to use data, it *sometimes* fails to switch over to 3G or LTE in a timely manner. It does switch over after a while (30 sec, 2 minutes?) or you can immediately make it work by turning off or toggling wifi. It seems as if phone is trying to make extra sure that the wifi access point is not there before switching over to cellular data. Not a huge deal but..
  15. smoledman's Avatar
    Banned

    Posts
    1,252 Posts
    Global Posts
    1,282 Global Posts
    #15  
    Quote Originally Posted by TK2011 View Post
    Let me clarify. Portico introduced the wifi always-on option. By default it's off. But if you turn that on, leave your wifi area and then try to use data, it *sometimes* fails to switch over to 3G or LTE in a timely manner. It does switch over after a while (30 sec, 2 minutes?) or you can immediately make it work by turning off or toggling wifi. It seems as if phone is trying to make extra sure that the wifi access point is not there before switching over to cellular data. Not a huge deal but..
    You know there is something to this idea. The building that I work has WiFi but depending on where I am walking around it I lose the connection. I wouldn't want the back and forth thing to happen in that scenario. I suspect the 30s interval is there for the majority of use cases where a person is leaving home or Starbucks and getting into their car. Microsoft figures the earliest you'll be accessing your smartphone for data will be after the interval. It's never going to satisfy 100% of users. I wonder how iOS & Android do it?

    What I think Microsoft should do is expand out the WiFI settings so that you can select 2 options:

    - immediately connect to LTE when out of range of WiFI
    - the current 30 second wait
  16. Chregu's Avatar
    Member

    Posts
    7,509 Posts
    Global Posts
    7,539 Global Posts
    #16  
    Quote Originally Posted by smoledman View Post
    What I think Microsoft should do is expand out the WiFI settings so that you can select 2 options:

    - immediately connect to LTE when out of range of WiFI
    - the current 30 second wait
    I think they would never do this, because this is a minor option and they already don't let us choose much more important things.
  17. Nataku4ca's Avatar
    Member

    Posts
    429 Posts
    #17  
    i think the always on is more for guys like me who don't have a data plan, i mean if your phone goes into standby and you have data plan you still get notifications right? (with out always on, i stop getting notifications...)

    but ya, i think smoledman is right, it might be decided that 30sec~2min was a good enough gap, wonder if they'll change it eventually

    btw, did you figure out if it was your router or not yet for the second issue?
  18. Steve Ridges's Avatar
    Member

    Posts
    156 Posts
    #18  
    Quote Originally Posted by TK2011 View Post
    Let me clarify. Portico introduced the wifi always-on option. By default it's off. But if you turn that on, leave your wifi area and then try to use data, it *sometimes* fails to switch over to 3G or LTE in a timely manner. It does switch over after a while (30 sec, 2 minutes?) or you can immediately make it work by turning off or toggling wifi. It seems as if phone is trying to make extra sure that the wifi access point is not there before switching over to cellular data. Not a huge deal but..
    I thought the purpose of the Portico change was to leave WiFi connected when the phone was locked. I didn't think there was supposed to be much change as far as what happens when you leave a WiFi area. At any rate, I haven't have any problem with this. I HAVE had my phone continue to use cell data while connected to WiFi however. I started a separate thread about that. I contacted AT&T and they were no help.
  19. TK2011's Avatar
    Member

    Posts
    229 Posts
       #19  
    Quote Originally Posted by Nataku4ca View Post
    i think the always on is more for guys like me who don't have a data plan, i mean if your phone goes into standby and you have data plan you still get notifications right? (with out always on, i stop getting notifications...)

    but ya, i think smoledman is right, it might be decided that 30sec~2min was a good enough gap, wonder if they'll change it eventually

    btw, did you figure out if it was your router or not yet for the second issue?
    I haven't experienced the second issue again since then. I have several PCs and an old smartphone. Something about WPA2 setting is causing trouble for one or the other. Lumia 920 has been fine. Not sure what happened ealier. It happened in my home where wifi signal is pretty weak so it's possible the phone lost the wifi signal briefly and decided to use cellular at the time. The status bar at the top doesn't always show so it's hard to tell for sure whether wifi was active at the moment app download started.
  20. fieldsy1024's Avatar
    Member

    Posts
    46 Posts
    #20  
    Is that why my tunein radio shuts off when I walk out of my house and then turns back on about 20 seconds later after going for a walk? This happens every time I go for a walk.
  21. SaucePolicy's Avatar
    Member

    Posts
    82 Posts
    #21  
    Yes because it loses its WiFi connection. There is no way for it to "hand off" the connection to cellular from WiFi and back again. It requires a new connection to be made or waits for the old one to become available again.
  22. tomatoes11's Avatar
    Member

    Posts
    249 Posts
    #22  
    Quote Originally Posted by TK2011 View Post
    Let me clarify. Portico introduced the wifi always-on option. By default it's off. But if you turn that on, leave your wifi area and then try to use data, it *sometimes* fails to switch over to 3G or LTE in a timely manner. It does switch over after a while (30 sec, 2 minutes?) or you can immediately make it work by turning off or toggling wifi. It seems as if phone is trying to make extra sure that the wifi access point is not there before switching over to cellular data. Not a huge deal but..
    Um, your new router could be way stronger and you actually do have a connection farther away and something else entirely is eating your data. I don't have a Lumia 920 but my 8x works just fine with wifi always on.
  23. Ne0natal's Avatar
    Member

    Posts
    1 Posts
    #23  
    I have the wifi always on. I went over my data limit this month and from ATT logs, most of the data was used ard midnight when i was at home where i have wifi. ATT guy asked me to turn data off but this is not a solution. I shouldn't have to do that. Its supposed to be a *smart* phone. Anybody found a solution?

    @Steve Ridges - I could not find the other thread on this topic. Link please.
  24. popeyesailer's Avatar
    Member

    Posts
    1 Posts
    #24  
    I have the same problem with my wife's lumia 920. It is burning up data at home at midnight where I have wifi and nobody is using the phone.

    Called ATT and they told me to shut the cell data off. That is crazy. I have a Lumia 900 that does not have this problem.
  25. Anthony80693's Avatar
    Member

    Posts
    13 Posts
    #25  
    Download an App called "Active Now!". It tells you what kind of connection albeit WiFi or Cellular the phone is currently using. It help me a lot and dictates which and much apps I use depending on what connection I'm using.
Page 1 of 2 12 LastLast

Similar Threads

  1. Pros/Cons of Always on WiFi from new update.
    By Glavata in forum Nokia Lumia 920
    Replies: 41
    Last Post: 01-19-2014, 09:45 AM
  2. 3G/WiFi Always On - I think there is a solution!!
    By rockstarzzz in forum Windows Phone 8
    Replies: 5
    Last Post: 02-11-2013, 02:53 PM
  3. Should the flash lens be flush with the body?
    By TenTwelve in forum Nokia Lumia 920
    Replies: 2
    Last Post: 11-14-2012, 06:46 PM
  4. You can't be friends with yourself on the wpcentral :(
    By BIGPADDY009 in forum The "Off Topic" Lounge
    Replies: 2
    Last Post: 11-03-2012, 03:03 PM
  5. WhatsApp seems to give me "Wifi Always On Stream"!?
    By mcmaui in forum Windows Phone 7
    Replies: 2
    Last Post: 08-17-2012, 07:45 PM

Posting Permissions