Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. bevmo73's Avatar
    Member

    Posts
    14 Posts
       #1  
    Since activating my 920 at Christmas I've been struggling to actually get service. 90% of time phone says no service, I have no service at home (but AT&T maps show 'moderate' LTE coverage) unless I stand by window to get 1 bar, whereas my old GSM Nokia was fine, and friends iPhone5 on AT&T at my home work fine. I don't drop down to stable 3G Edge service. Trying to fix the phone at 3G using the field tool doesn't get me a stable service. When I'm out and about I often have no service, inside stores or in my car, or at the Oakland Amtrak station. So I think I have a defective radio or antenna.

    The worst symptom is dropping 2 bars of service when I make a call. EG If I see 3 bars of LTE service, when I try to make a call, the signal bars drop 2 levels to 1 bar whilst the call is set up, or if I have 1-2 bars of service, and it looks like I can make a call, it is often dropped and the display switches to no service. I can see 4 or 5 bars of service / signal strength some times on the phone but they don't seem real when I try to use them.

    Tried hard reset and SIM card swap with AT&T tech support, now exchanging the phone.

    I guess I'll see if it's just my device when I get the replacement in the next few days, so I can keep a WP, else I'll have to pick something else...

    Anyone else had a similar experience?
  2. palandri's Avatar
    Retired Moderator

    Posts
    6,904 Posts
    Global Posts
    9,034 Global Posts
    #2  
    It must of had a bad antenna.
    Check out the great deals on Windows Phone Accessories: http://store.wpcentral.com
  3. farzonalmaneih's Avatar
    Member

    Posts
    45 Posts
    Global Posts
    753 Global Posts
    #3  
    Yeah, there must be something wrong with that particular one. I live in the South Bay and have driven all over (north bay, east bay, central coast) and have very good reception. Much much better than my iPhone 4s.
  4. bevmo73's Avatar
    Member

    Posts
    14 Posts
       #4  
    Replacement red arrived and service and signal seems normal, 3 bars where I used to have none, no drop in bars when I make a call ... hurray!
  5. dkp23's Avatar
    Member

    Posts
    1,395 Posts
    Global Posts
    1,418 Global Posts
    #5  
    Where in southbay you in? I am in Santa clara, i had an issue with reception as well,but it was an odd issue.

    The reception was fine in general, Santa Clara has a very strong LTE signal which I usually got 4-5 bars easily at all times.

    What the issue was, when i put the phone to sleep, the reception would be lost or die which cause idle drain because the phone was trying to sustain reception and update my accounts. So everytime i put my phone on idle, let it sit for a minute or two, then click the middle button to turn on, you see the reception signal on the top left show a no reception sign, then 0 bars, then 1, 2, 3 and then normal bars. Once i start using it, the reception is fine, once i put it to sleep, it would go away and i couldn't get notifcations and it also drained battery.

    Only place i know that has bad reception in the southbay is near mckee.

    If your phone is having issues in the southbay with reception in most areas, your phone is probably bad.
  6. bevmo73's Avatar
    Member

    Posts
    14 Posts
       #6  
    I'm in Oakland, but didn't travel my usual amount around San Jose, Peninsula, and SF, during the holidays. I'll look out for your symptoms when picking up and unlocking from idle or charging. Mine was more like the above, when you see the bars then make a call, they dropped away during call set up.

Similar Threads

  1. Replies: 6
    Last Post: 11-21-2012, 11:02 PM
  2. Replies: 13
    Last Post: 04-27-2012, 04:01 AM
  3. Poor battery life because of background tasks?
    By baba.bhagat in forum Nokia Lumia 800
    Replies: 27
    Last Post: 04-19-2012, 01:32 AM
  4. AT&T LTE Live in My Area
    By pseudoware in forum Other OS's and Devices
    Replies: 3
    Last Post: 12-09-2011, 12:23 AM
  5. Any Chance something of WP7 gets announced at CTIA?
    By buckeyeballer09 in forum Upcoming & Rumored Devices
    Replies: 1
    Last Post: 10-09-2011, 04:08 PM

Posting Permissions