Results 1 to 21 of 21
  1. JConn_Lefty's Avatar
    Member

    Posts
    218 Posts
    Global Posts
    332 Global Posts
       #1  
    UPDATE:
    so it seem like the weak signal is the culprit.

    by the time i got home, battery was showing 60%. this was me using the phone from 6:00am-7:30pm @ work (more than usual because work was slow). once home, i turned cellular data off and went about my business. from 7:30-10:00pm, the phone went from 60%-59%!!! It only lost 1% of battery power. the only use in the 2.5 hour was couple of short calls(less than 2 min) and a handful of text messages. i left home after 10pm but i think it's pretty safe to assume, MY current lumia 920 is draining the battery when signal strength is weak. I'm going to try and get a micro cell from att to see if that'll make the difference.

    this is my 3rd 920 from att and this one is by far the best one i've had. it's solid without any creeks or pops. it hasn't froze on me yet. no dust under the lens either.

    the battery life however isn't on par with my 2 previous 920's i've had. mind you, the previous 920s both had horrible battery but after a couple of charges, it made significant changes. this 3rd one however doesn't seem to have changed much after several charges.

    funny thing i noticed yesterday. the batter meter was showing 24% power remaining. turned the phone off and turned it on again for reasons i dont remember. once the phone was turned back on, it showed 29% batter remaining. this only seems to happen after i charge the phone. this morning same thing happened. the phone was charged to 100%. arrived @ work and battery went down to 99%. turned it off and turned it on and now it's showing 100%.

    im using the same battery reader on all 3 lumias i've had/have. anybody else going to similar issues? if so, any solutions?
    Last edited by JConn_Lefty; 01-02-2013 at 04:23 PM.
    Lumia 920
  2. jdhooghe's Avatar
    Member

    Posts
    504 Posts
    Global Posts
    1,827 Global Posts
    #2  
    Maybe give it a couple cycles? Sounds like a calibration issue. I'm surprised you stuck through three phones!
    HTC Droid Incredible --> Apple iPhone 4S --> Nokia Lumia 920 --> BlackBerry Z10 --> HTC One --> iPhone 5
  3. vinnyvv's Avatar
    Member

    Posts
    12 Posts
    Global Posts
    18 Global Posts
    #3  
    im on my 4th lumia 920, this one is perfect except battery drain. Overnight in 12 hrs My battery went from 79 to 62 with nothing running. And when i text or use an app the percentage drops fast. Ive had 3 other phones and their batteries were great. I got this 4th one 3 days ago and automatically installed portico instead of waiting and checking out the battery on the old software. Now i dont know what to do, exchange again or wait for another update
  4. JConn_Lefty's Avatar
    Member

    Posts
    218 Posts
    Global Posts
    332 Global Posts
       #4  
    Quote Originally Posted by jdhooghe View Post
    Maybe give it a couple cycles? Sounds like a calibration issue. I'm surprised you stuck through three phones!
    at the moment, this is the only phone in the market i'll consider. i'm tire of the iphone os. the only other phone i see myself with is the note 2 but that thing is just too damn big. i use my phone as a phone a lot m-f and i hate wearing the bluetooth ear piece.
    Lumia 920
  5. JConn_Lefty's Avatar
    Member

    Posts
    218 Posts
    Global Posts
    332 Global Posts
       #5  
    Quote Originally Posted by vinnyvv View Post
    im on my 4th lumia 920, this one is perfect except battery drain. Overnight in 12 hrs My battery went from 79 to 62 with nothing running. And when i text or use an app the percentage drops fast. Ive had 3 other phones and their batteries were great. I got this 4th one 3 days ago and automatically installed portico instead of waiting and checking out the battery on the old software. Now i dont know what to do, exchange again or wait for another update
    i feel your pain.

    i've noticed something else. today, my phone's battery has been performing like my 2 previous 920s. i've been @ work all day today and here, i get full bars no matter where i am. at home, i barely get 2-3 bars. apparently, when the phone's signal is weak, it requires more power to do anything. i think this might be the issue but it doesn't make 100% sense since i have wifi @ home.

    tonight, i'm going to turn wifi off when i get home and i'll see how the battery performs.
    Lumia 920
  6. conanheath's Avatar
    Member

    Posts
    450 Posts
    Global Posts
    561 Global Posts
    #6  
    Batteries do recharge to an extent when load is removed. I could see a couple of % change easy with a short power down. But whatever Nokia is using to monitor battery is erratic at best. If you are still having battery drain issues, here is what worked for me. Portico did stop random drain but otherwise my battery life was bad from launch day. It sucks, but it is the only thing that worked even after Portico. Perform factory reset, flash latest os, and restore. I tried everything listed in forums and this took my battery usage from 7-9% an hour to 3-4%. Same apps, same setup. It sucked, but it is only noticeable difference I have seen since day one and two different phones. I can't make you any promises but I tried all the other "this fixed my battery" solutions. Good luck. I wouldn't worry too much about a couple of % difference. I would be concerned about 10-20% difference. Oh ya, I don't know if it makes a difference, but make sure your phone is fully charged before attempt reset and watch the video in forums about flashing OS. May have nothing to do with it but I wouldn't chance it with the screwed up battery monitor Nokia uses.
  7. vinnyvv's Avatar
    Member

    Posts
    12 Posts
    Global Posts
    18 Global Posts
    #7  
    Quote Originally Posted by JConn_Lefty View Post
    i feel your pain.

    i've noticed something else. today, my phone's battery has been performing like my 2 previous 920s. i've been @ work all day today and here, i get full bars no matter where i am. at home, i barely get 2-3 bars. apparently, when the phone's signal is weak, it requires more power to do anything. i think this might be the issue but it doesn't make 100% sense since i have wifi @ home.

    tonight, i'm going to turn wifi off when i get home and i'll see how the battery performs.
    hmm good idea, tell us how that goes, im gonna try that too actually, but the thing is my wifi didnt run in the background when my phone was locked overnight. Ill turn it off anyways and see if i get any changes, oh and btw i just restarted my phone and got 10 updates! call and sms, nokia maps, nokia music, feedback to nokia, weather, nokia city lens, accessories,audio, display and touch, extras and info. Why did i need to restart to get all of this? did this help anyones battery by installing the ones from Nokia? im not updating anything for now.
  8. vinnyvv's Avatar
    Member

    Posts
    12 Posts
    Global Posts
    18 Global Posts
    #8  
    Quote Originally Posted by conanheath View Post
    Batteries do recharge to an extent when load is removed. I could see a couple of % change easy with a short power down. But whatever Nokia is using to monitor battery is erratic at best. If you are still having battery drain issues, here is what worked for me. Portico did stop random drain but otherwise my battery life was bad from launch day. It sucks, but it is the only thing that worked even after Portico. Perform factory reset, flash latest os, and restore. I tried everything listed in forums and this took my battery usage from 7-9% an hour to 3-4%. Same apps, same setup. It sucked, but it is only noticeable difference I have seen since day one and two different phones. I can't make you any promises but I tried all the other "this fixed my battery" solutions. Good luck. I wouldn't worry too much about a couple of % difference. I would be concerned about 10-20% difference. Oh ya, I don't know if it makes a difference, but make sure your phone is fully charged before attempt reset and watch the video in forums about flashing OS. May have nothing to do with it but I wouldn't chance it with the screwed up battery monitor Nokia uses.
    Ive also drained the battery dead 3 times. And completely started from scratch again. and ya the battery monitor is the worst garbage ive ever seen
  9. JConn_Lefty's Avatar
    Member

    Posts
    218 Posts
    Global Posts
    332 Global Posts
       #9  
    Quote Originally Posted by conanheath View Post
    Batteries do recharge to an extent when load is removed. I could see a couple of % change easy with a short power down. But whatever Nokia is using to monitor battery is erratic at best. If you are still having battery drain issues, here is what worked for me. Portico did stop random drain but otherwise my battery life was bad from launch day. It sucks, but it is the only thing that worked even after Portico. Perform factory reset, flash latest os, and restore. I tried everything listed in forums and this took my battery usage from 7-9% an hour to 3-4%. Same apps, same setup. It sucked, but it is only noticeable difference I have seen since day one and two different phones. I can't make you any promises but I tried all the other "this fixed my battery" solutions. Good luck. I wouldn't worry too much about a couple of % difference. I would be concerned about 10-20% difference. Oh ya, I don't know if it makes a difference, but make sure your phone is fully charged before attempt reset and watch the video in forums about flashing OS. May have nothing to do with it but I wouldn't chance it with the screwed up battery monitor Nokia uses.
    i'll give this a shot as well. so far, my phone's been off the charger since 6:00 am. it is now 3:00pm and my battery is showing 80% battery remaining. this is with 2 phone calls, 4 text, some web browsing, and some game play. normally, when i'm home with similar usage, i'm down to about 70 and below. i think it's the signal strength that's affecting my battery output.
    Lumia 920
  10. jdhooghe's Avatar
    Member

    Posts
    504 Posts
    Global Posts
    1,827 Global Posts
    #10  
    Quote Originally Posted by JConn_Lefty View Post
    i'll give this a shot as well. so far, my phone's been off the charger since 6:00 am. it is now 3:00pm and my battery is showing 80% battery remaining. this is with 2 phone calls, 4 text, some web browsing, and some game play. normally, when i'm home with similar usage, i'm down to about 70 and below. i think it's the signal strength that's affecting my battery output.
    Isn't that great battery life though? Looks awesome to me
    HTC Droid Incredible --> Apple iPhone 4S --> Nokia Lumia 920 --> BlackBerry Z10 --> HTC One --> iPhone 5
  11. conanheath's Avatar
    Member

    Posts
    450 Posts
    Global Posts
    561 Global Posts
    #11  
    Quote Originally Posted by JConn_Lefty View Post
    i'll give this a shot as well. so far, my phone's been off the charger since 6:00 am. it is now 3:00pm and my battery is showing 80% battery remaining. this is with 2 phone calls, 4 text, some web browsing, and some game play. normally, when i'm home with similar usage, i'm down to about 70 and below. i think it's the signal strength that's affecting my battery output.
    Wait, 20% in 9 hrs is 2% and 30% in 9hrs is about where I'm at. My 3-4% is idle with all the battery saving techniques in place. If you are getting that, I wouldn't mess with it. It could get worse and then you would blame me. LTE is a battery hog from what I'm seeing and I think this might be as good as it gets. Short of living under a cell tower.
  12. JConn_Lefty's Avatar
    Member

    Posts
    218 Posts
    Global Posts
    332 Global Posts
       #12  
    Quote Originally Posted by jdhooghe View Post
    Isn't that great battery life though? Looks awesome to me
    absolutely, i would not be complaining if my battery performs the way it is now. my battery seems to drain extremely fast when i'm home where my signal is a lot weaker than at work.

    just yesterday, i was home doing similar things. from 6:00am-10:00am my phone went from 100%-50%. roughly the same amount of use as today.
    Lumia 920
  13. JConn_Lefty's Avatar
    Member

    Posts
    218 Posts
    Global Posts
    332 Global Posts
       #13  
    Quote Originally Posted by conanheath View Post
    Wait, 20% in 9 hrs is 2% and 30% in 9hrs is about where I'm at. My 3-4% is idle with all the battery saving techniques in place. If you are getting that, I wouldn't mess with it. It could get worse and then you would blame me. LTE is a battery hog from what I'm seeing and I think this might be as good as it gets. Short of living under a cell tower.
    believe me, if i can get my current 920 to perform the way it is today, i'm set! this one still has the light seeping out from the lower right hand corner but this doesn't bother me.
    Lumia 920
  14. Etyrnus's Avatar
    Member

    Posts
    353 Posts
    #14  
    I've been getting much better battery life lately, and I have a launch 920. Only things that kill my battery are playing a few games and baconit.
    Arguing with an ***** is like playing chess with a pigeon.
    You could be the greatest player in the world, but the pigeon will still knock over all the pieces, s--t on the board and strut around triumphantly-Tomtom6 on NcSportbikes.com
  15. JConn_Lefty's Avatar
    Member

    Posts
    218 Posts
    Global Posts
    332 Global Posts
       #15  
    hypothetically speaking, if the meek signal strength is the culprit, do we have any remedies to fix this problem?
    Lumia 920
  16. JConn_Lefty's Avatar
    Member

    Posts
    218 Posts
    Global Posts
    332 Global Posts
       #16  
    Quote Originally Posted by Etyrnus View Post
    I've been getting much better battery life lately, and I have a launch 920. Only things that kill my battery are playing a few games and baconit.
    i've noticed the same with my 2 previous lumia 920s. battery life improved significantly after several charges. this 3rd one i have has gone through similar charges and i dont see the type of improvement i saw on the previous lumias. i've only had this phone for a total of 8 days now but it's gone through more than 8 charge cycles. i find myself charging my phone 2x when i'm home and this is not due to excessive use. i use my phone pretty much in the same manner whether i'm home or at work. the only difference is that at home, i use wifi (my signal strength hovers at 1-3 bars max) and at work, i use LTE (full bar 24/7).
    Lumia 920
  17. Etyrnus's Avatar
    Member

    Posts
    353 Posts
    #17  
    One thing you can try if you use WiFi at home is turn cellular data off. Only downside is you have to turn it back on if someone sends you a pic text.
    Arguing with an ***** is like playing chess with a pigeon.
    You could be the greatest player in the world, but the pigeon will still knock over all the pieces, s--t on the board and strut around triumphantly-Tomtom6 on NcSportbikes.com
  18. JConn_Lefty's Avatar
    Member

    Posts
    218 Posts
    Global Posts
    332 Global Posts
       #18  
    Quote Originally Posted by Etyrnus View Post
    One thing you can try if you use WiFi at home is turn cellular data off. Only downside is you have to turn it back on if someone sends you a pic text.
    yup, i plan to do this tonight when i get home. i'm going to put my phone on airplane mode and see if this makes any difference.

    work is slow today, so i've been on my phone pretty much non-stop and i'm still @ 70%. i've been playing dredd vs zombies for a good 30 mins too.
    Lumia 920
  19. jdhooghe's Avatar
    Member

    Posts
    504 Posts
    Global Posts
    1,827 Global Posts
    #19  
    Quote Originally Posted by JConn_Lefty View Post
    absolutely, i would not be complaining if my battery performs the way it is now. my battery seems to drain extremely fast when i'm home where my signal is a lot weaker than at work.

    just yesterday, i was home doing similar things. from 6:00am-10:00am my phone went from 100%-50%. roughly the same amount of use as today.

    Ooooooh, gotcha'
  20. Etyrnus's Avatar
    Member

    Posts
    353 Posts
    #20  
    Quote Originally Posted by JConn_Lefty View Post
    yup, i plan to do this tonight when i get home. i'm going to put my phone on airplane mode and see if this makes any difference.

    work is slow today, so i've been on my phone pretty much non-stop and i'm still @ 70%. i've been playing dredd vs zombies for a good 30 mins too.
    You don't have to go airplane mode, because then you can't receive calls or texts. Just turn the cellular data off so it's not constantly searching for a stronger signal.
    Arguing with an ***** is like playing chess with a pigeon.
    You could be the greatest player in the world, but the pigeon will still knock over all the pieces, s--t on the board and strut around triumphantly-Tomtom6 on NcSportbikes.com
  21. JConn_Lefty's Avatar
    Member

    Posts
    218 Posts
    Global Posts
    332 Global Posts
       #21  
    update:
    so it seem like the weak signal is the culprit.

    by the time i got home, battery was showing 60%. this was me using the phone from 6:00am-7:30pm @ work (more than usual because work was slow). once home, i turned cellular data off and went about my business. from 7:30-10:00pm, the phone went from 60%-59%!!! It only lost 1% of battery power. the only use in the 2.5 hour was couple of short calls(less than 2 min) and a handful of text messages. i left home after 10pm but i think it's pretty safe to assume, MY current lumia 920 is draining the battery when signal strength is weak. I'm going to try and get a micro cell from att to see if that'll make the difference.
    Lumia 920

Similar Threads

  1. Low battery back up after Tango update
    By md_minhaj in forum Samsung Focus Flash 4G
    Replies: 7
    Last Post: 09-12-2012, 12:13 PM
  2. Turning on/off 3G on the Focus
    By firedancer1189 in forum Samsung Focus
    Replies: 8
    Last Post: 06-08-2011, 10:52 PM
  3. Is your arrive heating up after a phone call?
    By kushkm in forum HTC Arrive / 7 Pro
    Replies: 11
    Last Post: 03-29-2011, 07:37 PM
  4. Phone not starting up, stuck on weird icon...
    By Xm_jdm in forum Windows Phone 7
    Replies: 6
    Last Post: 02-20-2011, 10:19 AM

Posting Permissions

B