Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 29
Like Tree1Likes
  1. PhilS_UK's Avatar
    Member

    Posts
    19 Posts
       #1  
    Hi,
    Noticed after I delete an email in WP8 Gmail app....when I log into Gmail on the web the deleted items appear in my gmail folder ...instead of in the deleted folder? Annoying.

    Anyone else have this issue or know how to resolve it?

    Thanks
  2. CamiKitti's Avatar
    Member

    Posts
    293 Posts
    #2  
    You just have to manually move it in the trash when you are deleting emails. Same thing with Yahoo mail.
  3. tebugg's Avatar
    Member

    Posts
    363 Posts
    Global Posts
    366 Global Posts
    #3  
    Quote Originally Posted by PhilS_UK View Post
    Hi,
    Noticed after I delete an email in WP8 Gmail app....when I log into Gmail on the web the deleted items appear in my gmail folder ...instead of in the deleted folder? Annoying.

    Anyone else have this issue or know how to resolve it?

    Thanks
    i had this same issue on my android device. it only gets rid of it in your phone but inside your actually email from the site it doesnt move it to the delete folder. i think the apps dont have sufficient permission to actually delete it from your email.
  4. PhilS_UK's Avatar
    Member

    Posts
    19 Posts
       #4  
    Odd...I never had this problem on my Galaxy S2. In fact iPhone has no problem either. Just 920. :S
  5. #5  
    Try refreshing your inbox on your phone after you delete the email. I've noticed the same thing. For some reason when you delete an email it is not re-syncing with your normal inbox..

    So sync your emails. Delete from phone. Sync phone again. Should fix it
  6. evilbadger's Avatar
    Member

    Posts
    1 Posts
    #6  
    You need to change the sync settings on your Google account to allow your WP8 device to actually delete mails.

    This article gives more details: How to use Google services in Windows Phone 8
  7. joshingyou's Avatar
    Member

    Posts
    23 Posts
    #7  
    I was just trying to set it up at m.google.com/sync on my phone and for some reason IE10 just automatically takes me to a desktop version (more like a help portal). Don't know how to fix it since I do set IE10 to request "mobile version". I was able to do it 3 weeks ago but now I can't. Help!
  8. tebugg's Avatar
    Member

    Posts
    363 Posts
    Global Posts
    366 Global Posts
    #8  
    Quote Originally Posted by joshingyou View Post
    I was just trying to set it up at m.google.com/sync on my phone and for some reason IE10 just automatically takes me to a desktop version (more like a help portal). Don't know how to fix it since I do set IE10 to request "mobile version". I was able to do it 3 weeks ago but now I can't. Help!
    gettin the same thing. have browser set to go to mobile version but it still takes you to google.com/sync not the mobile version. and there is no option to sign in from that page. and if you select sync with a mobile device, it takes you to a dead end for windows mobile. no option to select your wp8 device.

    EDIT: i was able to do the exchange email option and i sent myself a test email. deleted it from my phone and checked my email on google's site and the email is still in my inbox on the site.
    Last edited by tebugg; 12-13-2012 at 09:24 PM.
  9. devize's Avatar
    Member

    Posts
    226 Posts
    Global Posts
    232 Global Posts
    #9  
    I've got mine set up as an exchange email and if I do a sync AFTER deleting the emails it'll then sync with the website.
  10. philpeeps's Avatar
    Member

    Posts
    487 Posts
    Global Posts
    657 Global Posts
    #10  
    Quote Originally Posted by devize View Post
    I've got mine set up as an exchange email and if I do a sync AFTER deleting the emails it'll then sync with the website.
    but it moves them to archive, not trash, unless you changed the sync setting as described above.
  11. devize's Avatar
    Member

    Posts
    226 Posts
    Global Posts
    232 Global Posts
    #11  
    Quote Originally Posted by philpeeps View Post
    but it moves them to archive, not trash, unless you changed the sync setting as described above.
    Oh right, I see what you mean. Well I can't access m.google.com/sync like in the tutorials I've seen so I don't know how to go about fixing it now. Atleast the deleted emails stay out of the inbox.
  12. snakebitten's Avatar
    Member

    Posts
    64 Posts
    #12  
    Thanks fellas!
    Logged into Gmail in desktop browser and changed imap settings to "client" controlled options.

    Now I delete messages from phone, and they are moved to trash on google server.

    Nice. No more deleting messages twice. Not for Gmail or office Exchange account.

    This phone is just getting better everyday.
  13. aaa6112's Avatar
    Member

    Posts
    538 Posts
    #13  
    I tried changing the settings mentioned in the link evilbadger shared but I still see the emails that I deleted on my 920, on my laptop.
    As to how I was able to access the m.google.com page, here's what I did:
    1. Opened IE10 on my laptop.
    2. Alt+T-> F12 developer tools.
    3. In the new window that pops up, click tools->change user agent string and select Apple Safari (IpAD).
    4. Went to "https://m.google.com/sync/settings/" exactly (without double quotes of course), and it opened the correct mobile version of the page. Signed into my Google account
    5. I selected Windows Phone and selected the box adjacent to "Enable "Delete Email As Trash" for this device." and saved these settings.

    Even after I do this, emails deleted on my Lumia 920 still show up in my Gmail inbox on my laptop.
  14. brmiller1976's Avatar
    Member

    Posts
    2,092 Posts
    Global Posts
    2,578 Global Posts
    #14  
    Google wants you to "archive" your mail so that it can continue scraping your personal data and build a detailed profile of you. Are you *sure* you want Google getting that info?
  15. snakebitten's Avatar
    Member

    Posts
    64 Posts
    #15  
    After deleting email on phone, I had to refresh the Gmail webpage to see the changes. And I set "to trash". Not archive.

    By the way, I didn't use link above. I simply loaded full version of Gmail. Then chose options. Then imap settings. (not windows phone specifically)
  16. Darus214's Avatar
    Member

    Posts
    73 Posts
    Global Posts
    75 Global Posts
    #16  
    That probably because you have it set for manual sync. After you delete them on your phone just hit the refresh button and it will delete them off of google
  17. anthonyng's Avatar
    Member

    Posts
    269 Posts
    #17  
    I think google changed something with the workaround to set up calendars cause I can't get there anymore without it redirecting back to Google Sync

    I wanted to double check my delete email setting and I can't! I don't have an IE10 machine around to try yet.... So glad I got my calendars selected properly right away cause now I can't change them :D
  18. futurix's Avatar
    Member

    Posts
    63 Posts
    #18  
    If you are using Google Apps (any edition) the setting to actually delete and not archive can be set in administrator's console for all users.
    Thanked by:
  19. anthonyng's Avatar
    Member

    Posts
    269 Posts
    #19  
    hmmm so I'm going through the set up process for business and only apps account works right? Not my primary regular gmail account? Like I don't want to go through the whole set up process only to find I can't modify the settings of my gmail account because it's not an Apps account.
  20. applekid's Avatar
    Member

    Posts
    2 Posts
    #20  
    Hello all - I'd like to register the same issue. I've attempted using a browser user-agent switcher to access the mobile version of the sync website from my desktop with no success. I have no success on my phone, either.

    I'm still experiencing issues where my inbox is not being synced back up to Gmail after reading/deleting messages on the phone. I understand that you can do this manually by hitting the ActiveSync button, but practically speaking we shouldn't have to do this.

    Has anyone else had success or learned anything new about this issue?
  21. PhilS_UK's Avatar
    Member

    Posts
    19 Posts
       #21  
    Have tried all of the above...nothing fixed it. Think answer should lay in Gmail IMAP/POP3settings, though why iPhone/Android works fine I don't know.
  22. CamiKitti's Avatar
    Member

    Posts
    293 Posts
    #22  
    Gmail fixed it. Now emails can be deleted properly since it's now called trash rather than deleted items.
  23. applekid's Avatar
    Member

    Posts
    2 Posts
    #23  
    Quote Originally Posted by CamiKitti View Post
    Gmail fixed it. Now emails can be deleted properly since it's now called trash rather than deleted items.
    Hello Cami, I have to say I don't believe this has been resolved. I've also noticed that this is the case for my Exchange account. Only when you manually activate the sync (or wait 1 hour) does it actually sync up. I have everything set to work "as it happens," but that doesn't seem to make any difference. If this is working properly for you now, do you mind sharing your settings and a brief explanation of how you confirmed it is working properly?
  24. CamiKitti's Avatar
    Member

    Posts
    293 Posts
    #24  
    Quote Originally Posted by applekid View Post
    Hello Cami, I have to say I don't believe this has been resolved. I've also noticed that this is the case for my Exchange account. Only when you manually activate the sync (or wait 1 hour) does it actually sync up. I have everything set to work "as it happens," but that doesn't seem to make any difference. If this is working properly for you now, do you mind sharing your settings and a brief explanation of how you confirmed it is working properly?
    I was trying to sync my Gmail account with the Google calendar, and the Gmail unlinked from all of the linked inboxes. Then, I looked in the Gmail and noticed that the trash was there instead of deleted items. I wish I could help, but it just worked for me. :(
  25. halocameo's Avatar
    Member

    Posts
    5 Posts
    #25  
    Quote Originally Posted by snakebitten View Post
    Thanks fellas!
    Logged into Gmail in desktop browser and changed imap settings to "client" controlled options.

    Now I delete messages from phone, and they are moved to trash on google server.

    Nice. No more deleting messages twice. Not for Gmail or office Exchange account.

    This phone is just getting better everyday.
    Where do you see the option to have "client" controlled IMAP settings - I do not see it in my gmail account on the web?
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 12
    Last Post: 03-29-2013, 08:14 PM
  2. Replies: 0
    Last Post: 11-21-2012, 01:22 PM
  3. Deleting Gmail messages (really deleting them)
    By gtbuzz in forum Nokia Lumia 900
    Replies: 7
    Last Post: 10-03-2012, 09:28 AM
  4. How to pin Gmail tile after deleting
    By jbeal82 in forum Windows Phone 7
    Replies: 1
    Last Post: 08-20-2011, 05:34 AM

Posting Permissions