Results 1 to 3 of 3
  1. djncanada1's Avatar
    Member

    Posts
    39 Posts
    Global Posts
    55 Global Posts
       #1  
    Hi,

    I have an unlocked Lumia 920, was unlocked by Rogers last night.

    Last night, I installed my Telus micro SIM and got a LTE signal.

    Today, I purchased an additional micro SIM and installed in Lumia 920.

    I have moved SIM's between Samsug Galaxy SIII and Lumia 920, always get LTE on Samsung, 4G on the Lumia 920.

    I called Telus, I am connected to LTE service.

    Any suggestions?
  2. djncanada1's Avatar
    Member

    Posts
    39 Posts
    Global Posts
    55 Global Posts
       #2  
    Hi,

    Just an update. I really feel like a knob..

    When I fired up IE and looked to download something..LTE shows up.

    Could someone verify that Lumia 920 normally uses 4G mode until a data activity starts and then moves to LTE? If yes, this is brilliant!!!

    Dave
  3. EG8196's Avatar
    Member

    Posts
    74 Posts
    #3  
    Quote Originally Posted by djncanada1 View Post
    Hi,

    Just an update. I really feel like a knob..

    When I fired up IE and looked to download something..LTE shows up.

    Could someone verify that Lumia 920 normally uses 4G mode until a data activity starts and then moves to LTE? If yes, this is brilliant!!!

    Dave
    No, mine is always LTE, unless no LTE signal.
    If no LTE signal, it will be 3G until a data activity starts and then moves to 4G

Similar Threads

  1. Rogers Lumia 920 Signal issues.
    By MikeLynch001 in forum Nokia Lumia 920
    Replies: 7
    Last Post: 12-09-2012, 10:50 AM
  2. got a lumia 920! one issue
    By graigsmith in forum Windows Phone 8
    Replies: 1
    Last Post: 11-09-2012, 11:41 PM
  3. Rogers' Lumia 920
    By miki20021 in forum Nokia Lumia 920
    Replies: 4
    Last Post: 11-07-2012, 09:25 AM
  4. Replies: 15
    Last Post: 11-01-2012, 02:44 AM

Posting Permissions

B