Results 1 to 18 of 18
  1. jbwpcentral's Avatar
    Member

    Posts
    33 Posts
       #1  
    This is BS! Whenever im in a call on my lumia 920 i cannot use the phone. The screen flickers for a second then goes black! Has anyone noticed this on their phone?
  2. Sinabu's Avatar
    Member

    Posts
    226 Posts
    Global Posts
    261 Global Posts
    #2  
    First thing to check.

    Do you have a Case on your phone. If so is it covering up the prox sensor? It's just above the N of the Nokia Logo.
    Red Lumia 920
    Thanked by:
  3. americasteam's Avatar
    Member

    Posts
    47 Posts
    Global Posts
    119 Global Posts
    #3  
    Not on mine. I use the device all the time while on a call.
  4. randywintle's Avatar
    Member

    Posts
    34 Posts
    #4  
    This happened to me tonight, think I had some smudges over proximity sensor making it act up. But, definitely can happen.
    Sent from my RM-820_nam_att_100 using Board Express
  5. rimmer007's Avatar
    Member

    Posts
    1 Posts
    #5  
    Think I am having the same problem, when i make a call and its asking a for a selection ie press 3 for customer service. I press the power button to bring up the num pad but the num pad flickers on/off in to fast for me to make a selection.

    I dont have a case and im sure there are no marks above the prox sensor. Any other suggestions please?
  6. alvarezjpr's Avatar
    Member

    Posts
    54 Posts
    Global Posts
    189 Global Posts
    #6  
    Hopefully this thread will help all of you.

    http://is.gd/PpyA5T
    Thanked by:
  7. zigzagr63's Avatar
    Member

    Posts
    23 Posts
    #7  
    I haven't had this problem until this morning. Was on a call and had to do a number selection but I couldn't do it. When I pulled my phone away from my face the screen wouldn't come on. If you hit the power button the screen just flashes.
    I don't have a case and I read the forums to try what others have done but I am still having an issue. It's not really a big deal for now because I don't have to use this very often. In fact this is the first time in 3 weeks since I have had the phone that I have had the need. Any other suggestions please tell.
  8. zigzagr63's Avatar
    Member

    Posts
    23 Posts
    #8  
    I'm not sure this is a hardware or software issue. Someone mentioned that Skype might be an issue but it isn't. I uninstalled and rebooted with still no improvement. I have noticed this problem getting worse now. Anybody having any luck getting it to work?
  9. clavecinist's Avatar
    Member

    Posts
    30 Posts
    #9  
    I think that has been said elsewhere, but get a can of air and blow out the earpiece. Mine had the same problem, but blowing dust out of the earpiece fixed it.
    Sent from my RM-820_nam_att_100 using Board Express
    First party accessories are my jam.
    Thanked by:
  10. lennyk1313's Avatar
    Member

    Posts
    84 Posts
    #10  
    Definitely check and wipe your proximity sensor. Worked for me.
  11. erike3198's Avatar
    Member

    Posts
    65 Posts
    Global Posts
    83 Global Posts
    #11  
    same thing with me, it has NOTHING to do with smudges or dirt. Its either a hardware issue, or possibly software. but unless everyone has this issue, Im leaning towards hardware. I need to get mine replaced asap, its really bad. cant hang up calls!!
  12. zigzagr63's Avatar
    Member

    Posts
    23 Posts
    #12  
    OK.... well I do have to say that blowing some air into the earpiece made a difference. Thanks for the tip. Seems to be working great now.
  13. zigzagr63's Avatar
    Member

    Posts
    23 Posts
    #13  
    No you need to use a can of air and blow out the earpiece. It works.... funny it never did this with my 900 but such as it is. Thanks again clavecinist for the tip on this. I take it this is where the sensor is now.
  14. erike3198's Avatar
    Member

    Posts
    65 Posts
    Global Posts
    83 Global Posts
    #14  
    Got a replacement and the phone is fine now.
  15. erike3198's Avatar
    Member

    Posts
    65 Posts
    Global Posts
    83 Global Posts
    #15  
    Starting to happen again, very annoying. What causes this to happen after a while?
  16. #16  
    Quote Originally Posted by jbwpcentral View Post
    This is BS! Whenever im in a call on my lumia 920 i cannot use the phone. The screen flickers for a second then goes black! Has anyone noticed this on their phone?
    Yes I had this exact same problem. it is a known defect with the proximity sensor. Some people seem to say if you take a few pictures with the front facing camera that will correct it... oddly enough. I had my device replaced but try the camera thing. My second device doesn't have the problem but I'm going to be moving on to my third because my current one is creaky as **** and the power button is loose.
  17. churchwa's Avatar
    Member

    Posts
    21 Posts
    Global Posts
    44 Global Posts
    #17  
    Quote Originally Posted by clavecinist View Post
    I think that has been said elsewhere, but get a can of air and blow out the earpiece. Mine had the same problem, but blowing dust out of the earpiece fixed it.
    Sent from my RM-820_nam_att_100 using Board Express
    This worked a treat, thanks.
  18. NTSzlovak's Avatar
    Member

    Posts
    2 Posts
    #18  
    Hy i have the same problem with my 920. The problem on mine was the screen protector which covers the proximity sensor. So i get a new screen protector and i cut the top right corner off then put it on the phone and is working fine.
    Other remark if you in a call and you turn on the speaker phone the screen will stay on permanently!
    One more thing If you in a call press and hold the upper left corner of the glass just between the speaker and the upper left corner. This is only temporary but works for me.

Similar Threads

  1. Screen flickers and unresponsive when making a call?
    By Papaguan in forum Nokia Lumia 900
    Replies: 11
    Last Post: 02-26-2013, 06:56 PM
  2. Screen unresponsive when usb plugged in?
    By mrshamoozoo in forum Nokia Lumia 920
    Replies: 13
    Last Post: 12-23-2012, 12:27 PM
  3. How to keep screen on when plugged in?
    By RockPaperBFG in forum Windows Phone 7
    Replies: 3
    Last Post: 08-15-2011, 04:34 PM

Posting Permissions

B