Results 1 to 5 of 5
  1. tomassplatch's Avatar
    Member

    Posts
    3 Posts
    Global Posts
    23 Global Posts
       #1  
    Hello, I have a problem with since two days. My Lumia 920 doesn't charge when plugged into the provided usb charger. It makes the typical sound and shows the battery charging icon, but is actually discharging.
    Interestingly, the phone is charging when connected to PC with the same usb cable. It also does charge with different charger with higher output...

    Anyone experienced this as well?
    Sent from my RM-821_eu_france_267 using Board Express
  2. morpheus1982's Avatar
    Member

    Posts
    199 Posts
    #2  
    Quote Originally Posted by tomassplatch View Post
    Hello, I have a problem with since two days. My Lumia 920 doesn't charge when plugged into the provided usb charger. It makes the typical sound and shows the battery charging icon, but is actually discharging.
    Interestingly, the phone is charging when connected to PC with the same usb cable. It also does charge with different charger with higher output...

    Anyone experienced this as well?
    Sent from my RM-821_eu_france_267 using Board Express
    You mean you are NOT using "wireless" charging? Your issue must be the mains adaptor. Can you get it replaced?

    Device: O2 HTC Windows Phone 8X 16Gb
  3. tomassplatch's Avatar
    Member

    Posts
    3 Posts
    Global Posts
    23 Global Posts
       #3  
    correcy, it's the wall plugin cable charger... I will try to have it replaced...
  4. #4  
    Same problem here. I have come to take for technical service to be told what the problem was. Charged the phone and told me that he would be discharged only. Using the charger supplied by Nokia in USB computer, in light socket, swapping cables does nothing work. This is me with despair to think that I will have to take the service again ...
    Here is 240V...
  5. gerulis's Avatar
    Member

    Posts
    1 Posts
    #5  
    I have same poblem. conect phone to chage its show sharging, but battery life decreas, until remaining battery life goes to 0%, but then i disconect from chrger phone shows 0 battrey life. If i restore factory setings battery goes to 100%. and same again, how i can fix this problem?

Similar Threads

  1. Lumia 920 not installing on Windows 7?
    By soylent in forum Nokia Lumia 920
    Replies: 14
    Last Post: 03-14-2013, 07:43 AM
  2. AT&T Preorder Lumia 920 - Not On Time
    By garak0410 in forum Windows Phone 8
    Replies: 11
    Last Post: 11-10-2012, 05:24 PM
  3. AT&T Preorder Lumia 920 - Not On Time
    By garak0410 in forum Windows Phone 8
    Replies: 10
    Last Post: 11-09-2012, 01:12 PM
  4. Did the digitizer pen not come with the RT version?
    By Ricom1 in forum Microsoft Surface for Windows RT
    Replies: 12
    Last Post: 11-06-2012, 05:24 PM
  5. Am I the only one not impressed with the 900?
    By Mochi in forum Nokia Lumia 900
    Replies: 50
    Last Post: 04-04-2012, 07:09 PM

Posting Permissions

B