Results 1 to 10 of 10
  1. Matt Fara's Avatar
    Member

    Posts
    53 Posts
       #1  
    My phone keeps switching between 3G, 4G, 4 bars, 1 bar, and sometimes no reception at all. I bought the phone from Rogers, and my Fido sim works in it without unlocking.
    I'm trying to connect to LTE, which I still have not done, I can't even keep a stable 3G connection.
    These are my APN settings:

    APN:
    LTEMOBILE.APN

    User name:

    Password:

    Proxy server (URL):

    Proxy:

    IP type:
    IPv4

    Any help is greatly appreciated.
  2. Matt Fara's Avatar
    Member

    Posts
    53 Posts
       #2  
    Bump!
  3. benjaminleroux's Avatar
    Member

    Posts
    4 Posts
    Global Posts
    115 Global Posts
    #3  
    Quote Originally Posted by Matt Fara View Post
    My phone keeps switching between 3G, 4G, 4 bars, 1 bar, and sometimes no reception at all. I bought the phone from Rogers, and my Fido sim works in it without unlocking.
    I'm trying to connect to LTE, which I still have not done, I can't even keep a stable 3G connection.
    These are my APN settings:

    APN:
    LTEMOBILE.APN

    User name:

    Password:

    Proxy server (URL):

    Proxy:

    IP type:
    IPv4

    Any help is greatly appreciated.
    Try not setting any APN settings.. I also bought the Rogers one and using it on Fido... did not plug in any APN settings, worked like a charm.

    I do see it bob from 3G to 4G when I unlock the phone... but I think that's normal. As for LTE, make sure you have a LTE sim card... I get great LTE in Montreal and getting abou 33m + download speeds
  4. Matt Fara's Avatar
    Member

    Posts
    53 Posts
       #4  
    I tried that, still nothing...
    Could it be a defective phone?
    Should I try to return it?
  5. denious's Avatar
    Member

    Posts
    4 Posts
    #5  
    I wanted to join in the conversation to report that I am having the same problem, but have discovered it through my SMS messages not being sent out 1 out of 10 times. Every single time a message could not be sent my phone was completely disconnected from the network, only to get full bars again in a couple of seconds.

    Since I've noticed that I have been taking a look at my bars, and they're constantly fluctuating.

    Here's a Rogers thread on people having problems with their SMS messages:
    Lumia 920 can't send text messages - Rogers Community

    Here's another thread on WPCentral on the issue:
    Signal issues

    I am sure that it's all part of the same problem.
  6. Matt Fara's Avatar
    Member

    Posts
    53 Posts
       #6  
    Yup, same thing is happening to me.
    I just returned that unit and got another one, same problem.
    Don't know what to do at this point..
  7. eomahos's Avatar
    Member

    Posts
    3 Posts
    #7  
    Hi, guys

    Can someone please advise what to do? I constantly get no signal, and my data bounces between 3G to 4G, no LTE, my area has lighting fast LTE, when i insert the same in on my Iphone5...i almost get 33-35mbps. Not sure, why the signal constantly bounces 2-3 bars, then justs dies at 0....is this an hardware issue? did you guys manage to solve this?

    thanks
    omayer.
  8. eomahos's Avatar
    Member

    Posts
    3 Posts
    #8  
    Hi, how did you solve your issue?
  9. dula714's Avatar
    Member

    Posts
    63 Posts
    #9  
    I have no problem with my Rogers Lumia 920 that works on Fido. I never had to input any settings to the phone. All I had to do was get a LTE sim from Fido and it worked like a charm.

    My cousin, who is on Mobilicity, unlocked his phone and he is getting 4G on Mobilicity.
  10. eomahos's Avatar
    Member

    Posts
    3 Posts
    #10  
    humm not sure. i'm going to try with my rogers sim, if i still get the same issue..then i'm just out of luck...i really think it could be a carrier profile issue? is there an update? and if the still persists, can i send it back to nokia for a replacement considering the fact that i bought the phone from kijiji, but here in montreal, i get really amazing LTE reception on my iphone5. I really hope i can use the lumia, looked really promising.

Posting Permissions

B