Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 22 of 22
Like Tree2Likes
  • 1 Post By oldpueblo
  • 1 Post By jsntrenkler
  1.    #1  
    So I realized that my visual voicemail is not working, and there is very little information ANYWHERE on how to fix it. It works fine when I pop the sim into my iPhone 4S, but then does not in the Lumia 920. Under settings, it says to contact the service provider.

    Long story short, after spending over an hour on the line with the rep, nothing was resolved. She claimed she saw the issue and another team would have to call me back within 24 hours. She stated she had to remove the data plan and add it back, but didn't want to do that since I had the "unlimited" grandfathered plan and she couldn't add unlimited to any account.

    So I am stuck here without getting any sort of voicemail updates. Is visual voicemail working fine for all of you? Has anyone else run into this problem? If so, is there a fix?

    TIA
  2. jwinch2's Avatar
    Member

    Posts
    350 Posts
    #2  
    Others are able to use visual voicemail without issue, there is another thread on it around here somewhere.

    However, I suggest just setting up a youmail account and using the magikmail app on WP and you will be good to go. That way, if you ever switch platforms, or companies, get a new device, etc. it will already be set up, just download the app and you are back in business. I have mine set up so that certain people get certain greetings (my boss gets a professional one, my wife a romantic one, and my friends from college funny ones, etc.) As noted above, if you switch, all of your settings, greetings, old messages that you want to keep, etc. will still be there. I've had it for years now and have kept it from Blackberry, to Android, and now to WP8 and it works great.

    Visual Voicemail For Your Phone | YouMail
    Store search results | Windows Phone Apps+Games Store (United States)
    My smartphone history.
    Thanked by:
  3. oldpueblo's Avatar
    Member

    Posts
    678 Posts
    Global Posts
    837 Global Posts
    #3  
    I had visual voicemail on my 900 and it carried over to the 920, but I had someone switch me on their computer within an AT&T store instead of just popping my SIM in. So maybe they did something. Anyway all I did was call voicemail, enter pin, then hang up. Then it asks you for your pin again via a popup and tada visual voicemail. Same process I followed on the 900, but it is an account type thing not a device type thing.
    Thanked by:
    pjs37 likes this.
  4.    #4  
    Wow, no such popup for me... I will see what they say. Supposedly they are going to call me tomorrow. I will look into that youmail too. Thanks for the tips. :)
  5. EvoKnvl's Avatar
    Member

    Posts
    43 Posts
    Global Posts
    44 Global Posts
    #5  
    I had this come up when I got my HTC One X before. You need to call AT&T and request they add Visual Voicemail to your plan. I noticed you have Unlimited which I have as well. This is the Data plan you need.
    Data Unlimited for 4G LTE w/Visual Voice Mail

    Once you have it, you can do what oldpueblo said to activate the Visual Voice Mail. Mine works no problem.
    Thanked by:
  6.    #6  
    Thanks. She claimed that she wasn't able to change any unlimited data. I didn't want to push it because I have heard people have issues with a rep messing up the data. WHile it's not unlimited, 5GB at $30 is way better than my other options if they screw things up. WHat is strange is that LTE works just fine on my phone, so I am really unsure what the deal is. Hopefully I get a call tomorrow. If not, I will try and call them back and confirm that that is the exact name of the data plan on my account.
  7. EvoKnvl's Avatar
    Member

    Posts
    43 Posts
    Global Posts
    44 Global Posts
    #7  
    No problem. I had the same issue before. I checked my OLAM and that's the actual name of the data plan that is provisioned on my account. My guess is you have the LTE without the Visual VM.
  8.    #8  
    Quote Originally Posted by EvoKnvl View Post
    No problem. My guess is you have the LTE without the Visual VM.
    You are probably right, but I question AT&T's logic of making such a plan. They are priced the same, why not just offer visual VM on the plan and call it a day? Why have a plan without it? :giggle:
  9. fwaits's Avatar
    Member

    Posts
    859 Posts
    #9  
    Yeah VVM is tied to the data plan, but they do have to set it up. If it's setup as basic then you won't get the prompt on the phone to set it up. Call a rep and tell them your VVM isn't working and they should be able to check the account and fix it then the next time you login to your voicemail the old fashioned way and hang up, you should get a prompt to set up VVM.
    "Bro, you know I lift cause I use a Lumia 920..."
  10.    #10  
    Quote Originally Posted by fwaits View Post
    Yeah VVM is tied to the data plan, but they do have to set it up. If it's setup as basic then you won't get the prompt on the phone to set it up. Call a rep and tell them your VVM isn't working and they should be able to check the account and fix it then the next time you login to your voicemail the old fashioned way and hang up, you should get a prompt to set up VVM.
    I basically did exactly that already. I think I just got a clueless rep, to be honest.:mad:
  11.    #11  
    You know, I just logged in online and it says I have the unlimited data LTE with VVM. Very strange. Oh well, bed time lol. Will see if I can sort this tomorrow.
  12. jsntrenkler's Avatar
    Member

    Posts
    56 Posts
    Global Posts
    3,498 Global Posts
    #12  
    If your sim is provisioned for iPhone Visual Voicemail won't work. IPhones have their own provisioning. Same thing goes the other way, have your phone provisioned for the LTE plan and pop into iPhone and Visual Voicemail won't work on that phone. I switch phones often (maybe not so much now I love this phone) and have found that leaving my phone provisioned for LTE (without visual voicemail) provision works best for me. With that setting visual voicemail works on windows phone as well as all the android devices that at&t offers. If I jump to iPhone I use youmail. However I love the way visual voicemail is baked into WP8.
    Thanked by:
    pjs37 likes this.
  13. Beacio_mo's Avatar
    Member

    Posts
    58 Posts
    Global Posts
    167 Global Posts
    #13  
    I had a problem logging into my voicemail too. It kept popping up an error when I entered my voicemail password. Ended up calling my phone from another line, left a message, and when the voicemail showed up on my phone, it popped up a different message that asked for my voicemail password. I entered it and it has worked perfectly since.
  14. #14  
    I had issues at first and when I called support they were pretty clueless. I hung up with no resolution. I then tried chat support and the lady fixed it within minutes. Maybe try that route if u get nowhere on the phone.
  15.    #15  
    So I never got a call, but earlier today I got the pop from VVM asking for my pin. I can only assume they did something on their end? I have yet to tinker with popping the sim back into my iPhone. Haven't really missed the phone at all, but I will try it in a bit just to see what happens.
  16. Landsharkk's Avatar
    Member

    Posts
    280 Posts
    #16  
    Never had this on my previous phone, but now with my Lumia 920/WP8 I always get prompted for my passcode when I try to open the 'phone' app. However, I've also reset my visual voicemail passcode twice on AT&T's website (which defaults to your 7 digit phone number), but it never works.

    So now I'm stuck with a password prompt every time I want to make a call or check voicemail (basically every time I open the "Phone" app).

    The reset passcode for visual voicemail does not work.
  17. mparker's Avatar
    Member

    Posts
    337 Posts
    Global Posts
    347 Global Posts
    #17  
    Quote Originally Posted by Landsharkk View Post
    Never had this on my previous phone, but now with my Lumia 920/WP8 I always get prompted for my passcode when I try to open the 'phone' app. However, I've also reset my visual voicemail passcode twice on AT&T's website (which defaults to your 7 digit phone number), but it never works.

    So now I'm stuck with a password prompt every time I want to make a call or check voicemail (basically every time I open the "Phone" app).

    The reset passcode for visual voicemail does not work.
    Yeah, the reset VVM page at AT&T is a red herring. I ran into this with my L920. WP8 doesn't use that password, it uses the regular voicemail password.

    Quote Originally Posted by lordofthereef View Post
    Wow, no such popup for me...
    This happened to me as well. The fix is to dial in to voicemail with the 611 number, go into administrative options, and change the regular voicemail password. Reboot your phone (to make sure the dialer app is restarted) and go into the dialer app. It should prompt you again for the visual voicemail password - enter the regular voicemail password and you should be good to go.
    Thanked by:
  18. Landsharkk's Avatar
    Member

    Posts
    280 Posts
    #18  
    Quote Originally Posted by mparker View Post
    Yeah, the reset VVM page at AT&T is a red herring. I ran into this with my L920. WP8 doesn't use that password, it uses the regular voicemail password. If that doesn't work, then dial in to voicemail with the 611 number, go into administrative options, and change the regular voicemail password. Restart your phone, and go into the dialer app. It should prompt you again for the visual voicemail password - enter the regular voicemail password and you should be good to go.
    Thank you. I ended up calling 611 and resetting it using the automated process. I then received a txt with a new password.

    Funny thing is after doing that I no longer get prompted for visual voicemail password (I never entered the new password). I even restarted my phone, still no password prompt. I am not sure if visual voicemail is working at all now, guess I'll have to ignore the next call I get to find out. :)
  19. mparker's Avatar
    Member

    Posts
    337 Posts
    Global Posts
    347 Global Posts
    #19  
    In your phone app, do you see both "history" and "voicemail" pivots? If you only see "history", then try rebooting your phone. When I fixed mine I had to reboot before it asked me for my VVM password and I got the "voicemail" pivot.

    I must have gotten lucky when I called AT&T support; my CSR really knew his stuff
  20. TMavC5's Avatar
    Member

    Posts
    592 Posts
    #20  
    Quote Originally Posted by lordofthereef View Post
    So I realized that my visual voicemail is not working, and there is very little information ANYWHERE on how to fix it. It works fine when I pop the sim into my iPhone 4S, but then does not in the Lumia 920. Under settings, it says to contact the service provider.

    Long story short, after spending over an hour on the line with the rep, nothing was resolved. She claimed she saw the issue and another team would have to call me back within 24 hours. She stated she had to remove the data plan and add it back, but didn't want to do that since I had the "unlimited" grandfathered plan and she couldn't add unlimited to any account.

    So I am stuck here without getting any sort of voicemail updates. Is visual voicemail working fine for all of you? Has anyone else run into this problem? If so, is there a fix?

    TIA
    Just call AT&T and have them re-provision so they can activate Visual Voicemail. I had to do this when I first got my L900.
  21. ncxcstud's Avatar
    Member

    Posts
    940 Posts
    #21  
    I had this issue earlier today. What kicked it in for me was just calling my voicemail number and then going out of it. Once I did that the 'popup' came up when I went to the dialing app. Then, I called my voicemail again - set my pin password and voila! Voicemail!

    I never had it on my Focus, but its always been on my data plan. But, now it works on my L920!
    Pastor of All Saints Lutheran Church in Mason, MI
    God's work, our hands.
    Preaching the Gospel.
    Holding a Windows Phone.

  22. fwaits's Avatar
    Member

    Posts
    859 Posts
    #22  
    Quote Originally Posted by ncxcstud View Post
    I had this issue earlier today. What kicked it in for me was just calling my voicemail number and then going out of it. Once I did that the 'popup' came up when I went to the dialing app. Then, I called my voicemail again - set my pin password and voila! Voicemail!

    I never had it on my Focus, but its always been on my data plan. But, now it works on my L920!
    Yes that is how it should work if it is on your data plan correctly. If you call your VM, check messages, then disconnect and it doesn't prompt the VVM sign in, you may need to call and get them to fix it on the account side.
    "Bro, you know I lift cause I use a Lumia 920..."

Posting Permissions