Results 1 to 6 of 6
  1. homegeek's Avatar
    Member

    Posts
    59 Posts
    Global Posts
    146 Global Posts
       #1  
    I have been having some issues I think with IE on my 920 and I want to know if it is just me or a limitation of the OS.

    Can someone with the 920 goto the desktop version of Bestbuy.com and see if you are able to navigate through the navigation tabs at the top of the page. I am unable to and it is very frustrating.
  2. downhillrider's Avatar
    Member

    Posts
    189 Posts
    Global Posts
    236 Global Posts
    #2  
    are you talking about the Products, Services etc tabs? I pressed on that button and waited for th "open link in new tab" to come up and I was able to get to the drop down menu.
  3. homegeek's Avatar
    Member

    Posts
    59 Posts
    Global Posts
    146 Global Posts
       #3  
    Quote Originally Posted by downhillrider View Post
    are you talking about the Products, Services etc tabs? I pressed on that button and waited for th "open link in new tab" to come up and I was able to get to the drop down menu.
    Exactly! But are you able to actually select something in one of those drop down boxes? Everytime I try the menu disappears as soon as I move my finger and it does not work if I slide it.
  4. KoukiFC3S's Avatar
    Member

    Posts
    526 Posts
    Global Posts
    2,612 Global Posts
    #4  
    This seems to be a common problem with mobile browsers. I think my iPhone did that as well.
  5. homegeek's Avatar
    Member

    Posts
    59 Posts
    Global Posts
    146 Global Posts
       #5  
    Quote Originally Posted by KoukiFC3S View Post
    This seems to be a common problem with mobile browsers. I think my iPhone did that as well.
    I never had an issue like that on Android and I just wondered if this is a limitation of the mobile browser on 8.
  6. theefman's Avatar
    Member

    Posts
    2,355 Posts
    Global Posts
    2,356 Global Posts
    #6  
    I get the same with my Windows 8 tablet, site probably needs to be updated for IE10.
    I say we take off and nuke the entire site from orbit. It's the only way to be sure.

Posting Permissions

B