Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 7 of 7
  1. chevans920's Avatar
    Member

    Posts
    189 Posts
       #1  
    Those of us that have been fortunate enough to get the 920, I have a few questions for you.

    I'm running the activation now... And have been for almost an hour - has anyone else seen it take a long time?

    Also, did you get a charger to match your phone? I ordered white, but have a black charger/cable.

    Just wondering.
    Thanks!

    Edit - did you also get earbuds???
  2. MAERSK's Avatar
    Member

    Posts
    213 Posts
    #2  
    all ATT chargers/cables are black & don't come with earbuds
    Thanked by:
  3. chevans920's Avatar
    Member

    Posts
    189 Posts
       #3  
    Quote Originally Posted by MAERSK View Post
    all ATT chargers/cables are black & don't come with earbuds
    Cool deal, thanks, MAERSK! Just wanted to be sure :)
  4. jonesyvoor's Avatar
    Member

    Posts
    30 Posts
    Global Posts
    43 Global Posts
    #4  
    I ordered a white 920 and got a black charging plate. I believe all of the free plates are black.

    Also, my phone worked right out of the box. There was no "activation period".
  5. chevans920's Avatar
    Member

    Posts
    189 Posts
       #5  
    Quote Originally Posted by jonesyvoor View Post
    I ordered a white 920 and got a black charging plate. I believe all of the free plates are black.

    Also, my phone worked right out of the box. There was no "activation period".
    Not the plate, I know that is black. Was talking about the wall charger.

    Looks like a call to AT&T is in order... :(
  6. bauerbach's Avatar
    Member

    Posts
    221 Posts
    #6  
    yeah, all accessories are black, except for the power plug of the charging plate, which is white for some reason.

    I "activated" my phone online, waited 2-3 hours, then chatted with ATT. they had me try my old iphone sim. then back to new sim, than to ech support... finally, it just started working.
    Thanked by:
  7. chevans920's Avatar
    Member

    Posts
    189 Posts
       #7  
    Quote Originally Posted by bauerbach View Post
    yeah, all accessories are black, except for the power plug of the charging plate, which is white for some reason.

    I "activated" my phone online, waited 2-3 hours, then chatted with ATT. they had me try my old iphone sim. then back to new sim, than to ech support... finally, it just started working.
    Thanks! Finally got mine working after some on/off efforts with both phones!

Posting Permissions