Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 11 of 11
  1. D0gsballs's Avatar
    Member

    Posts
    233 Posts
    Global Posts
    239 Global Posts
       #1  
    Hi all.

    apologies if this has been asked before.

    I've been searching the net for a couple of days now to try and find this answer. In Phone Settings there is My Phone Number. I've had my Lumia for a week now and migrated my number over from my old carrier. This completed three days ago, but the number in My Phone Number still shows the new number I got given, not my old number that has been ported.

    It's not a biggie I know, just wondering if anyone knows how to change this?

    Cheers
  2. inteller's Avatar
    Member

    Posts
    2,503 Posts
    Global Posts
    2,508 Global Posts
    #2  
    have you tried turning off the phone and pulling out the SIM, wait a few minutes and put it in and turn on?
  3. D0gsballs's Avatar
    Member

    Posts
    233 Posts
    Global Posts
    239 Global Posts
       #3  
    Yep tried that and still the same. I've asked T-Mobile but not heard back yet. I assume it's the sim but no idea why it hasn't updated.
  4. bnvis's Avatar
    Member

    Posts
    2 Posts
    #4  
    Has this been resolved yet? I'm having the same issue with the Lumia 820. I'm new to Windows Phone and haven't been able to find any settings for this. My number is recognised by call recipients though.
  5. bnvis's Avatar
    Member

    Posts
    2 Posts
    #5  
    Is this resolved yet? Having the same issue with the Lumia 820, though all recipients do receive the right number. Can it be changed in some settings?
  6. D0gsballs's Avatar
    Member

    Posts
    233 Posts
    Global Posts
    239 Global Posts
       #6  
    Yep it seems to have sorted itself out. I suspect it was resolved by logging onto the Windows Phone website and changing my number on there. It took a while but it seems to have finally updated on my phone.
    Thanked by:
  7. phander's Avatar
    Member

    Posts
    92 Posts
    #7  
    I've got this problem too. You can see it in settings>about>more information. THe MDN number for me reports the wrong number (as it does in the main dialer settings).

    I've changed at WP site so I assume it's just a matter of waiting...? Otherwise we need the ##code that allows you to change the MDN.
  8. sNathan's Avatar
    Member

    Posts
    2 Posts
    #8  
    me too, but i've still can sending/recv text messege or make calling.

    phone > ... > settings
    show like this:
    my phone number
    -------------
    +0819xxx
    -------------

    *my country region code +62. As i know +62 = 0, in Indonesia
  9. Yak93's Avatar
    Member

    Posts
    1 Posts
    #9  
    Same issue as everyone above. Did you all manage to change your number?
    Updated mine on My Windows Phone but so far no change in handset settings.

    Dogsballs - do you know what corrected yours? Changing as above or did provider do something?
    Mine categorically states that the handset can't be changed from the original number on the first sim which sounds bonkers.

    Trivial but annoying
  10. Amit Mittal's Avatar
    Member

    Posts
    1 Posts
    #10  
    Go to https://www.windowsphone.com/en-gb/my/account

    Click on Update and change your number.
  11. MartLea's Avatar
    Member

    Posts
    49 Posts
    #11  
    Update to my previous post elsewhere on this issue. Called Three 3 who said they would send out a blank sim which I could then call to have activated with my ported (old) number. Why this can't update on my Lumia 620, WP8.1, I don't know. Will try resetting the number on windowsphone.com anyway.

    OK that didn't work. So will assume I need the blank sim. Meanwhile however I find I can no longer back up my phone, it fails at 96% with the error: "There was a problem backing up your settings. Try again later". Is this because the phone number on my phone don't match the phone number in my Windows account?

    Right, seems there is no way to edit the sim card phone number on Windows phones! Feature has been available on phones for years and still is on Iphone. Only way to do it is to find another phone - not Windows - that will edit the sim or take it to your network provider to edit as far as I can see.
    Last edited by MartLea; 06-11-2014 at 03:28 AM. Reason: New information

Posting Permissions