Results 1 to 6 of 6
  1. kki75's Avatar
    Member

    Posts
    6 Posts
       #1  
    Hi, I'm looking for some advice.

    I've recently lost battery monitoring functionality on my Lumia 900. Not sure when it happened. And now I have no way of really determining how much (if) my battery is charging, discharging, etc.

    Oddly enough, the WP 7.5 battery icon at the top right of the screen still appears to work, and the WP settings "battery saver" seems ok. Maybe that will fail after a full battery discharge?

    Has anyone else seen this (picture attached) from the Nokia diagnostic app?
    OS: 7.10.8779.8
    FW: 2175.2301.8779.12223
    Nokia Diag: 1.17.1.0 (installed by ##634# on the dial pad).

    Do I have a hardware fault in the battery circuits?
    Bug?
    Feature?
    Nokia problem?
    Microsoft WP problem?

    I've already tried to hard reset (and erase) the phone, but the battery diagnostic still shows nothing afterwards.

    Thanks in advance. ..kki
    Attached Thumbnails Attached Thumbnails batt-fault-1.jpg  
  2. percychow's Avatar
    Member

    Posts
    2 Posts
    #2  
    Quote Originally Posted by kki75 View Post
    Hi, I'm looking for some advice.

    I've recently lost battery monitoring functionality on my Lumia 900. Not sure when it happened. And now I have no way of really determining how much (if) my battery is charging, discharging, etc.

    Oddly enough, the WP 7.5 battery icon at the top right of the screen still appears to work, and the WP settings "battery saver" seems ok. Maybe that will fail after a full battery discharge?

    Has anyone else seen this (picture attached) from the Nokia diagnostic app?
    OS: 7.10.8779.8
    FW: 2175.2301.8779.12223
    Nokia Diag: 1.17.1.0 (installed by ##634# on the dial pad).

    Do I have a hardware fault in the battery circuits?
    Bug?
    Feature?
    Nokia problem?
    Microsoft WP problem?

    I've already tried to hard reset (and erase) the phone, but the battery diagnostic still shows nothing afterwards.

    Thanks in advance. ..kki
    You know... when stuff like that happens, back up everything (videos, photos, etc.) and restore the phone. Which is pretty much erasing the phone. IF that doesn't work... AT&T (or the carrier) should be able to replace it under warranty.
  3. kki75's Avatar
    Member

    Posts
    6 Posts
       #3  
    Can anyone confirm that their Lumia 900, US AT&T, with the latest updates (FW: 2175.2301.8779.12223), has a working battery status diagnostic?

    I think a blank diagnostic is a fault/failure, but I'm not able to confirm.

    And the battery saver screen shows rather incredible battery life?
    58% charge after almost 3 days(!), with more than 2 days remaining???

    But that information could be completely bogus, if there exists a physical defect of some kind.
    Last edited by kki75; 03-16-2013 at 11:26 AM. Reason: removed expired link to photo
  4. kki75's Avatar
    Member

    Posts
    6 Posts
       #4  
    I found a staff member at a retail phone store that had an identical phone (well the color was different) with the identical, zune updated, win phone OS 7.5. The battery status display works fine on that phone.

    That means the subject phone (mine) has definitely become defective :(, after less than 6 months. To add, I tried hard resetting and erasing the phone, which does not fix the problem.

    Now the question is whether I should send the bad phone in for warranty service? Besides the battery diagnostic failure, there doesn't seem to be anything else that's not working properly...
  5. n3rfh3rd3r's Avatar
    Banned

    Posts
    545 Posts
    Global Posts
    691 Global Posts
    #5  
    Quote Originally Posted by kki75 View Post
    Now the question is whether I should send the bad phone in for warranty service? Besides the battery diagnostic failure, there doesn't seem to be anything else that's not working properly...
    Consider this:

    Now the question is whether I should send the bad laptop in for warranty service? Besides the battery diagnostic failure, there doesn't seem to be anything else that's not working properly...

    or this:

    Now the question is whether I should send my car in for warranty service? Besides the battery diagnostic failure, there doesn't seem to be anything else that's not working properly...


    There may be underlying problems with the device that you haven't had to deal with yet, or this could be the extent of your problems. So long as you didn't root the device or put it into developer mode and sideload apps I don't see a problem with contacting AT&T for assistance.

    If you can hold out, maybe waiting another 3-4 months might yield a Lumia 920 replacement instead. Just a thought.
  6. kki75's Avatar
    Member

    Posts
    6 Posts
       #6  
    Here's the update on how this was fixed, in case anyone else runs into the same problem.

    Nokia repair center fixed the phone under warranty, with no fault found, by (as far as I can tell) service tool reflashing the phone to the release current at the time of repair (fw ..12223 in this case).

    So the problem was software, where prior updates via Zune did not fix the issue. My further guess/speculation on what the root problem may have been is maybe a software certificate expired, and user accessible update procedures did not update the certificate.

Tags for this Thread

Posting Permissions

B