Results 1 to 3 of 3
  1. bassrocks's Avatar
    Member

    Posts
    3 Posts
       #1  
    My battery has been dying quickly over the past several days. I charge it every night, and then have to charge again by early afternoon. Not only that, but I caught it today doing this:

    1. Looked at battery stats and saw 33% left.
    2. A few minutes later, it was 66%! No, it wasn't plugged in.
    3. 5 minutes after that, battery saver kicked in and it was at 23%.

    So what's up with this? Has anyone else had this happen? What should I do?

    Could the battery be fine, but the OS is reporting it wrong?

    Thanks,
    Andy
  2. techygeek82's Avatar
    Member

    Posts
    189 Posts
    #2  
    Wow. You know I noticed this today myself. I knew that since the last update the meter didn't start registering until after the first 10% was drained. Today however I noted that I checked the battery and it was down to 49% at one point and then jumped to 55%.

    I think there is some weird firmware stuff going on in registering the battery useage. Hopefully when we get the Tango update this will get resolved.
  3. bassrocks's Avatar
    Member

    Posts
    3 Posts
       #3  
    So I caught my phone in an interesting situation today. After just a few hours of use, the phone told me the battery was critically low. I checked Settings, and the Battery Saver screen said it was at 13%. I checked Nokia Diagnostics, and it said 60%. I restarted the phone, and then they both agreed on 60%.

    What's going on here? You'd think the OS would get the battery remaining info from the hardware (and that it would be more or less accurate).

Tags for this Thread

Posting Permissions

B