Results 1 to 9 of 9
  1. jfreiman's Avatar
    Member

    Posts
    31 Posts
       #1  
    Is anyone else's new Lumia 900's battery not charging properly?

    After I disconnect my phone from the charger the phone still indicates that the phone is charging.

    Then, after charging the phone overnight my 900 showed that my battery was fully discharged and rebooted 4 or 5 times before recognizing that it was charged.

    Now I plugged it back into the wall outlet after being charged overnight and is showing that the phone is still charging.

    This seems freakishly familiar - is/was this the same issue the Lumia 800 had?

    my phone has the following firmware:
    2175.0000.8112.12082

    John
  2. ddaniel87's Avatar
    Member

    Posts
    25 Posts
    Global Posts
    36 Global Posts
    #2  
    Quote Originally Posted by jfreiman View Post
    Is anyone else's new Lumia 900's battery not charging properly?

    After I disconnect my phone from the charger the phone still indicates that the phone is charging.

    Then, after charging the phone overnight my 900 showed that my battery was fully discharged and rebooted 4 or 5 times before recognizing that it was charged.

    Now I plugged it back into the wall outlet after being charged overnight and is showing that the phone is still charging.

    This seems freakishly familiar - is/was this the same issue the Lumia 800 had?

    my phone has the following firmware:
    2175.0000.8112.12082

    John
    not that same issue but when plugged into to computer, it shows an empty battery and shuts off.
  3. AlexanderJJJ's Avatar
    Member

    Posts
    132 Posts
    Global Posts
    206 Global Posts
    #3  
    Mine shows it's at 99% battery and I have it plugged in all night.
  4. ggonzalez777's Avatar
    Member

    Posts
    49 Posts
    #4  
    I haven't had those issues yet, but I did notice that my battery is draining extremely fast, 30% in one hour!!! And whenever i plug in the cable to the phone, it sometimes takes a full second til it starts charging.
  5. AlexanderJJJ's Avatar
    Member

    Posts
    132 Posts
    Global Posts
    206 Global Posts
    #5  
    Actually unplugged the phone, turned off the phone, let it drain to about 97%, then turn it back on and put it back on the charger and in a couple minutes it was at 100%, so no problems now. :)
  6. Gaiking's Avatar
    Member

    Posts
    165 Posts
    Global Posts
    278 Global Posts
    #6  
    I actually cant turn the phone off to charge it. As soon as I plug it in it turns on again.
  7. sailorgloom's Avatar
    Member

    Posts
    1 Posts
    #7  
    I bought one for my wife. I liked it so much I bought one for myself. While my Lumia 900 works fine I've had to return hers twice due to battery issues.
  8. puredrive07's Avatar
    Member

    Posts
    30 Posts
    #8  
    I'm getting worried that I may have a battery issue with my L900. It was perfectly fine until Monday night and now it has locked up twice, didn't charge last night and if I turn off the phone and plug it in, it will just flip out and keep restarting/vibrating and showing a low battery warning eventhough the Diagnostics show's I have plenty of battery life.

    Should I hold out until Monday's firmware fix or just exchange it at the store tonight?
  9. theefman's Avatar
    Member

    Posts
    2,356 Posts
    Global Posts
    2,357 Global Posts
    #9  
    Quote Originally Posted by AlexanderJJJ View Post
    Mine shows it's at 99% battery and I have it plugged in all night.
    I have a similar problem, charging all night and checking the phone a few times while its charging sometimes shows its at 100% and sometimes its showing as 99% and still charging. Did you exchange yours or has the problem gone away by itself? Got mine from Amazon so an exchange could give me the same problems since I can't check beforehand. Thanks.

Posting Permissions

B