Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. chasvs's Avatar
    Member

    Posts
    53 Posts
    Global Posts
    1,890 Global Posts
       #1  
    My NL822 has terrible network connectivity on LTE. In Central Florida and often recive cannot connect errors when trying to test or use web browser even when I have LTE signal. Anyone else have this issue? Any resolution?
  2. stephen_az's Avatar
    Member

    Posts
    733 Posts
    Global Posts
    767 Global Posts
    #2  
    I think there must be a pretty significant range of variation with respect to QC in 822 phones. Some have no problems, great reception, etc., and others have issues. My problem isn't constant but there is an intermittent issue with signal quality on my 822 in Phoenix. Sometimes it is fine and others it is poor, even if I am using the phone from the same location. I also need to log off and on visual voice mail to get the phone to stop giving me cannot connect to data messages and actually download voicemail.

    I would have tech support swap it out but contrary to what some people around here think, the refurbished phone they will ship probably really would be refurbished. In my personal experience, VZW has a terrible rep when it comes to properly checking out phones before cycling them into the refurbished pool. A few years back I was sent five HTC TouchPro phones in just about the same number of months. All had either the same problems that prompted the original return or those plus additional problems. All I kept getting were sincere apologies from flustered tech support people until one elevated it and they sent me an Omnia II instead. On my front, I will hold out until the update is released before taking the option of last resort (warranty replacement).
  3. wilks7's Avatar
    Member

    Posts
    67 Posts
    #3  
    i have had similar problems when i am out and about and had connection problems on the data end....i switched in settings under cellular data roaming options to roam....and haven't had an issue since
  4. tomxteam's Avatar
    Member

    Posts
    22 Posts
    #4  
    I cross a mountain pass 2-3 times a week that has some dead zones. When my connection comes back up, sometimes data does not even though LTE may show several bars. If I reboot my device it starts working again, even if I haven't moved locations. Just another fine quirk of the 822.
    Thanked by:
    wilks7 

Posting Permissions