Results 1 to 3 of 3
  1. franmav4's Avatar
    Member

    Posts
    3 Posts
       #1  
    I am finding that my data does not switch over automatically to my Wifi at home even though it shows connected. This explains my high data usage compared to my previous andriod phone.

    Unless I am doing something wrong, I still see that my data icon is running as well as my wifi. I assumed this was normal for WP8 but it made me think when first got the phone "which one am I connected to?". You would think that once you are connected to wifi, that is where your data is coming though so you don't use your limited data.

    I checked this by going to check my external IP on my device which shows that it is connected to my phone provider and as soon as I connect at my home wifi, this IP remains the same. As soon as I disable my data, the external IP immediately changes to my home broadband. Switching the data back on will leave it on my home broadband External IP until I disconnect.

    I do not want to keep switching my data on and off everytime just to get around this.

    Has anyone else found this? I do not have the portico update as yet!
  2. Chregu's Avatar
    Member

    Posts
    4,819 Posts
    #2  
    Quote Originally Posted by franmav4 View Post
    Has anyone else found this? I do not have the portico update as yet!
    Before Portico there was no option to keep WiFi on. So, every time your phone goes into standby, the connection is lost. Could this be the reason for the behavior you're describing?
  3. franmav4's Avatar
    Member

    Posts
    3 Posts
       #3  
    Thanks for your response Chregu,

    The symptoms im experiencing are while the phone is in use (in the same session before it goes on standby). So I would unlock it, switch on wifi, wait at least 30 seconds for the icon to appear connected (plus checking it is connected in the wifi settings). Check my external IP and it would still be my Phone Providers IP (still going through data). It will only decide to go through my wifi internet once I switch the data off.

    I wouldn't really mind so much if I had unlimited data but I had picked up elsewhere that others have been getting unusually high data usage since migrating to WP8.

    Perhaps the Portico update will resolve this.

Similar Threads

  1. Data Roaming prompt when connecting to wifi
    By Br1anK in forum Windows Phone 8
    Replies: 0
    Last Post: 01-17-2013, 05:20 AM
  2. Replies: 5
    Last Post: 12-30-2012, 08:33 AM
  3. Phone is not connecting to wifi
    By Bartdog in forum Nokia Lumia 900
    Replies: 2
    Last Post: 10-03-2012, 04:39 PM
  4. HTC Arrive will not connect to wifi
    By Starlifter27 in forum Windows Phone 7
    Replies: 20
    Last Post: 11-25-2011, 05:41 AM
  5. Replies: 5
    Last Post: 10-21-2011, 12:02 PM

Posting Permissions

B