Results 1 to 2 of 2
  1. Lukas Treigys's Avatar
    Member

    Posts
    1 Posts
       #1  
    Hi, so lately i'm having a problem turnning my phone on.. Every time that i turn it on, it shows battery logo and one bar, than after few minutes it trys to boot up and shows me "NOKIA" logo. And nothing happens, i tryed that reset thing, doesn't work. Every time that i try to boot it up, it shows i need to charge it and than NOKIA logo just never goes away, can anyone help me?
    Mode: Lumia 800
  2. WorzelGummage's Avatar
    Member

    Posts
    1,043 Posts
    Global Posts
    1,046 Global Posts
    #2  
    Does your phone not charge at all when connected to a charger? Try using a different charger if you can and also, just leave it plugged in for an hour or so to see if the phone springs to life. Otherwise, you may have a defective battery which might need to be replaced.

Similar Threads

  1. What does everyone think of the Glance screen?
    By Narse77 in forum Nokia Lumia 1020
    Replies: 49
    Last Post: 04-02-2014, 07:47 PM
  2. Unlocked Nokia 920 and T-Mobile -- MMS not working
    By Lizr0204 in forum Nokia Lumia 920
    Replies: 18
    Last Post: 01-13-2014, 09:06 PM
  3. New update on My lumia 920 :)
    By AHMAD DADFAR in forum Nokia Lumia 920
    Replies: 14
    Last Post: 08-07-2013, 03:54 PM
  4. Data Sense on unbranded phone?
    By Rob van Uden in forum Windows Phone 8
    Replies: 10
    Last Post: 08-06-2013, 09:03 PM
  5. Nokia Product Care Suite Error...
    By Msallvideo in forum Nokia Lumia 920
    Replies: 8
    Last Post: 08-06-2013, 04:08 PM

Posting Permissions

B