Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. deadly.devilz's Avatar
    Member

    Posts
    1 Posts
       #1  
    I had bought the Nokia lumia 800 on 16th December,2011 . The very first day it was launched here in India. Since the first day it does not dial. Whenever I dial a number , it shows dialing and then call ended. What kind of a phone doesn't dial ! I went to Nokia care and they repaired it and gave it back to me. This problem is occurring again and again and they donot give me a replacement.

    Can any update fix this problem? What's the point of a phone which doesn't dial.
  2. #2  
    Where did you buy the phone from? Perhaps you could try and get a replacement from them. Could it be a problem with your carrier?
  3. Sib85's Avatar
    Member

    Posts
    11 Posts
    Global Posts
    12 Global Posts
    #3  
    hopefully these tricks could help, i've read it from the net few weeks back when i had the same problem a you. the thing is the phone won't be able to 'dial' or 'call' any number that is not in the list from the contacts...

    1. go to call settings under the 'phone' icon and set 'show my caller ID' to everyone, try calling numbers that is not in your contact list, if it's still not working...

    2. set the 'show my caller ID' to my contacts, pull out the SIM card and put it back in. Set 'show my caller ID' back to everyone and then restart the phone.

    hopefully by then the phone should behave normally afterwards, i'm going to search back where these source came from, it does help me and i guess it should help you too! ;)

    here's the site where i found out the solution http://www.askmefast.com/My_nokia_lu...na1849369.html

    Here is the solution for that. In dailler pad,select call settings .. Select option show my caller id to .My contacts ..then press back button then dail and check ny one number in your contacts.It will be dailled. After this again come back to the caller stettings ,it will b showing everyone.again select to My contacts.after its done dont press back button again change it to the everyone.then press back button. Now tourn off your mobile ,remove your sim card.then turn on your mobile without sim card .again turn off your mobile now insert your sim card and restart it properly.. It will work.. It worked for me

    Read more: My nokia lumia 800 is unable to make outgoing calss? - My nokia lumia 800 is unable to make outgoing calls, whenever i m calling it shows call ended. :: Ask Me Fast at http://www.askmefast.com/My_nokia_lu...na1849369.html
    Last edited by Sib85; 07-04-2012 at 11:21 AM. Reason: credits to the original poster
  4. Jamie Hughes1's Avatar
    Member

    Posts
    2 Posts
    #4  
    I've got a similar problem at my end, except with some differences. I just bought my Nokia Lumia 800 2 days ago from CEX. Today I bought an orange sim (to which the phone is locked to) and popped it in. Firstly, I get a full signal and the phone no longer prompts me for a sim. But I can't view my phone number in the settings and my calls cannot be connected. As of yet the only outcome I can find to this problem is that it's likely the phone is barred. I'm hoping that i'm wrong and somebody can help me. If not i'll just have to return the phone.

    Thanks
    Jamie
  5. Jamie Hughes1's Avatar
    Member

    Posts
    2 Posts
    #5  
    Quote Originally Posted by Jamie Hughes1 View Post
    I've got a similar problem at my end, except with some differences. I just bought my Nokia Lumia 800 2 days ago from CEX. Today I bought an orange sim (to which the phone is locked to) and popped it in. Firstly, I get a full signal and the phone no longer prompts me for a sim. But I can't view my phone number in the settings and my calls cannot be connected. As of yet the only outcome I can find to this problem is that it's likely the phone is barred. I'm hoping that i'm wrong and somebody can help me. If not i'll just have to return the phone.

    Thanks
    Jamie
    No worries folks, i've sorted it now.

    JAMIE

Posting Permissions