Page 1 of 2 12 LastLast
Results 1 to 25 of 32
Like Tree3Likes
  1. SkywolfNYNE's Avatar
    Member

    Posts
    3 Posts
       #1  
    hey guys, i'm a android person but got my gf a lumia 521 and she loved it. I ended up purchasing one of the "bring your own phone" sim card kits for t mobile prepaid since the guy i bought the phone off of didn't give me a sim card with it but when the sim card was inserted the phone displayed some error message about the sim card (unfortunately i wasn't there when she put the sim card in so i don't know exactly what it said ) and now the phone wont boot up past the nokia screen, it goes straight to a blank blue screen and nothing else. any ideas what happened or how i can fix this? thanks.
  2. Corepc's Avatar
    Member

    Posts
    1,158 Posts
    #2  
    Take the sim card out what happens...

    Reset the phone press hold power vol up+vol down
    Nokia Lumia 521 (GDR3/Black) - TMobile Prepaid Unlimited + 2.5gb Hotspot
    New-Nokia Lumia AT&T 520 - Net10 AT&T
    Broke - Focus Flash (Locked) OS=7.10.8862.14 (Net10 AT&T)
    Net10/Straight Talk AT&T Apn Data for Samsung Wireless Manager
  3. SkywolfNYNE's Avatar
    Member

    Posts
    3 Posts
       #3  
    It always go back to the blue screen with or without simcard. And doing the resets I even managed to get it to freeze on a lightning bolt and a gear symbol. I'm running out of ideas to get it to boot
  4. stevethenerd's Avatar
    Member

    Posts
    42 Posts
    #4  
    Contact Nokia... That sounds really bad. Being a new phone it should qualify for service.
  5. #5  
    Perhaps use Nokia care suite to due a firmware reset on the phone?
  6. Skohn's Avatar
    Member

    Posts
    3 Posts
    #6  
    I am having the same problem!!! Today is only the 18th day I have owned the new Lumia 521.. It was fine this morning.. then on my way to work I pulled it out & it was turned off without me doing so.. When I powered it back on, it showed booted the Nokia name, then T-Mobile, then a blue screen & then turns off.. If I have it plugged into the charger and try to power on it does the exact same thing over & over again until I unplug it.. I have tried to reboot/master reset every way possible both with & without the sim card... I do not know what else to do!! Nothing I try works.. Its just stuck on blue! :(
  7. Skohn's Avatar
    Member

    Posts
    3 Posts
    #7  
    I have also managed to get my phone to show the lighting bolt & gear symbol.. as well as a " ! " symbol.. I'm am totally lost on wth is going on with this phone.. :(
  8. #8  
    Quote Originally Posted by Skohn View Post
    I have also managed to get my phone to show the lighting bolt & gear symbol.. as well as a " ! " symbol.. I'm am totally lost on wth is going on with this phone.. :(
    Have it replaced. If you're sure you've tried everything in your power to repair it, have it replaced.
    Apparently, there is not a single trace of Segoe UI on this forum.
  9. SkywolfNYNE's Avatar
    Member

    Posts
    3 Posts
       #9  
    ah the only problem with getting it replaced is that i bought it off a friend :( i will google that nokia care suite thing though thanks for the tip. i wish it was like an android where you can just plug it in and volia full access to install and reset like magic. i dont see what the big appeal for windows phones are if they blue screen like a desktop haha
  10. nomegustaios's Avatar
    Member

    Posts
    10 Posts
    #10  
    If you are getting a "Lightning bolt and a gear" normally this is achieved by holding the volume up plus the volume key.

    The proper way to reset the device is to:
    With the phone turned off, press Power key to turn ON the phone, then immediately press and hold Volume Down key.

    • An ! mark will appear on the display.
    • Press the following keys in this order:
      1. Volume Up
      2. Volume Down
      3. Power Key
      4. Volume Down
    Thanked by:
    gomaryaoni 
    ryaoni, goma and troysyx like this.
  11. Skohn's Avatar
    Member

    Posts
    3 Posts
    #11  
    Thank you Nomegustaios!!! That worked perfect!! I am happy again.. My blue screen is now gone!!
  12. daisyroberts's Avatar
    Member

    Posts
    1 Posts
    #12  
    Ah my phone had the blue screen too. Then i did the power button power down, and the rest of the procider now when i try to turn it on it comes up with a 'Windows Boot' Screen. It says i have to insert my windows installation disc and restart my computer. I have No idea what this is?? so annoyed
  13. Gilbert Wright's Avatar
    Member

    Posts
    1 Posts
    #13  
    Hi, The message probably said" Sim card has to be updated, This is what happened to me when I got my Samsung s2 with sim included. This is how they get you
    .You have to go to their store and get a new card and when you leave, you end up with a contract when they say there is no contract.
  14. Kenneth Wilson's Avatar
    Member

    Posts
    1 Posts
    #14  
    i got the same boot screen too :(( any ideas?
  15. ryaoni's Avatar
    Member

    Posts
    20 Posts
    #15  
    My wife had the same thing (blue screen) happen with her Lumia 925, only 2 weeks after buying it. We tried all the resets and T-Mobile had to send a replacement.
  16. #16  
    @nomegustaios

    Thanks a lot man..it worked!!!
    kudos
  17. tomarlyn's Avatar
    Member

    Posts
    1 Posts
    #17  
    Quote Originally Posted by nomegustaios View Post
    If you are getting a "Lightning bolt and a gear" normally this is achieved by holding the volume up plus the volume key.

    The proper way to reset the device is to:
    With the phone turned off, press Power key to turn ON the phone, then immediately press and hold Volume Down key.

    • An ! mark will appear on the display.
    • Press the following keys in this order:
      1. Volume Up
      2. Volume Down
      3. Power Key
      4. Volume Down
    That fixed my issue with the blank blue screen and continuous self reboots. Now I've got a pair of gears turning, factory reset?

    Anyway thankyou I nearly wanted to pull my hair out. Just gonna wait and see what happens now.

    ***update*** yeah a factory reset happened, at least its working. Bless you sir.
  18. Rohit Agarwal2's Avatar
    Member

    Posts
    2 Posts
    #18  
    how mch time it normally takes for factory reset ???? mine happening frm last half n hr
  19. Rohit Agarwal2's Avatar
    Member

    Posts
    2 Posts
    #19  
    hey do u noe hw mch tym it takes for factory reset ??
  20. Tracy Cousins's Avatar
    Member

    Posts
    2 Posts
    #20  
    Omg I tried everything,took to repair and they said no fix....thank u so much
  21. Tracy Cousins's Avatar
    Member

    Posts
    2 Posts
    #21  
    omg it's still happening, if i push the up button it ask me do i want a custom os system, i say yes and press up and it's just sits there for an hour on the same screen sayig downloading, then i stoped that then i did the down button and it's back to the same thing, it wont boot up to the main menue and it wont let me do a master reset I believe, what do i do? how does this even happen, is there a site i can go to to hook my phone up and let the computer do it'?
  22. #22  
    Thanks :) It works
  23. #23  
    when i want to switch off the keybad tone,and sound played afta checking airtime.and reducing data usage
  24. #24  
    my lumia 520 did exactly the same today........am confused
  25. skerro's Avatar
    Member

    Posts
    1 Posts
    #25  
    I just got my Nokia Lumina 521 two months ago. I just got the BSOD yesterday. I just tried to

    -power on, press and hold volume down button..
    Then volume up, volume down, power...and it still gives me blue screen.any thoughts to fix this issue
Page 1 of 2 12 LastLast

Similar Threads

  1. 822 Wont boot passed NOKIA screen
    By ibbyj in forum Nokia Lumia 822
    Replies: 6
    Last Post: 04-11-2013, 08:20 AM
  2. Replies: 0
    Last Post: 01-15-2013, 09:06 AM
  3. Replies: 1
    Last Post: 12-16-2012, 03:17 PM
  4. Grip Of Death!
    By peestandingup in forum HTC TITAN
    Replies: 17
    Last Post: 12-13-2011, 05:13 PM
  5. Yikes! Phone wont charge~!
    By jalb in forum Samsung Focus
    Replies: 2
    Last Post: 05-17-2011, 02:56 PM

Posting Permissions

B