Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 4 1234 LastLast
Results 1 to 25 of 85
Like Tree3Likes
  1. lovenokia's Avatar
    Member

    Posts
    436 Posts
    Global Posts
    56 Global Posts
       #1  
    I have a lumia 1520 on the dev preview, and now I want to revert back to 8.0, but it seems that the software recovery tool is not able to reset my lumia 1520. Are there any tips on how to get this software to work?
  2. MDK22's Avatar
    Member

    Posts
    541 Posts
    PIN
    No
    #2  
    working on it, NOW.
    You have to d/l the latest version (Nokia Software Recovery tool) from Nokia USA.

    Painfully slow d/l the ROM (to 8.0), more to come ....
    if this helped, press the THANKS button ... muchas gracias

    -
  3. biciracer's Avatar
    Member

    Posts
    2 Posts
    #3  
    Same here, no luck.
  4. Aviad Kohn's Avatar
    Member

    Posts
    87 Posts
    #4  
    Happened to me. Remove your sim and try again. Worked with two Lumia 1520 on a windows 8.1 PC
    Thanked by:
  5. Kevin_STLTechTalk's Avatar
    Member

    Posts
    27 Posts
    Global Posts
    200 Global Posts
    #5  
    Odd, worked for me. I had to repair the Recovery Tool after the initial install for whatever reason.

    Uninstall the Recovery Tool and reinstall it then try again.
  6. biciracer's Avatar
    Member

    Posts
    2 Posts
    #6  
    The SIM thing did not work for me, so am curious to see your results. I also didn't try the recovery tool install yet but am not sure that this is the root cause.
  7. #7  
    Odd question, but have you usb 3.0 and usb 2.0 ports on the pc?

    If so try to use one of the usb 3.0, that got mine working.

    Edit.

    Is the 1520 showing the Nokia logo in "BIG" text when you get this error?
    If not, what i did was install the "Nokia Software Updater for Retail" and got a second error, after that i could use the "nokia recovery tool" just fine(on a usb 3.0 port, cuz F logic).
  8. Carlos002's Avatar
    Member

    Posts
    37 Posts
    #8  
    Not working for me either, lumia 822, verizon, windows 7pc, help
  9. BRC1711's Avatar
    Member

    Posts
    77 Posts
    Global Posts
    78 Global Posts
    #9  
    I'm on my 3rd attempt now. The first two times the download completed then just started again with no error message.

    Posted via Windows Phone Central App
  10. #10  
    change download destination in settings, you might have not enuff space left.
  11. BRC1711's Avatar
    Member

    Posts
    77 Posts
    Global Posts
    78 Global Posts
    #11  
    I have plenty of space left but if it fails this time I'll try changing the destination

    Posted via Windows Phone Central App
  12. MDK22's Avatar
    Member

    Posts
    541 Posts
    PIN
    No
    #12  
    Worked for me (downloading CYAN now for my AT&T 1520). I went to the Nokia site to get the latest Software Recovery tool, hmmmm
    if this helped, press the THANKS button ... muchas gracias

    -
    Thanked by:
  13. mparker's Avatar
    Member

    Posts
    351 Posts
    Global Posts
    361 Global Posts
    #13  
    Quote Originally Posted by BRC1711 View Post
    Is it supposed to be downloading the same software version as what I already have?
    Not if you have the dev preview. Unfortunately I'm having the same problem as you...
  14. #14  
    Mine did that to, btw the software has the same name so to answer the question, YES it is suppose to have the same "name" :S

    Don*t ask me why but it seems like the Nokia recovery ****e picks up black update not the os installed.
    so the "os" number is the same you are downloading that is on your current phone.
  15. Blacklac's Avatar
    Member

    Posts
    1,452 Posts
    Global Posts
    4,002 Global Posts
    #15  
    I just left mine downloading and I'm pretty sure it was downloading the same OS that's on my phone, as well. Makes sense though, if we are on AT&T and they just released the newest OS. I'm assuming we will have to manually download GDR3 and install it?
    Lumia 1020 & 1520 on Cyan, OS 8.1 Update 1.
    Nexus 7 (2013) on 4.4.4 stock
    Lumia 2520 WinRT 8.1
  16. #16  
    Quote Originally Posted by Blacklac View Post
    I just left mine downloading and I'm pretty sure it was downloading the same OS that's on my phone, as well. Makes sense though, if we are on AT&T and they just released the newest OS. I'm assuming we will have to manually download GDR3 and install it?
    I dont know how it works for you.
    But mine downloaded the Latest Black update(wp8), even doh it had the same number as DP(8.1p) black i got back to wp8(black).
  17. wspaw's Avatar
    Member

    Posts
    24 Posts
    #17  
    I got the error message too. After that I am prompted to: 1. Hold the power and volume down keys until the phone vibrates and 2.Press OK to continue. Then it says to connect the phone (which is connected) and finally goes back to 1 and 2. This cycle repeats endlessly.

    I've tried reinstalling the tool...
  18. missylob's Avatar
    Member

    Posts
    4 Posts
    #18  
    Quote Originally Posted by wspaw View Post
    I got the error message too. After that I am prompted to: 1. Hold the power and volume down keys until the phone vibrates and 2.Press OK to continue. Then it says to connect the phone (which is connected) and finally goes back to 1 and 2. This cycle repeats endlessly.

    I've tried reinstalling the tool...
  19. wspaw's Avatar
    Member

    Posts
    24 Posts
    #19  
    Not seeing a response, missylob...

    I've tried USB 2 and 3 ports, several cables, including the Nokia cable.

    Has anyone tried a hard reset?
  20. wspaw's Avatar
    Member

    Posts
    24 Posts
    #20  
    Quote Originally Posted by biciracer View Post
    The SIM thing did not work for me, so am curious to see your results. I also didn't try the recovery tool install yet but am not sure that this is the root cause.
    Didn't work for me, either.
  21. Keith Brooks's Avatar
    Member

    Posts
    17 Posts
    #21  
    I'm having a similar problem. The Nokia Recovery Software installs no problem on my Windows 8.1 Pro w/Media Center x64 pc. It's running the recent update to Windows 8.1. The Windows Phone app on my pc's desktop see's my Lumia 521 running Windows Phone 8.1 Developer Preview. The Nokia Software Recovery Tool doesn't see my phone, at all.I've done 2 factory resets through settings > about on the phone. Each time it reinstalled Windows Phone 8.1 Developer Preview with the Black update. In the USA, T-Mobile still has Cyan listed as, Under Testing.
  22. wspaw's Avatar
    Member

    Posts
    24 Posts
    #22  
    Quote Originally Posted by Keith Brooks View Post
    I'm having a similar problem. The Nokia Recovery Software installs no problem on my Windows 8.1 Pro w/Media Center x64 pc. It's running the recent update to Windows 8.1. The Windows Phone app on my pc's desktop see's my Lumia 521 running Windows Phone 8.1 Developer Preview. The Nokia Software Recovery Tool doesn't see my phone, at all.I've done 2 factory resets through settings > about on the phone. Each time it reinstalled Windows Phone 8.1 Developer Preview with the Black update. In the USA, T-Mobile still has Cyan listed as, Under Testing.
    Mine saw the phone, recognized it and downloaded the ROM. The install, however, fails every time. Then the cycle begins...
  23. prjkthack's Avatar
    Member

    Posts
    228 Posts
    PIN
    No
    #23  
    When your phone shows the large NOKIA logo, if you check Device Manager, do you see a device in there that is unrecognized or not properly working (sometimes Windows will also pop-up a message that says your device could not be recognized)? More than likely, proper drivers are not being installed for your device.

    Couple of things I tried to get it working:

    1. Restart the phone.
    2. Restart the computer.
    3. Uninstall/restart/reinstall Nokia software.
    4. Switch USB ports. (For me, switching from a USB 3 to a USB 2 plug worked).
    5. Go into the Device Manager and remove any devices that were not installed properly or were having issues.
    prjkthack
    Nokia Lumia 1020, Nokia Lumia 1520, iPhone 6
    Surface Pro 128GB
  24. wspaw's Avatar
    Member

    Posts
    24 Posts
    #24  
    Ok. Flashed stock ROM using Nokia Care Suite from here:[Tutorial] Unbrand (flash) all Nokia Windows… | Windows Phone 8 | XDA Forum.

    Had the same issue with the software losing the USB connection. Just had to time it right - turn off the phone, click Retry, then very quickly plug it in and when it turned on the connection was established.
  25. #25  
    I can't get it to recognize my phone is plugged in. The windows phone app for win 7 won't recognize it after installing the recovery tool. Have tried all the tips in this thread nothing works. So ******* annoying!!!!!! My computer installs drivers and sees my phone but NOTHING ELSE DOES!!!!!

    Trying the nokia care suite guide posted directly above me I guess.... Well.. that didn't work either.

    Guess I screwed up... Stupid phone won't even restore the backup I made before starting this whole mess.

    Maybe tomorrow I'll have more luck.
    Last edited by NastySasquatch; 07-25-2014 at 03:29 AM.
Page 1 of 4 1234 LastLast

Similar Threads

  1. Is this the end... ?
    By Talderon in forum Cortana
    Replies: 14
    Last Post: 07-28-2014, 10:48 AM
  2. Nokia Color Shells now available at MS Store
    By jiovine in forum Nokia Lumia 635
    Replies: 2
    Last Post: 07-25-2014, 07:44 PM
  3. Nokia 930 recording sound and speaker
    By Stephen Lynam in forum Nokia Lumia 930
    Replies: 1
    Last Post: 07-24-2014, 08:49 PM
  4. Anybody know how to get subtitles to work on WP8.1?
    By rizzo183 in forum Windows Phone Apps
    Replies: 2
    Last Post: 07-24-2014, 04:23 PM
  5. Replies: 3
    Last Post: 07-24-2014, 04:19 PM

Posting Permissions