Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 11 of 11
  1. ninjaap's Avatar
    Member

    Posts
    2,454 Posts
    Global Posts
    2,466 Global Posts
       #1  
    Why is my RT only able to get between 50-65mbps on the same home network that my VAIO is able to get about 144mbps?
  2. rx74ray's Avatar
    Member

    Posts
    79 Posts
    #2  
    whats is your routers brand and model?
  3. ninjaap's Avatar
    Member

    Posts
    2,454 Posts
    Global Posts
    2,466 Global Posts
       #3  
    Linksys e1200 (N300)
  4. rx74ray's Avatar
    Member

    Posts
    79 Posts
    #4  
    Your router has a 2x2 MIMO antenna. It can operate at 5Ghz and 2.4Ghz simultaneously covering N and G bands. So something is wrong here as you mentioned.
    Your Surface is forced to use the G band instead of N. This usually is achieved by a handshake between the devices. This is what I suggest.


    1. Turn off all your wireless devices,
    2. Reboot router.
    3. Logon to your router and make sure nothing is connected wirelessly. This ensures antennas are free and not locked into any bands.
    4. Power on surface and check your connection speed/band to see if it uses faster. N band.


    if still shows as slow 50 mbps, that could mean the auto negotiate for band selection is not working right.On surface you can force N band selection. this is done through adapter configuration and settings. if you cannot find this I can send you details later when I get home.


    good luck
    Thanked by:
  5. ninjaap's Avatar
    Member

    Posts
    2,454 Posts
    Global Posts
    2,466 Global Posts
       #5  
    Quote Originally Posted by rx74ray View Post
    Your router has a 2x2 MIMO antenna. It can operate at 5Ghz and 2.4Ghz simultaneously covering N and G bands. So something is wrong here as you mentioned.
    Your Surface is forced to use the G band instead of N. This usually is achieved by a handshake between the devices. This is what I suggest.


    1. Turn off all your wireless devices,
    2. Reboot router.
    3. Logon to your router and make sure nothing is connected wirelessly. This ensures antennas are free and not locked into any bands.
    4. Power on surface and check your connection speed/band to see if it uses faster. N band.


    if still shows as slow 50 mbps, that could mean the auto negotiate for band selection is not working right.On surface you can force N band selection. this is done through adapter configuration and settings. if you cannot find this I can send you details later when I get home.


    good luck
    I turned off all devices and rebooted router. I got up to 65mbps standing right next to the router, which is what I usually get and it's the max speed I have ever seen. I don't think its limiting the Surface's adapter to G because it's over 54mbps. I've gone through "change adapter settings" under "network and sharing center" but I cant find anything to force it to stay on N.
  6. ninjaap's Avatar
    Member

    Posts
    2,454 Posts
    Global Posts
    2,466 Global Posts
       #6  
    I tried setting the router to N mode only and only had my Surface connected wirelessly and still only get 65mbps. It seems like, for some reason, the max is 65mbps.

    Are you or anyone else reading this getting above 65mbps?

    capture.jpg
  7. rx74ray's Avatar
    Member

    Posts
    79 Posts
    #7  
    When I looked at your routers support page I saw a few firmware updates. Go ahead and flash the firmware to latest version.
    Thanked by:
  8. ninjaap's Avatar
    Member

    Posts
    2,454 Posts
    Global Posts
    2,466 Global Posts
       #8  
    Quote Originally Posted by rx74ray View Post
    When I looked at your routers support page I saw a few firmware updates. Go ahead and flash the firmware to latest version.
    Updating my router's firmware is how I ended up with this new N router. A couple days ago, I totally messed up my old Netgear G router when I tried to update it and it bricked. So I'm a little hesitant. I think I'll try a refresh of the Surface first before updating router. :) But thank you for letting me know about the updates. You've been very helpful.
  9. ninjaap's Avatar
    Member

    Posts
    2,454 Posts
    Global Posts
    2,466 Global Posts
       #9  
    And the refresh did it! Im getting 130mbps now!

    screenshot-1-.jpg
  10. rx74ray's Avatar
    Member

    Posts
    79 Posts
    #10  
    I am glad to hear that. Did you switch your router back to mixed mode (b, g, n) ?
  11. ninjaap's Avatar
    Member

    Posts
    2,454 Posts
    Global Posts
    2,466 Global Posts
       #11  
    Yes I did change it back before the refresh. It could very well be the combination of router reboot and Surface refresh that fixed it. Thank you!

Similar Threads

  1. Replies: 19
    Last Post: 01-09-2014, 12:40 PM
  2. Skidrive icon does not show in Windows Explorer on my RT
    By mapexvenus in forum Microsoft Surface for Windows RT
    Replies: 17
    Last Post: 11-02-2012, 04:28 PM
  3. Replies: 6
    Last Post: 11-06-2011, 11:01 AM
  4. Wifi Sleep Problems on HTC 7 Pro from Cellcom?
    By nickmiller71 in forum Windows Phone 7
    Replies: 2
    Last Post: 10-16-2011, 06:52 AM
  5. Replies: 10
    Last Post: 10-16-2011, 02:06 AM

Posting Permissions