Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 22 of 22
  1. nasellok's Avatar
    Member

    Posts
    226 Posts
    Global Posts
    242 Global Posts
       #1  
    I have been using my 4g Galaxy Nexus (rooted) for wifi tethering my ipad for a while now, and decided to upgrade my itoy to a device that actually can do some work for me. Only thing is, that when i turn on my hotspot, the surface sees it, and i can connect, but it tells me that connection is limited, and nothing works. Not sure why - as i can connect fine with my ipad. Any suggestions why this might happen?
  2. LimeSoda's Avatar
    Member

    Posts
    12 Posts
    #2  
    I had this issue too on one or two occasions when I was out and about. However recently its been working better at home. The 3g signal is much better at home, so I wonder if that's related (I placed the phone against the window to get the best signal indoors)
  3. TeknoBlast's Avatar
    Member

    Posts
    210 Posts
    #3  
    I tether my Surface to my HD7 and no issues. There was a couple of times that I get the same issue as you, but all I did was restart both devices and problem solved. Since then, it has always connected just fine.
  4. nasellok's Avatar
    Member

    Posts
    226 Posts
    Global Posts
    242 Global Posts
       #4  
    Quote Originally Posted by TeknoBlast View Post
    I tether my Surface to my HD7 and no issues. There was a couple of times that I get the same issue as you, but all I did was restart both devices and problem solved. Since then, it has always connected just fine.
    Thanks, will try to restart, and see what happens
  5. Skaughtto's Avatar
    Member

    Posts
    53 Posts
    #5  
    I tether to my Lumia 710, no problems.
  6. paulm187's Avatar
    Member

    Posts
    273 Posts
    #6  
    I tether to my Lumia 920 no problems, I have noticed that if the signal isn't good like 1 bar the Surface reports limited. Make sure you have applied all the windows updates to the surface.
  7. Digital Moe's Avatar
    Member

    Posts
    176 Posts
    Global Posts
    179 Global Posts
    #7  
    I had this issue with my Lumina 920 had to restart the device and that fixed the issue. I had only just restarted the phone the night before so this could be a on going issue.
  8. nasellok's Avatar
    Member

    Posts
    226 Posts
    Global Posts
    242 Global Posts
       #8  
    OK - so im still getting limited connectivity for tethering - Ive tried all of the wifi registry tweaks, etc, but am not having any luck. My phone broadcasts just fine - my ipad connects, my old android phone will connect, my wifes android phone, even my xp laptop will connect...but for some reason my surface RT says limited connectivity - Ive tried WPA, WPA2, etc. no luck. Makes no sense, and is really crippling me in my efforts to take this thing places with no wifi. At this point, if I know im going someplace without wifi, and will need a bigger screen than my phone, I am forced to take my ipad (sigh). Anyone else having this issue?

    Quote Originally Posted by nasellok View Post
    I have been using my 4g Galaxy Nexus (rooted) for wifi tethering my ipad for a while now, and decided to upgrade my itoy to a device that actually can do some work for me. Only thing is, that when i turn on my hotspot, the surface sees it, and i can connect, but it tells me that connection is limited, and nothing works. Not sure why - as i can connect fine with my ipad. Any suggestions why this might happen?
  9. pedenske's Avatar
    Member

    Posts
    193 Posts
    Global Posts
    196 Global Posts
    #9  
    Im not sure about this but can you change the SSID of the wifi your phone is broadcasting. I remember seeing something about the how surface cant connect if the name has symbols or numbers or something like that. A bit of a long shot but hope this may help.
  10. shn'g's Avatar
    Member

    Posts
    175 Posts
    Global Posts
    482 Global Posts
    #10  
    Quote Originally Posted by nasellok View Post
    OK - so im still getting limited connectivity for tethering - Ive tried all of the wifi registry tweaks, etc, but am not having any luck. My phone broadcasts just fine - my ipad connects, my old android phone will connect, my wifes android phone, even my xp laptop will connect...but for some reason my surface RT says limited connectivity - Ive tried WPA, WPA2, etc. no luck. Makes no sense, and is really crippling me in my efforts to take this thing places with no wifi. At this point, if I know im going someplace without wifi, and will need a bigger screen than my phone, I am forced to take my ipad (sigh). Anyone else having this issue?
    have you tried forgetting the device? (hold over the device in the WiFi settings and I believe it will let you disconnect then try and reconnecting.

    another thing I had to try when it wouldn't connect to my iPhone is connect just through Bluetooth (which to me was just as fast a connection) this way is annoying to connect to cause I had to forget the device and reconnect every time but at least it should connect. You have to connect to your phones Bluetooth in surface then go into devices in desktop mode and click on your phone and there will be an option to connect using hotspot..... hope that helps :s
  11. Zeroplanetz's Avatar
    Member

    Posts
    348 Posts
    #11  
    Hmmm interesting. I have the 920 and surface rt. No issues at all.
  12. nasellok's Avatar
    Member

    Posts
    226 Posts
    Global Posts
    242 Global Posts
       #12  
    Quote Originally Posted by pedenske View Post
    Im not sure about this but can you change the SSID of the wifi your phone is broadcasting. I remember seeing something about the how surface cant connect if the name has symbols or numbers or something like that. A bit of a long shot but hope this may help.
    The name is just AndroidApp - no numbers, spaces, etc. I tried forgetting, changing the password, changing the name, all no dice.

    I will try the Bluetooth thing, hopefully that works.
  13. jywang's Avatar
    Member

    Posts
    30 Posts
    Global Posts
    57 Global Posts
    #13  
    This is a known issue that is supposed to be addresses in this month's patches. There is a workaround that involves a registry key change that disabled the wifi mode that is broken.


    http://answers.microsoft.com/en-us/s...e4b35e?page=26
  14. fatclue_98's Avatar
    Member

    Posts
    1,789 Posts
    Global Posts
    1,905 Global Posts
    #14  
    Quote Originally Posted by nasellok View Post
    The name is just AndroidApp - no numbers, spaces, etc. I tried forgetting, changing the password, changing the name, all no dice.

    I will try the Bluetooth thing, hopefully that works.
    WP7/8 does not have bluetooth PAN. A major omission IMO. One of the many reasons I cannot keep a WP device as a primary phone. Before the flame wars begin, there's no reason that consumers can't have choices. Oh, I know, carriers want to limit your ability to tether, etc. My Moto ES400 has more functionality than just about any WP device out there, and it's a Windows Mobile 6.5 device!
  15. shn'g's Avatar
    Member

    Posts
    175 Posts
    Global Posts
    482 Global Posts
    #15  
    Quote Originally Posted by fatclue_98 View Post
    WP7/8 does not have bluetooth PAN. A major omission IMO. One of the many reasons I cannot keep a WP device as a primary phone. Before the flame wars begin, there's no reason that consumers can't have choices. Oh, I know, carriers want to limit your ability to tether, etc. My Moto ES400 has more functionality than just about any WP device out there, and it's a Windows Mobile 6.5 device!
    oh really? I keep up with tech pretty good but have had my iphone 4 for 2 years now so am getting out of what the features are with all the phones. I am more into tablets now anyways so don't really care what phone I have but the iphone started to get a little stale a year ago so I will be happy when I switch next year. That kind of sucks that it doesn't have Bluetooth mode. Do android devices have this feature like iphone?

    I guess one of the updates must have worked for me cause at the start I wasn't able to see the iphone then last week I tried and it recognized it so maybe with the newest update it will fix something. Here's hoping cause I know how frustrating it is.
  16. nasellok's Avatar
    Member

    Posts
    226 Posts
    Global Posts
    242 Global Posts
       #16  
    So - I installed all the updates last night - which were supposed to correct the limited connection in WIFI, and still no dice. I am starting to get frustrated with this thing, and might send it back to MS for a replacement. Does anyone know if replacement units MS sends are re-furbished?
  17. Narr's Avatar
    Member

    Posts
    239 Posts
    #17  
    No, they should be new units if they are replacing a faulty unit.
  18. Coreldan's Avatar
    Member

    Posts
    2,277 Posts
    Global Posts
    2,285 Global Posts
    #18  
    Just checking in, havnt had problems tethering from my 920 to the Surface.
  19. elvisff's Avatar
    Member

    Posts
    31 Posts
    #19  
    I would get a limited connection while tethering to my L920 (at&t). The current firmware update seems to have fixed my problem.
  20. Omnislash9998's Avatar
    Member

    Posts
    31 Posts
    #20  
    Refresh your surface then reinstall if refresh doesn't work. Will only have to reinstall everything anyway if Microsoft send a new one.
    Thanked by:
  21. nasellok's Avatar
    Member

    Posts
    226 Posts
    Global Posts
    242 Global Posts
       #21  
    Well, with the battery capacity issue (my surface has lost 25% of its capacity in less than 2 months, and in only 24 battery cycles) - I am opening an ticket with MS, an sending it back. When I get a new one will it know which Apps I had previously installed, similar to how google play on my android phone ? Plus, my laptop seems to be on its last leg, so I am thinking I might just sell the brand new one on ebay, and pick up the Thinkpad Helix - that thing is bad A$$.
  22. crav4speed's Avatar
    Member

    Posts
    347 Posts
    #22  
    Try deleting the profile using the command prompt:

    To see the wifi profiles you have ever connected to, open a command prompt and type:

    c://Users/"Your Name"/netsh wlan show profiles


    Now delete the profile that is giving you a problem:

    c://Users/"Your Name"/netsh wlan delete profile "Name of profile" (if there are spaces in the name of the profile you MUST use the quotation marks, otherwise you don't need them)


    Reconnect to wifi and see if it is still limited.
    Windows - Surface RT

    Windows Phone - Dell Venue Pro | Nokia Lumia 920 | Nokia Lumia 1520

    Windows Mobile - i-mate SP5 | HTC 8525 | HTC Touch HD

Similar Threads

  1. New to windows phone 7
    By ZombieZakk in forum HTC Surround
    Replies: 4
    Last Post: 12-26-2010, 06:07 PM

Posting Permissions