Page 4 of 4 FirstFirst 1234
Results 76 to 94 of 94
Like Tree2Likes
  1. kane4fire's Avatar
    Member

    Posts
    47 Posts
    #76  
    If you're looking to just add your media library, I wrote a write up a 2 days ago:
    How To add your MicroSD to a Windows Music, Picture, or Video Library

    It's pretty straight forward, and unless you're looking to make it into your primary for everything, this has worked great for me. Hope it helps.
    Last edited by kane4fire; 11-10-2012 at 04:46 AM.
  2. mattgrif's Avatar
    Member

    Posts
    37 Posts
    #77  
    Quote Originally Posted by nuprotocol View Post
    This is awesome! This fixed the indexing issue. Didn't think it would be that simple. Thanks a million! All changes are instantly reflected in the photos app now. No more rebuilding.... lol
    Glad to hear it helped you, that's exactly why I did it this way because the indexing was ticking me off with the Photos app.
  3. nuprotocol's Avatar
    Member

    Posts
    179 Posts
    Global Posts
    365 Global Posts
       #78  
    Quote Originally Posted by mattgrif View Post
    Glad to hear it helped you, that's exactly why I did it this way because the indexing was ticking me off with the Photos app.
    Yes it was getting on my nerves too. This was a simple fix. I'm also now following your blog. Thanks again. Now if we can just get an MKV player. lol
  4. dkp23's Avatar
    Member

    Posts
    1,390 Posts
    Global Posts
    1,400 Global Posts
    #79  
    Quote Originally Posted by kane4fire View Post
    If you're looking to just add your media library, I wrote a write up a 2 days ago:
    How To add your MicroSD to a Windows Music, Picture, or Video Library

    It's pretty straight forward, and unless you're looking to make it into your primary for everything, this has worked great for me. Hope it helps.
    THis seems to simple to be true compared to all the other ways people have said...

    HOpefully it works well, can you confirm that these issues dont exist with this method?

    -Music stopping after a few seconds the tablet goes to sleep
    -not recognizing new files

    Feedback appreciated.
  5. TeamRadicus's Avatar
    Member

    Posts
    6 Posts
    #80  
    Quote Originally Posted by mattgrif View Post
    Glad to hear it helped you, that's exactly why I did it this way because the indexing was ticking me off with the Photos app.
    Matt,

    Great method - works flawlessly! Thanks.

    Toni

    P.S. Add a couple of lines at the beginning of the post to enable unsigned PS scripts otherwise the auto-mount script will fail by default.
  6. kane4fire's Avatar
    Member

    Posts
    47 Posts
    #81  
    Quote Originally Posted by dkp23 View Post
    THis seems to simple to be true compared to all the other ways people have said...

    HOpefully it works well, can you confirm that these issues dont exist with this method?

    -Music stopping after a few seconds the tablet goes to sleep
    -not recognizing new files

    Feedback appreciated.
    I have been using this method for a few days now with no issues on my end. It plays the songs even when the screen sleeps (both time out and power button)

    The new files do propagate, but it seems to take a few minutes before it is added to the library. I am guessing it takes a while for it to search and find it. It also might just be due to my music library collection size.
    Last edited by kane4fire; 11-10-2012 at 04:34 AM.
  7. VidJuhEffex's Avatar
    Member

    Posts
    73 Posts
    #82  
    include quotes "mount-disk image" part or no? won't auto-mount on startup, maybe the other reply is onto it but low on details. What lines do we add to run unsigned scripts?
  8. weldon's Avatar
    Member

    Posts
    3 Posts
    Global Posts
    8 Global Posts
    #83  
    I initially did what Paul suggested and mounted my SD card, adding the folders to the library, etc.

    I copied the Xbox Music folders into the SD card, and everything was working fine -- but I noticed it had two 'copies' of each file (ie. Artist - Song.wma, Artist - Song (2).wma), so I deleted the entire directory of all the music.

    Now, songs cannot be downloaded, the option is not available. Additionally, any song I play that isn't in SmartDJ just plays 30 seconds!

    Does anyone else have this issue? It's super frustrating - I don't want to have to wait 30 days to delete the device and try again (if that's what's required)
  9. dkp23's Avatar
    Member

    Posts
    1,390 Posts
    Global Posts
    1,400 Global Posts
    #84  
    Quote Originally Posted by weldon View Post
    I initially did what Paul suggested and mounted my SD card, adding the folders to the library, etc.

    I copied the Xbox Music folders into the SD card, and everything was working fine -- but I noticed it had two 'copies' of each file (ie. Artist - Song.wma, Artist - Song (2).wma), so I deleted the entire directory of all the music.

    Now, songs cannot be downloaded, the option is not available. Additionally, any song I play that isn't in SmartDJ just plays 30 seconds!

    Does anyone else have this issue? It's super frustrating - I don't want to have to wait 30 days to delete the device and try again (if that's what's required)
    Pauls version didnt work so well for me, still had the new file not recognizing issue, but also had issues with the app not recognizing files although you see it in the libraries.

    Never had this issue you had though
  10. TeamRadicus's Avatar
    Member

    Posts
    6 Posts
    #85  
    Quote Originally Posted by VidJuhEffex View Post
    include quotes "mount-disk image" part or no? won't auto-mount on startup, maybe the other reply is onto it but low on details. What lines do we add to run unsigned scripts?
    • From the Start screen, flick up from the bottom and choose All Apps
    • Scroll all the way to the right and launch Command Prompt
    • On the task bar, 'right-click' Command Prompt and choose Run as Administrator
    • In the new Command Prompt window, type powershell [Enter]
    • Type set-executition policy unrestricted [Enter]

    The script should run now - reboot and see.

    And you don't need the quotes.

    HTH
    Toni
  11. weldon's Avatar
    Member

    Posts
    3 Posts
    Global Posts
    8 Global Posts
    #86  
    Quote Originally Posted by dkp23 View Post
    Pauls version didnt work so well for me, still had the new file not recognizing issue, but also had issues with the app not recognizing files although you see it in the libraries.

    Never had this issue you had though
    Mine probably still has the issue with new files- I did not know about this VHD method until earlier today, and I don't think I verified the initial SD card fix for more than a minute or so.
  12. weldon's Avatar
    Member

    Posts
    3 Posts
    Global Posts
    8 Global Posts
    #87  
    After being on phone with Microsoft support for 2 hours, (1 hour with the Xbox Music team, an hour with the Surface team) a Device 'refresh' fixed the issue I was having. Haven't seen if that's affected anything else yet.


    Have you all been able to use the VHD method and have it be the default save location?
  13. rOIVAz's Avatar
    Member

    Posts
    70 Posts
    #88  
    Quote Originally Posted by mattgrif View Post
    I had that same problem then I realized I could use a VHD. I wrote up a blog about how to do this with a VHD and enable indexing on the VHD.

    Configure Surface to use MicroSD as Primary Storage | Matt Blogs IT
    Hi Matt, thanks for this guide! I'm probably being stupid here but when I try to allocate space to the VHD it comes back with an error message saying it can't complete the operation due to a file system limitation. Does the SD card have to be empty, even if I'm only trying to allocate the GBs of available free space?
  14. VidJuhEffex's Avatar
    Member

    Posts
    73 Posts
    #89  
    Thanks! Although I went with the RemoteSigned policy rather than full unrestricted. Lets local scripts run unsigned but web scripts/etc still require signing.
  15. docbot's Avatar
    Member

    Posts
    15 Posts
    #90  
    Quote Originally Posted by rOIVAz View Post
    Hi Matt, thanks for this guide! I'm probably being stupid here but when I try to allocate space to the VHD it comes back with an error message saying it can't complete the operation due to a file system limitation. Does the SD card have to be empty, even if I'm only trying to allocate the GBs of available free space?
    You must format the sd card to NTFS not the default exFAT. Also I found that my vhd file extension was vhd not vhdx.

    Mark
    Thanked by:
    rOIVAz 
  16. rOIVAz's Avatar
    Member

    Posts
    70 Posts
    #91  
    Quote Originally Posted by docbot View Post
    You must format the sd card to NTFS not the default exFAT. Also I found that my vhd file extension was vhd not vhdx.
    Thanks - I knew it would be something obvious! I'll give this a go tonight.
  17. mattrees's Avatar
    Member

    Posts
    17 Posts
    #92  
    This worked really well for me when I first did it but for some reason now when I open my pictures app all I see are the file names but no images.

    If I go back to file explorer in the desktop they are all there in the VHD I created and if I double click on a picture there it takes me back into the pictures app and displays the picture correctly.

    Any ideas as to what's happening?
  18. yaoye78's Avatar
    Member

    Posts
    14 Posts
    Global Posts
    40 Global Posts
    #93  
    For people still having some sort of problems, you might want to try following:
    1) Go to index options, check if all the locations that you need are included
    2) Go to index options -> advanced to rebuild indexes

    Worked for me...
    Thanked by:
  19. mattrees's Avatar
    Member

    Posts
    17 Posts
    #94  
    Quote Originally Posted by yaoye78 View Post
    For people still having some sort of problems, you might want to try following:
    1) Go to index options, check if all the locations that you need are included
    2) Go to index options -> advanced to rebuild indexes

    Worked for me...
    thanks yaoye78 - that really helped. I still have a few 'blank' folders and images in the pictures app but it's soooo much better than it was before (+ I noticed that the issue was affecting my music as well which wasn't being recognised - and re-indexing seems to have fixed that too).
Page 4 of 4 FirstFirst 1234

Posting Permissions

B