Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 16 of 16
  1. graigsmith's Avatar
    Member

    Posts
    51 Posts
    Global Posts
    64 Global Posts
       #1  
    ok so like the title says. the windows phone sync app on my mac, crashes over and over.

    i can launch the app. but then when i plug the phone it, it crashes.

    every single time.

    it was working fine till i did a factory reset on my phone.

    also internet sharing is not working for me... could the whole issue be the phone?

    does anyone know where the windows phone sync app for mac stores it's data? heck if you know where the windows phone sync app stores its data on windows that would probably help.
  2. #2  
    i had this same problem. delete your itunes xml file and try again. worked for me!
  3. graigsmith's Avatar
    Member

    Posts
    51 Posts
    Global Posts
    64 Global Posts
       #3  
    where is that file?
  4. graigsmith's Avatar
    Member

    Posts
    51 Posts
    Global Posts
    64 Global Posts
       #4  
    ok. so i found itunes.xml in the music folder. deleting it diddn't help. still crashes.
  5. jfo7404's Avatar
    Member

    Posts
    15 Posts
    Global Posts
    30 Global Posts
    #5  
    I had same problem. I tried deleting the .xml file which didn't work for me either. I tried to uninstall and reinstall the app and still received the force closes. I then uninstalled the app, rebooted and then reinstalled the app and that combination worked for me.
  6. teo155's Avatar
    Member

    Posts
    52 Posts
    #6  
    I didn't work for me! I'm so upset :((
  7. inffy's Avatar
    Member

    Posts
    31 Posts
    Global Posts
    272 Global Posts
    #7  
    Had the same problem, I found a fix (atleast this worked for me) from Microsofts community page:

    Hi all. We are actively working on a fix for this issue.


    If you want to turn off the "sync automatically" setting, you can do it outside the app, no need for quick reflexes/slow computer:


    - In Finder, pres cmd-shift-G
    - Type the following path into the dialog: ~/Library/Containers/com.microsoft.Windows-Phone-7-Connector/Data/Library/Application Support/Windows Phone/Devices
    - You should see a single folder with a bunch of characters representing your phone, open that folder
    - Edit the file named "Sync Configuration.xml"
    - Change the value after Setting/Sync On Connect from <integer>1</integer> to <integer>0</integer>

    I can't guarantee this will fix the crash in all cases, but as several people have reported it helps them, I thought I'd pass along this info.
  8. teo155's Avatar
    Member

    Posts
    52 Posts
    #8  
    Quote Originally Posted by inffy View Post
    Had the same problem, I found a fix (atleast this worked for me) from Microsofts community page:

    Hi all. We are actively working on a fix for this issue.


    If you want to turn off the "sync automatically" setting, you can do it outside the app, no need for quick reflexes/slow computer:


    - In Finder, pres cmd-shift-G
    - Type the following path into the dialog: ~/Library/Containers/com.microsoft.Windows-Phone-7-Connector/Data/Library/Application Support/Windows Phone/Devices
    - You should see a single folder with a bunch of characters representing your phone, open that folder
    - Edit the file named "Sync Configuration.xml"
    - Change the value after Setting/Sync On Connect from <integer>1</integer> to <integer>0</integer>

    I can't guarantee this will fix the crash in all cases, but as several people have reported it helps them, I thought I'd pass along this info.
    Mine was already "<integer>0</integer>", so i tried to change it to 1, but nothing changed.
    Thank you anyway, i'll check that xml file looking for other things may be helpful.
  9. teo155's Avatar
    Member

    Posts
    52 Posts
    #9  
    I finally solved my problem in this way:
    - removing the WP app with AppCleaner (for Mac)
    - removing manually the folder com.microsoft.Windows-Phone-7-Connector (which was in ~/Library/Containers/)
    - reinstalling WP app from the app store

    I think this should work for everyone; thanks for the help!
  10. Ru Das's Avatar
    Member

    Posts
    1 Posts
    #10  
    After going crazy with the WP app crashing on my macbook pro, I tried the above method, and it worked!!!!

    Thank you so much!!
  11. bowendesign's Avatar
    Member

    Posts
    1 Posts
    #11  
    This is driving me nuts... can't figure it out. Thanks for the above though, but where's this containers folder? I can't find it to be able to try that solution...

    edit; nvm, found it!

    edit 2; aaaand NO JOY. This is rubbish. Gah.
  12. Crisdean's Avatar
    Member

    Posts
    7 Posts
    Global Posts
    720 Global Posts
    #12  
    I was hoping you had an answer :( Just wondering. Would a virtual machine work with cross drag and drop? Like Parallels or so? Maybe that could help.
  13. Cpfoxhunt's Avatar
    Member

    Posts
    31 Posts
    #13  
    Just in case anyone is googling this, I found that deleting the files here worked (although you then have to re sync in full) - ~/Library/Containers/com.microsoft.Windows-Phone-7-Connector/Data/Library/Application Support/Windows Phone/Devices
  14. jdhooghe's Avatar
    Member

    Posts
    504 Posts
    Global Posts
    1,827 Global Posts
    #14  
    I can't find containers. I'm using mountain lion
  15. Cpfoxhunt's Avatar
    Member

    Posts
    31 Posts
    #15  
    Press cmd+shift+g in finder and try typing it in?
  16. #16  
    Open up a finder window, any window. Click and hold onto the Option key on your keyboard. Then go to the Go Menu and you'll see Library on the file list.

Similar Threads

  1. Windows Phone app crashes when syncing
    By dacarter77 in forum Windows Phone 8
    Replies: 14
    Last Post: 10-23-2013, 01:54 PM
  2. Sync app for mac?
    By mmoon24 in forum Mac OS X
    Replies: 16
    Last Post: 12-23-2012, 07:13 PM
  3. Tellme opening automatically over and over
    By Kdawg1989 in forum Nokia Lumia 900
    Replies: 0
    Last Post: 05-12-2012, 12:17 PM
  4. Replies: 3
    Last Post: 11-27-2011, 06:38 AM

Posting Permissions