Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. ralph8811's Avatar
    Member

    Posts
    1 Posts
       #1  
    Hi,
    I have an HTC HD7 and I'm unable to connect to the internet when I have wi-fi and cellular data turned on. I can't get tile updates, surf internet explorer, use chat, etc. However, if I turn off cellular data and leave wi-fi on I can use the internet and get updates. Same thing if cellular data was turned on and wi-fi was off then I can get internet and updates.

    I've tried turning my phone on and off and taking out the battery and such. The only thing I haven't tried is restoring my phone to factory condition and wiping out all my pics/music/data/etc. I've also tried restarting my router (turning it off/unplugging/etc) and that still doesn't work. Everyone in my house that uses an iphone 4/4s or android phone has no problem going online with cellular and wi-fi enabled at the same time.

    Do you guys have any suggestions that could fix it besides restoring to factory condition?
  2. vinser's Avatar
    Member

    Posts
    1 Posts
    #2  
    Quote Originally Posted by ralph8811 View Post
    Hi,
    I have an HTC HD7 and I'm unable to connect to the internet when I have wi-fi and cellular data turned on. I can't get tile updates, surf internet explorer, use chat, etc. However, if I turn off cellular data and leave wi-fi on I can use the internet and get updates. Same thing if cellular data was turned on and wi-fi was off then I can get internet and updates.
    I have the same thing when WiFi is available. But when it is not, all works fine.
    So I had to turn off cellular, when there is WiFi and use MS special app, which i've pinned on main screen
  3. awesumjon's Avatar
    Member

    Posts
    125 Posts
    Global Posts
    130 Global Posts
    #3  
    Same here too. It bothers the heck out of me. I have no idea why this hasn't been fixed. It's been like this for me ever since I got this phone (NoDo). It's like it's connected to the network but can't get any data until I turn off the cell data.

    I don't even think a factory reset would fix it. I had to master reset my phone once and that didn't change.

    Just curios, but is only when it's connected to WiFi or when the WiFi is on. Mine is when it's connected.

    Sent from my HD7 using Board Express
  4. #4  
    I have a HTC HD7 T-mobile.I would like to setup internet setting to the phone.In vain no use When I connected the internet simply it was turned off within seconds always the WI-FI is available but no use to access the net.I would like to know to rectify the problem

Posting Permissions