Results 1 to 6 of 6
  1. z3th's Avatar
    Member

    Posts
    1 Posts
       #1  
    I've been reading some threads here and saw that there's a couple of us who are using Verizon's 8X on T-Mobile's network in the US, because black is that awesome of a color and we like wireless charging. Some of you may be having problems fully using the phone on this network, so I'll be offering some hopefully useful information for you guys based on my own, empirical observations using this phone. Your results may vary, but I hope this will be helpful.

    If you are using a prepaid plan, you may find that not all of your text messages are going through to your recipients, but can receive all of them yourself. I am on T-Mobile's $30/month plan for 100 minutes, unlimited text and 5GB of data, and basically none of my text messages go through to a majority of recipients. My contacts are sync'd from Google.

    I've determined that such messages don't go through to numbers that have a + and the country code prefixed to it, like +12345678901 in the case of the US. I think it's because such prepaid plans don't have the international calling and texting package with them, so I'm guessing the network sees the + number as an attempt to message internationally and therefore blocks it. I've found that reworking all your numbers to not have the + prefix solves the issue.

    However, you may find that replying to messages sent to you from your contacts don't go through either. For some reason, the OS prefixes the incoming number with a +, despite the contact information having specified otherwise, when you receive a message. The workaround for this is to start a new message to your contact instead of visiting the existing thread and replying there. The new message, once sent, will be added to the existing thread so you won't have 346656734 separate threads for the same contact. Afterwards, you can continue texting in the existing thread until your contact replies, after which you have to reply back in a new message thread again otherwise it won't get delivered.

    These workarounds do the job for me, and I'm able to receive and send all texts. It's a temporary solution until this problem gets fixed. Again, this information is all based on my empirical observations and testing, and the real problem may be something completely different, so please do not take this information as 100% true. However, if it works for you, then I am glad.

    I've still yet to futz with MMS, as I've yet to send an MMS of my own (I hardly ever do...), but can receive MMS. I will assume the problem is similar in nature, but I've yet to confirm this and will have to test accordingly.

    I'm not sure who can fix this problem -- whether it's T-Mobile, Verizon, HTC, or Microsoft itself -- so if you do further testing to validate/invalidate my claims, I'll leave it to you guys to contact these people to see if we can get a fix so we don't have to use this silly little workaround. Although I'm afraid we are in a very gray zone as we are using a phone on a network it wasn't made for.

    Hope this helps; feel free to ask me any questions and/or add your two cents here. :]
  2. cornplex's Avatar
    Member

    Posts
    2 Posts
    #2  
    I have this exact same problem! thanks for the workaround tips! what I can't figure out is if it's a network problem or a software problem. I've called both tmobile and htc and all they do is refer me back to each other. since you posted this around 2 months ago, I was wondering if you're still doing with these workarounds or if you've found an easier solution to the problem since then?
  3. Godo Tan's Avatar
    Member

    Posts
    3 Posts
    #3  
    Portico update didnt fix the issue, grrr
  4. cornplex's Avatar
    Member

    Posts
    2 Posts
    #4  
    I've found the solution to this problem already actually, after tinkering around with phone settings. go to settings>phone and just turn off international assist. I believe that is what's responsible for automatically putting the +1 on the area codes.
  5. Godo Tan's Avatar
    Member

    Posts
    3 Posts
    #5  
    before the update even I turn off the international assist it still doesn't work but I guess the issue is now fix. thanks men :D
  6. elitelibra's Avatar
    Member

    Posts
    3 Posts
    #6  
    i was having the same issue with texting with my unlocked Verizon HTC 8x phone on tmobile for texting. however going to phone settings and unchecking the auto international assist it will allow you to send messages normally and receive them. However i will have to research the mms because its not working on anything i tried. because tmobile has added the mms settings automatically into the sim card its no way to change it through the phone.

Similar Threads

  1. MMS on T-Mobile?
    By drewsuruncle in forum Samsung Focus S 4G
    Replies: 56
    Last Post: 09-04-2013, 02:32 AM
  2. HTC 8X Verizon on T-Mobile
    By TechyMexican in forum HTC 8X
    Replies: 6
    Last Post: 01-07-2013, 11:29 PM
  3. Replies: 4
    Last Post: 11-23-2012, 10:32 PM
  4. 8X on Three - MMS Settings
    By benryder in forum HTC 8X
    Replies: 1
    Last Post: 11-14-2012, 06:26 AM
  5. HTC 8X is going to have some serious competition on T-mobile.
    By Winterfang in forum Upcoming & Rumored Devices
    Replies: 9
    Last Post: 09-28-2012, 03:05 AM

Posting Permissions

B