Welcome to the WPCentral Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 33
Like Tree4Likes
  1.    #1  
    Hi all,
    Against everyone's advice I bought the htc 8X from a foreign country. This just means that i will have to go back to that country if i needed to claim my warranty.
    The phone works great. Everything's awesome. But i just haven't been able to get my data connection to work. I've used a lot of phones,the HTC one X, galaxy note, galaxy S2,Xperia play, the HTC desire and I've never had problems with seting up the data connection. Since this is my 1st windows phone,I was struggling with it though I used the "connection setup" on the phone. So I took it to the vodafone office. I thought it might have something to do with the service provider. They checked the settings and said it was all okay. I can't entirely trust their knowledge/skills because I live in a small village and it is a new vodafone office with very inexperienced staff.
    I searched all over the net and I only found threads about users losing 3G connection after long periods of inactivity and other related issues.
    I, however haven't even seen the little 3G symbol in the notification bar on top. It has never worked so far.
    I can't take it back to teh place where i bought it from because its 3000 miles away :/
    Please help
  2. #2  
    On mine its an "H" symbol, HSDPA. Never had the 3G symbol, but H is the same thing
  3. adroit9's Avatar
    Member

    Posts
    15 Posts
    #3  
    So you bought the 8X (unlocked/sim-free, I presume), and you get service with your Vodafone SIM card, but not data? When you go to Settings>Cellular (mobile network/whichever it's called on yours), does it say you're connected to a network? Is Data switched on?
  4.    #4  
    @willybraatlund
    yea, i haven't had the HSDPA symbol either. I've had nothing.
  5.    #5  
    @adroit9 yep, its unlocked/sim free and i get service from a vodafone sim card i've had for about 8 years now. And yep I am connected to a network in my settings, data is switched on. I can make calls,sms's everything. Am all over the internet with wifi. Every part of the phone works great except for the data connection
  6. adroit9's Avatar
    Member

    Posts
    15 Posts
    #6  
    Okay, then perhaps you need to add an Internet APN. If you look online (Google search), you should be able to find your carrier's APN settings. If you can't find it online, then call your provider and ask a support rep or whatever. Once you locate the info, go to Settings>Mobile Network (if there's no "Access Points" in the Settings list itself (if there is, click on that, then "add" at the bottom)), and click on "Add Internet APN". Enter the Vodafone APN settings, and save the APN.

    Hope this helps.
    Thanked by:
  7.    #7  
    Thanks adriot9, that surely helps, but that is why i took it to the vodafone office and they supposedly filled in the APN settings. Anyway, like I said before they might have done it wrong. I'll google it and try and re-do it myself. i didn't want to mess with their settings, but now I think I'll give it a shot. Will let you know the outcome. thanks again.
  8.    #8  
    I just googled the APN settings for my country and the vodafone staff had apparently done it right when i took it to their office yesterday. So now i'm back to square one. Looks like its a problem with the phone. I'm just not ready to accept it though :/
  9.    #9  
    ok, thats it, i'm done. I managed to speak to vodafone customer care and they even escalated the matter to higher personnel and they walked me through the settings and again i had had eth correct settings all along. So now it is pretty much confirmed that its a hardware issue with my 8X. I have never been this disappointed. None of my gadgets have ever failed except for one of my PS3s. This is horrible. I can't even claim the warranty on it.
    My baby's just 4 days old :/
    Lesson learnt: Never ever buy gadgets from a foreign country with no international warranty.
  10. adroit9's Avatar
    Member

    Posts
    15 Posts
    #10  
    More likely the phone doesn't support the network bands your carrier uses, than a hardware default. It's that, or perhaps it's not completely unlocked.

    Sorry I couldn't help!
  11. MichaNL's Avatar
    Member

    Posts
    1 Posts
    #11  
    Have you tried switching roaming on to see if this helps?
    Sent from my Windows 8 device using Board Express Pro
    Thanked by:
  12.    #12  
    yes michaNL, i tried that too. Still didn't make a difference :/
  13.    #13  
    @adroit9 It supports the network bands my carrier uses. I checked. And like i said,I've used a whole range of phones with this very same sim card. Anyway, thanks so much for your time. I must be really missing out on some small setting. I just hope i figure it out. Will let you know if i find out. Thanks again for trying to help
  14. Chregu's Avatar
    Member

    Posts
    7,209 Posts
    #14  
    I don't really know if this a stupid question and of any help, but have you installed "Connection Setup" and set your carrier?
  15.    #15  
    @adroit9 i just called up the shop where i bought it from in Singapore and I told him my problem and asked him if he's sure the phone is completely unlocked. He got offended and said ofcourse it is unlocked and that it is illegal to lock a phone in Singapore. So that has been cleared up too now.
  16.    #16  
    @chregu Yep i tried connecting with the "connection setup" . No luck though
  17. martan1981#WN's Avatar
    Member

    Posts
    47 Posts
    Global Posts
    71 Global Posts
    #17  
    Have you tried switching to 2G only if you get at least E symbol? If there is a problem with 3G antennas, you still should be able to get data over edge.
    Sent from my Windows Phone 8X by HTC using Board Express
  18.    #18  
    @martan1981 yep, i tried switching to 3G as the highest connection. Still nothing on the notification bar, Haven't seen the E or H or 3G symbol so far.
    Just one thing.There is this IPV4, IPV6 AND IPV4V6 options right at the bottom of the APN settings... Any idea what that is for? vodafone told me default setting is IPV4.
    Meanwhile, as I type, i'm hard resetting my phone with the factory reset option. Hoping that will change things.
  19.    #19  
    okay, so hard resetting didn't make a difference either
  20. dol4er's Avatar
    Member

    Posts
    82 Posts
    Global Posts
    91 Global Posts
    #20  
    I guess, you have updated the phone to the latest version of the software and firmware. But if you haven't, you'd better try it - it may help...
  21. #21  
    Did you set it into 3G under carrier ? Because if it is in 2G it will not go to 3G...
    It can also be the SIM card, I would try a different SIM card in my phone to see if it picks up 3G once you set it to pick up 3G.
    Read my "8X battery tips and tricks" here on the 8X forum. You will find loads of information on settings.

    Set phone to English.
    Next: Go to Settings / Mobile Network

    Is Data Connection set to ON?

    Is Data roaming ON or OFF? You might need to roam where you are... try it.

    What is the Highest connection speed setting? 2G or 3G


    Then last, go to Network selection, Open it. You will get searching for Networks
    Then it will display a list of Networks, in there you might find your Network twice, as simple GSM or with Data.
    Check it out. Try if you have more than one choice.

    Also, after you insert the SIM, you must setup the phone using the "Connection Setup" app that comes from HTC. Then after you did that, switch the phone off and then on again. Do that first!

    Under APN make sure you try phone ipV4 and ipV4 and ipV6.

    Then send me a message if you have questions.
    Last edited by Coolknight1968; 12-26-2012 at 05:08 AM.
    *** Forza Windows Phone 8 ***
    Many answers here in my battery tips & tricks post: http://forums.wpcentral.com/htc-8x/2...ps-htc-8x.html
    Please help me with my WP8 Sync App idea called "WP8 ClonePhone": http://forums.wpcentral.com/windows-...lonephone.html
  22.    #22  
    yep i updated it to the latest version. there were ni updates available after that
  23.    #23  
    Quote Originally Posted by Coolknight1968 View Post
    Did you set it into 3G under carrier ? Because if it is in 2G it will not go to 3G...
    It can also be the SIM card, I would try a different SIM card in my phone to see if it picks up 3G once you set it to pick up 3G.
    Read my "8X battery tips and tricks" here on the 8X forum. You will find loads of information on settings.

    Set phone to English.
    Next: Go to Settings / Mobile Network

    Is Data Connection set to ON?

    Is Data roaming ON or OFF? You might need to roam where you are... try it.

    What is the Highest connection speed setting? 2G or 3G


    Then last, go to Network selection, Open it. You will get searching for Networks
    Then it will display a list of Networks, in there you might find your Network twice, as simple GSM or with Data.
    Check it out. Try if you have more than one choice.

    Also, after you insert the SIM, you must setup the phone using the "Connection Setup" app that comes from HTC. Then after you did that, switch the phone off and then on again. Do that first!

    Under APN make sure you try phone ipV4 and ipV4 and ipV6.

    Then send me a message if you have questions.
    hi coolknight, i tried everything you have listed above.

    I tried another sim card and the 3G still didn't work.
    I tried my current sim card into my older HTC on X and it worked.
    I used the HTC connection setup app.
    Still nothing.
    Vodafone has told me all about the APN settings.
    The only thing they didn't know about was IPV4 and IPV6
    Anyway i tried both of them too.
    Not sure if it is possible to attach a vide here.
    But i'll record a video of what i'm doing on my phone with the settings.
    Thanks a lot coolknight
  24. X0LARIUM's Avatar
    Member

    Posts
    1,584 Posts
    Global Posts
    1,686 Global Posts
    #24  
    The bands on your international device and the ones used by Vodafone 3G is different.
    You from India?

    Sent from my RaZr on MIUI.
    Thanked by:
  25.    #25  
    yes i'm from India. Tell me more. This is what i expected too. But I bought the device from Singapore which uses GSM900/1800 for 2G
    and India uses the same. Both use 2100mhz for 3G. I'm not really sure though. Google results says it uses the same bands. Is there any way I can check what bands my handphone is capable of handling?
    I couldn't find anything on the box.
    Last edited by rohan fernandez; 12-27-2012 at 03:18 PM.
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 42
    Last Post: 05-11-2012, 12:56 AM
  2. Been using an iphone the last few days and it is making me nuts
    By baseballbert in forum Other OS's and Devices
    Replies: 7
    Last Post: 12-07-2011, 03:13 PM
  3. Remove time, day and date from lock-screen?
    By YIP YOO in forum Windows Phone 7
    Replies: 1
    Last Post: 08-22-2011, 08:44 PM
  4. OK, WP7 and Verizon, a marriage is on the line here...
    By Umm Yeah... in forum HTC Trophy
    Replies: 5
    Last Post: 08-02-2011, 02:05 AM

Posting Permissions